1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.9 tdi going limp after 100mph

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by munchman s3, Mar 19, 2009.

  1. munchman s3

    munchman s3 Gas it

    Joined:
    Mar 7, 2009
    Messages:
    50
    Likes Received:
    0
    my mates A4 is going into limp mode as soon as he's hitting 100mph and even sometimes when just fast accelerating any ideas what this problem could be??????:greyrs4::uhm:
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Rocko

    Rocko A5 TSFI

    Joined:
    Apr 24, 2007
    Messages:
    534
    Likes Received:
    0
    Mines doing something similar. Going to my audi mechanic mate at the weekend for a severe service and a diagnosis so Ill let you know what he finds out.

    He thinks blocked EGR valve, collapsed pipe somewhere or eeegads, the turbo is in trouble but he wouldnt commit to anything until the spanners come out.
     
  4. BahnStormer77

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,646
    Likes Received:
    21
    bad remap?

    exhaust gasses overheating if he's been nailing it a few times in a row... safety will kick in so you don't shag the engine?

    Which 1.9TDi - they come in all flavours... from 90bhp to 150bhp!
     
  5. munchman s3

    munchman s3 Gas it

    Joined:
    Mar 7, 2009
    Messages:
    50
    Likes Received:
    0
    it aint been remmapped an its the 150 model, theres no warning lights and when the engine is switched off and on agen its fine. But when in limp mode sometimes it sounds like the air filter has been removed, deep noise
     
  6. quattrojames

    quattrojames Moderator
    Staff Member Moderator Audi A6

    Joined:
    Mar 28, 2008
    Messages:
    13,993
    Likes Received:
    522
    Did they do a B6 1.9tdi 150?
     
  7. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    726
    Likes Received:
    1
    Have a look here http://forums.tdiclub.com/showthread.php?t=179589

    Keep us updated on your progress, I'm sure it will help others - me included, I'm trying to work my way through the list, but I'm remapped, so that's where I started but still having issues :bye:
     
  8. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    726
    Likes Received:
    1
  9. Rocko

    Rocko A5 TSFI

    Joined:
    Apr 24, 2007
    Messages:
    534
    Likes Received:
    0
    He couldnt do it. Im awaiting a call from him for this week!
     
  10. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    726
    Likes Received:
    1
    Fingers crossed he'll be able to right it for you soon mate.
     
  11. Rocko

    Rocko A5 TSFI

    Joined:
    Apr 24, 2007
    Messages:
    534
    Likes Received:
    0
    Saturday is the day. Magic Matt will hopefully sort this problem out easily, quickly and cheaply and not say the words "turbo" and "buggered".
     
  12. BahnStormer77

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,646
    Likes Received:
    21

    Not they didn't... 130bhp... but those are good for 160bp on a remap...
     
  13. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    726
    Likes Received:
    1
    Any news mate?
     
  14. Rocko

    Rocko A5 TSFI

    Joined:
    Apr 24, 2007
    Messages:
    534
    Likes Received:
    0
    Yep. He replaced all the vacuum hoses and sorted a few fault codes and replaced the MAF sensor.

    Runs like a dream now, although my mapping guy checked the map on the car and its running twice the boost required! So that'll be getting tweaked.
     
  15. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    726
    Likes Received:
    1
    Phew, pleased it got sorted mate and wasn't anything too severe.

    I've replaced most of the rope covered hoses now, still no luck though. Also have a pretty leaky EGR which surely can't help things.

    I've now read things about boost creep at higher revs under higher load - something to do with the small turbo not being able to cope with the exhaust gases due to the extra fueling. All new to me like, but something to bear in mind I suppose.

    Have you managed to keep it on full throttle in the higher gear for over 10 seconds? Aparently this is the point of boost creep, if it's going to happen.

    Out of interest, do you know what boost level requested and actual you have right now? And what power and torque figures are you at?
     
  16. Rocko

    Rocko A5 TSFI

    Joined:
    Apr 24, 2007
    Messages:
    534
    Likes Received:
    0
    No not yet, not after being worked on.

    Remap should be 180bhp/310lbs ft but I cant confirm that now.
     

Share This Page