1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.9 low fuel consumption

Discussion in 'Diesel forum' started by Staz, Dec 30, 2006.

  1. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Dec 30, 2006]
    got a problem with low fuel consumption on a 1.9tdi 130

    Steadily the economy has been getting worse. Today we completed a 100km test and worked out we were getting 36mpg. It's been getting worse and worse.

    The garage says they can't find anything wrong. A so called expert says it's burning fine. Does anyone have any tips? It's done 55000 miles total btw
    #1
  2. Ads

    Ads

    [Oct 25, 2014]

  3. SteveS
    Offline

    SteveS S6 avant

    Joined:
    Oct 26, 2006
    Messages:
    691
    Likes Received:
    0
    [Dec 30, 2006]
    i think the maf is a source of trouble on audis. my last tdi was much better after i changed it. you can get them tested i think.
    #2
  4. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Dec 30, 2006]
    mass air filter?? at a guess
    #3
  5. Darthvader
    Offline

    Darthvader "The Darkside"

    Joined:
    Dec 30, 2006
    Messages:
    153
    Likes Received:
    0
    [Dec 31, 2006]
    Yep, i'm going with the MAF and it wont show a fault until it actually goes...

    I would replace it asap buddy, as a faulty MAF can lead to several problems and they all end up costing a pretty penny.
    #4
  6. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Dec 31, 2006]
    I should be able to se if it's full of **** myself shouldn't I?
    #5
  7. Darthvader
    Offline

    Darthvader "The Darkside"

    Joined:
    Dec 30, 2006
    Messages:
    153
    Likes Received:
    0
    [Dec 31, 2006]
    yep you can give it a good clean out, but you really need to replace this buddy...
    #6
  8. SteveS
    Offline

    SteveS S6 avant

    Joined:
    Oct 26, 2006
    Messages:
    691
    Likes Received:
    0
    [Dec 31, 2006]
    they are about £75. my tdi had little mid range pull and was only doing about 30mpg, with a new maf it was much faster (2000 b5,115bhp) and did 50+mpg on a run - 40+ in town.
    #7
  9. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Jan 1, 2007]
    thing is we've had no loss of power whatsoever so we're not sure it's the maf
    #8
  10. mas
    Offline

    mas Member

    Joined:
    Jul 31, 2005
    Messages:
    132
    Likes Received:
    0
    [Jan 2, 2007]
    temp sensor ?
    injection timing ?

    mafs are a pain though 0 and you wont necessarily get performance probs.
    #9
  11. vw754
    Offline

    vw754 vorsprung Durch Technik

    Joined:
    Nov 4, 2006
    Messages:
    2,041
    Likes Received:
    30
    [Jan 2, 2007]
    Replace temp sensor! i did on a friend vw passat tdi,now its brill on fuel,it sends the wrong in fo to the ecu,tells it engines still not hot enuf so ecu keeps fuelling more,common fault 22 quid and easy to fit
    #10
  12. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Jan 2, 2007]
    yeah but the temp guage will show it's not hot too
    #11
  13. vw754
    Offline

    vw754 vorsprung Durch Technik

    Joined:
    Nov 4, 2006
    Messages:
    2,041
    Likes Received:
    30
    [Jan 2, 2007]
    no mate it wont,this sensor has 2 wires that go behind the dash clocks,and 2 to the ecu,it will never show on a temp gauge inside the car never! ive done 3 so far and all owners happy,these are very common faults. whats 22 quid? try if u want gud results,infact ask on the forum shall i change my temp sensor as they are prone to playing up,you'll get yes more times than a no!
    when you do a diagnostic check it wont show up untill its near to death! so dont try that way,took mine off last week and binned it!
    #12
  14. Staz
    Offline

    Staz is a retronaut Staff Member Moderator VCDS Map User

    Joined:
    Oct 26, 2006
    Messages:
    6,195
    Likes Received:
    47
    [Jan 3, 2007]
    wher exactly is the temp sensor? Got any pics?
    #13
  15. vw754
    Offline

    vw754 vorsprung Durch Technik

    Joined:
    Nov 4, 2006
    Messages:
    2,041
    Likes Received:
    30
    [Jan 4, 2007]
    G62 Coolant Temperature Sender - Replacement guide
    Just did this job today and found some better ways to do it, over what I've read on some Audi sites so thought I'd publish my own guide.


    The G62 temperature sensor is a fairly common component to go on the Audi A4, typically this can be diagnosed via vag-com codes such as 17664.

    Tools required

    Socket set
    Small flat headed screwdriver
    Pliers

    Parts needed

    Some G12 coolant - You can get this from eurocarparts or GSF car parts, 1 1/2 litre for about 5 quid
    Some distilled water - You can get this most places, even supermarkets sell it now

    Audi parts

    A check of the sensor before ordering the parts (a torch is handy) revealed the sensor casing was black (this has been superseeded by a green sensor for which the part number is listed below). On some VAG cars, a blue temperature sensor is installed and this has a separate part number 078 919 501B).

    1 x 059 919 501 A - Dual temperature sender
    2 x 032 121 142 - Retaining Spring
    1 x 903 168 02 N - Round seal

    I got these parts from Vagparts for about £20 delivered. I would suggest you order 2 retaining springs. They are plastic clips and you can easily drop them, best to have one extra on hand just in case.


    Before you start, make sure the engine is cool. Do not do this on a warm car. It is best if you leave the car overnight to fully cool down first.

    (Optional) You may want to remove the plastic engine shield so that any coolant lost during this process falls onto the ground (or suitably positioned tray). I decided instead to leave the engine shield in place and flush the leaked coolant with a watering can. I managed to capture most of the lost coolant for safe disposal. Animals are attracted to the coolant due to it's sweet smell, so it is best to ensure your driveway is flushed of any leaked coolant when finishing this job.

    Start by removing the engine cover. Pop off the three caps with a small screwdriver and unscrew the bolts. Lift off the oil dipstick and remove the engine cover, replace dipstick.

    In order to make sure all pressure is relieved in the coolant system, remove the cap from the coolant reservoir.


    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62Location.jpg" border=0>


    The G62 sensor is positioned at the back left hand side of the engine, as shown with the red arrow in the picture above.

    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62Location1.jpg" border=0>

    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62Location2.jpg" border=0>

    You can see the wiring harness going into the temperature sender in the two pictures above.



    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62ItemsToRemove.jpg" border=0>

    It is best to remove the main air hose to get better access to the sensor.

    In the picture above I removed a small bolt holding the air hose in place (the location of this bolt is numbered 4), I then disconnected the sensor from the air hose (numbered 3). I then proceeded to remove the small section of air hose to get better access to the sensor (clips arrowed 1 and 2 above).

    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62ItemsToRemove2.jpg" border=0>

    A close up of the air hose section we want to remove is shown above. I removed clip numbered 1 above followed by clip numbered 2 above and removed that small section of hose.

    Alot of Audi forums on the Internet recommended removing the wire harness from the sensor first, but I found this impossible and after 30 minutes of swearing, I decided to remove the entire sensor with the wiring harness attached.

    To do this you should first have your new sensor to hand, you should mount the rubber seal on the metal part of the sensor ready for a quick swap over. You should also have your retaining clip to hand.

    I found it best to have a very small screwdriver on hand, to pull the retaining clip off. The clip is positioned underneath the sensor and is removed by pulling straight down on the clip.

    At this point I removed the sensor and I started losing coolant. A quick feel in the exposed hole for the old rubber seal and I was ready to push the new sensor in. I found at this point that the new sensor held in the hole without the retaining spring, so I went ahead and removed the wire harness from the old sensor and attached it to the new sensor.

    Now you have the fun of trying to push the new retaining clip in to hold the sensor in place.

    The clip is pushed in from the bottom, underneath the sensor, a few moments feeling around and I got it in place in about 5 minutes, the first few attempts were a bit of a pain, but I quickly got it in.

    Now you need to put your air hose back together. This was a bit tricky, but I found it best to attach clip numbered 1 followed by 2 in the picture below. I then reattached the sensor unclipped from the air hose and bolted the air hose back down that was previously removed.

    <IMG title="Click for larger image" style="WIDTH: 560px; ; WIDTH: expression(this.width > 730 ? 560 : true)" alt="Click for larger image" src="http://i15.photobucket.com/albums/a353/NeilScarrott/G62ItemsToRemove2.jpg" border=0>

    Now your new sensor is in place and you need to top up the coolant reservoir. If you have been quick you shouldn't have lost too much coolant.

    I lost about a litre and topped the coolant reservoir up with 50/50 coolant/distilled water. When I topped up I turned the car on and put the heating on High and opened all the vents. I then found the coolant needed topping up again. Ensure the cap is placed back on the coolant reservoir before the test drive!

    After a test drive I checked the coolant again and topped up a tiny bit and then put the engine cover back on the car.

    I then plugged my vag-com cable in and cleared the fault code related to the coolant temperature sender. I will check the car again in a week for error codes to ensure the error has not reoccured. oh and buy a genuine one!
    #14
  16. vw754
    Offline

    vw754 vorsprung Durch Technik

    Joined:
    Nov 4, 2006
    Messages:
    2,041
    Likes Received:
    30
    [Jan 30, 2007]
    mas....you think injection timing? wont car have more than just fuel problems if it timings out?
    #15

Share This Page