JMB RetrofitsChris Nott
Results 1 to 7 of 7
  1. #1
    Sammo's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2008
    Location
    Epsom, Surrey
    Posts
    16

    Thumbs up Evening Everyone

    Hi everyone

    I have a 92 S2 Coupe that I have endless problems with so I thought the more forums I join the more chance I have of fixing it.

    So wait for the questions to start coming.

    Cheers

    Sammo

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    voorhees's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,896
    Sammo
    Welcome to the site,I'm sure you'll find the help you need.
    If you struggle then I could give you the number of a guy who quite clever with S2's

  4. #3
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955
    Hello Sam ...Tell me your issues mate ..I have had plenty of long nights fixing S2/S4's..

    Urq RR
    S2 Coupe...RS2 +
    S2 Avant (slipper wagon spec)
    A4 AVANT TDI

  5. #4
    Sammo's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2008
    Location
    Epsom, Surrey
    Posts
    16
    Well if I accelerate hard the car will start to boost then it will suddenly just cut everything to the extent you nearly smack your face on the steering wheel. After doing it the once it will just keep doing it no matter how hard or soft you accelerate.

    I had the whole front of the car off the other day and found a split in the Michelin Man hose at the front which I replaced with a Samco hose. After putting it all back together the problem is still there. I also have noticed that the bolt on top of the wastegate is unwound quite far.

    The last thing which I think is very much connected to the problem is when you are accelerating, before it ****s its pants you can hear the air being sucked in(or pushed out) and when you change gear you can really hear the dump even though it just has a standard recirc valve.

    Someone please help as it making me want to get rid of the car. It has done this since the day after I bought the bloody thing!

    Oh yeh and its a 3B engine.

    Cheers

    Sammo
    Last edited by Sammo; 25th April 2008 at 22:12.

  6. #5
    evilscotsman's Avatar
    Space Cowboy

    Status
    Offline
    Join Date
    May 2008
    Location
    Fife, Scotland
    Posts
    1,345
    Hi mate, im new to the forum too

    Does sound like boost is getting dumped, could be a boost leak that happens under pressure like the hose swells and lets go at the end connection just as the boost builds....could also be a faulty divertor / bov letting go under pressure, check all the boost and vacuum hoses for splits or cracks, and that the factory bov has the correct connection to the inlet vacuum so it only triggers on throttle release.

  7. #6
    audivro's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    36
    had the same on a turbo celica,could well be the same thing.The turbo is hitting the ecu's boot upper limit and the pressure is being dumped to save the engine.(ecu failsafe)Sounds like the same thing based on the actuator issue you mentioned.

    P.s welcome dude i am new here also

  8. #7
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,087
    welcome mate, i cant help with this unfortunately, but you have a nice car :-)

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO