JMB RetrofitsSky Insurance
Results 1 to 2 of 2
  1. #1
    audi-a6's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    christchurch
    Posts
    489

    passat tdi limp mode no cel

    hey all, sorry not been on for a while, sadly had to let the a6 go and went back to a skyline. However i have just bought a passat 1.9 b5.5 tdi 130 as a run around..

    I bought it cheap as it had a blown turbo, so bought a new cartridge for it, took the turbo off and fitted new cartridge, while i had the turbo apart i cleaned the vnt nozzels as they were pretty coked up. Also cleaned inlet and egr valve. Put back together last night and took for a drive and drove almost perfect, had a bit of smoke (probs still oil in the intercooler from old turbo) and also a slight engine judder/hesitation above 3k..... other than that she was fine.....

    ...... until today, it will not rev past 2.5k, it like its hit a rev limiter so i presume is a form of limp mode :-/ I got no CEL light and no codes stored in the ecu..... but also i noticed the the cel does not come on even for a second when first switching ignition on, so i unplugged maf... still no cel. drove car and problem still there, this time with less boost so guess the maf is fine, but if the maf is unplugged, shouldn't it throw a code?

    some light on this would be apreciated
    Passat B5.5 tdi....... big plans to come
    Audi A3 8p motor way work horse
    Nissan Skyline r33 gts-t ..... my mid life crisis fun car

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    davc's Avatar
    Foursprung Duck Technik

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Caledonia
    Posts
    216
    If you switch the engine off then back on, does it drive ok until you hit 2.5k again?

    If it does it could be over boosting. The vnt mech may be the seizing, although I reckon your maf is the culprit. I had the same issue a few years back on my golf where it wouldn't rev past 3k.

    When my turbo eventually went, it would go into limp mode at 2.5k.

    Not sure about getting faults with the maf unplugged, but I know from experience that when they fail you don't get any codes.
    MY'09 S3 Sportback |Gloss Black Mirrors |Buckets |Black Optiks |Open Sky |Light & Rain Sensor Pack |CH/LH Lights |RNS-E & No Highs No Lows it must be Bose |

 

 

Similar Threads

  1. Replies: 3
    Last Post: 8th June 2014, 18:48
  2. AUDI A4 1.9 TDI LIMP MODE IN HEAVY RAIN
    By manan_a in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 23rd March 2014, 16:21
  3. 2005 a4 2.0 tdi limp mode
    By ifsot in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 4
    Last Post: 17th August 2013, 21:10
  4. 2000 Sport TDI - Limp Mode / Over Boost
    By ruffrida in forum A3/S3 Forum (8L Chassis)
    Replies: 44
    Last Post: 12th July 2013, 05:06
  5. A4 1.9 TDI Motorway Speed Limp Mode
    By inigoj in forum Diesel forum
    Replies: 10
    Last Post: 25th January 2007, 21:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO