Badger5Sky Insurance
Results 1 to 14 of 14
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Feb 2003
    Posts
    49

    Engine Mount error....

    Hi, i have the following error on my A4 B6 TDI 130 -

    17994 P1586 Engine mount solenoid valves Short to B+

    Can anyone tell me how to trouble shoot this code... is it the left or rignt mount ?

    17994 - Engine Mount Solenoid Valves (N144/N145): Short to Plus
    P1586 - 35-10 - - - Intermittent

    Readiness: 0 0 X X X

    Many Thanks

    John.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,089
    Seems to be some form of vibration damper by looks of it in etka, check any wiring going to the mount of the engine as seems to indicate not connected, could be corroded wire or damaged.

    As I dont know your engine code etc then I'm just checking overall in etka for a B6 car, but that should be enough for you to check.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2003
    Posts
    49
    Hi Thanks for the response. It's an AVF engine - 1.9 tdi quattro.

    Will check the connection tonight on the passenger side as it is accessable, or could i disconnect the wire to see if another fault came up to eliminate the passenger side one ?

    Cheers

  5. #4
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Staffordshire, UK
    Posts
    455
    Did you fix this do you know?

    Where abouts is the wiring to the passenger side mount?

  6. #5
    vw754's Avatar
    vorsprung Durch Technik

    Status
    Offline
    Join Date
    Nov 2006
    Location
    U.K
    Posts
    1,973
    Quote Originally Posted by johnny_m View Post
    Hi, i have the following error on my A4 B6 TDI 130 -

    17994 P1586 Engine mount solenoid valves Short to B+

    Can anyone tell me how to trouble shoot this code... is it the left or rignt mount ?

    17994 - Engine Mount Solenoid Valves (N144/N145): Short to Plus
    P1586 - 35-10 - - - Intermittent

    Readiness: 0 0 X X X

    Many Thanks

    John.
    open the bonnet and its the mounting at the front in the center with a wire going to it.
    Full leather/19"wheels/cruise/

  7. #6
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Staffordshire, UK
    Posts
    455
    Presume just replace the mount?

  8. #7
    vw754's Avatar
    vorsprung Durch Technik

    Status
    Offline
    Join Date
    Nov 2006
    Location
    U.K
    Posts
    1,973
    Quote Originally Posted by Funkyfin2000 View Post
    Presume just replace the mount?
    yes,replace it...about 70 from audi........try vw/skoda aswell
    Full leather/19"wheels/cruise/

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Staffordshire, UK
    Posts
    455
    Ive got a mount coming from the garage i bought car and my mechanic can fit for 30.

    The car shakes violently at a cold start and throws out quite a lot of smoke and runs lumpy for a min.

    The vag com scan shows only the same as the original posted.

    Car runs perfectly otherwise.

  10. #9
    vw754's Avatar
    vorsprung Durch Technik

    Status
    Offline
    Join Date
    Nov 2006
    Location
    U.K
    Posts
    1,973
    check coolant sensor,go to engine in vag and check measuring blocks when car is at normal temp...i.e temp gauge halfway and check reading on vag see what its showing.it will say coolant/temp sensor.
    Full leather/19"wheels/cruise/

  11. #10
    2nd Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Staffordshire, UK
    Posts
    455
    Which measuring block?

  12. #11
    vw754's Avatar
    vorsprung Durch Technik

    Status
    Offline
    Join Date
    Nov 2006
    Location
    U.K
    Posts
    1,973
    pm'd you
    Full leather/19"wheels/cruise/

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    London
    Posts
    91
    where can i get the mount from ... any on ebay as im not sure exactly how it looks?
    Whats the part number for the mount?
    Thanks

  14. #13
    vw754's Avatar
    vorsprung Durch Technik

    Status
    Offline
    Join Date
    Nov 2006
    Location
    U.K
    Posts
    1,973
    open bonnet and you shud see the mount just infront of engine....gearbox side
    Quote Originally Posted by jay786 View Post
    where can i get the mount from ... any on ebay as im not sure exactly how it looks?
    Whats the part number for the mount?
    Thanks
    Full leather/19"wheels/cruise/

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Location
    London
    Posts
    91
    i understand that but i want to buy a second hand one as euro car parts dont do it and the dealers are saying £100 ..??
    whats the part number?

    Is this the right one ...
    Engine Mount AUDI A4 95-04 | eBay

    Thanks

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO