Volks AutosEM Tuning
Results 1 to 18 of 18
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298

    VCDS Expert required

    I'm having some trouble with my cruise control working.
    I Logged block 066 in VCDS and on initial check, it appeared the brake switch/clutch switch etc were working, but I was told it was the clutch switch so I replaced it nayway,
    No difference
    I then noticed in block 066 that the second last digit in field 4 was 0 when it should be 1 when vagcom is switched on. I guessed the switch was faulty, replaced this, still no good.
    I now know that I can check the switch outputs, so have done this and the switch performs exactly as it should, as do the brake switch and clutch switch.
    in block 066, there are two speed readings. When I drive, only field 1 shows my speed. Field 3 does not.
    In parking assist module, I'm also getting this code:
    00625 - Vehicle Speed Signal
    27-10 - Implausible Signal - Intermittent

    Is it possible that this is causing my fault? And if so, where does it take this speed signal from and how do i test it?

    On a slightly related note, when I try to scan module 03 - ABS & Brakes, the car beeps and flashes which I'm told is perfectly normal, but it wont access the module. Going to try a different cable, but if its not the cable, anyone got any ideas why I cant access that module?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,776
    If the vehicle speed isnt being read properly for whatever reason, it could very well affect the cruise control.

    Post a full log of the car as it is.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    VCDS-Lite Version: Release 1.1
    Thursday, 04 October 2012, 19:30:57:20641

    Chassis Type: 8H - Audi Cabrio B6/B7
    Scan: 01,02,03,08,09,0F,11,15,16,17,18,26,36,37,45,46,55 ,56,57,63,65,67,73,75,76,77

    -------------------------------------------------------------------------------
    Address 01: Engine Labels: Redir Fail!
    Controller: 8E0 909 518 AA
    Component: 1.8L R4/5VT G 0004
    Coding: 0011701
    Shop #: WSC 00586
    VCID: 6F91001E3E93
    No fault code found.
    Readiness: 0000 0000
    -------------------------------------------------------------------------------
    Address 03: ABS Brakes Labels: 8E0-614-517.LBL
    Controller: 8E0 614 517 A
    Component: ABS/ESP allrad 1729
    Coding: 04475
    Shop #: WSC 06435
    VCID: 263F253AD1E9
    No fault code found.
    -------------------------------------------------------------------------------
    Address 08: Auto HVAC Labels: 8E0-820-043.LBL
    Controller: 8E0 820 043 H
    Component: A4 Klimaautomat 1116
    Coding: 00000
    Shop #: WSC 63351
    VCID: 263F253AD1E9
    No fault code found.
    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. Labels: 8E0-907-279-8E2.LBL
    Controller: 8E0 907 279 D
    Component: int. Lastmodul RDW 0203
    Coding: 00011
    Shop #: WSC 63351
    VCID: 3319CC6E123B
    No fault code found.
    -------------------------------------------------------------------------------
    Address 15: Airbags Labels: 8E0-959-655-84.LBL
    Controller: 8E0 959 655 B
    Component: Airbag 8.4EP 2000
    Coding: 0010602
    Shop #: WSC 63351
    VCID: 361FF57A0149
    No fault code found.
    -------------------------------------------------------------------------------
    Address 16: Steering wheel Labels: 8E0-953-549.LBL
    Controller: 8E0 953 549 N
    Component: Lenksáulenmodul 0308
    Coding: 01042
    Shop #: WSC 63351
    VCID: 3E0FED5A2979
    No fault code found.
    -------------------------------------------------------------------------------
    Address 17: Instruments Labels: 8E0-920-9xx-8E2.LBL
    Controller: 8E0 920 950 K
    Component: KOMBI+WEGFAHRS. RB4 D36
    Coding: 01400
    Shop #: WSC 00001
    VCID: 3115C666E827
    WAUZZZ8E53A317110 AUZ6Z0B0394459
    No fault code found.
    -------------------------------------------------------------------------------
    Address 45: Inter. Monitor Labels: 8E0-951-177.LBL
    Controller: 8E0 951 177
    Component: Innenraumueberw. 0604
    Coding: 00001
    Shop #: WSC 00000
    VCID: EBA9940E8A8B
    No fault code found.
    -------------------------------------------------------------------------------
    Address 46: Central Conv. Labels: 8E0-959-433-MIN.LBL
    Controller: 8E0 959 433 BD
    Component: Komfortgerát TBF 1411
    Coding: 07115
    Shop #: WSC 06435
    VCID: 749B0F7257B5
    1 Fault Found:
    01134 - Alarm Horn (H12)
    29-00 - Short to Ground
    -------------------------------------------------------------------------------
    Address 55: Xenon Range Labels: 4Z7-907-357.LBL
    Controller: 4Z7 907 357
    Component: dynamische LWR D09
    Coding: 00060
    Shop #: WSC 63351
    VCID: 047B5FB20715
    No fault code found.
    -------------------------------------------------------------------------------
    Address 56: Radio Labels: 8E0-035-1xx-56.LBL
    Controller: 8E0 035 186 J
    Component: concert II GRO 0008
    Coding: 01203
    Shop #: WSC 63351
    VCID: 2E2FDD1AF919
    No fault code found.
    -------------------------------------------------------------------------------
    Address 76: Park Assist Labels: 8Z0-919-283.LBL
    Controller: 8Z0 919 283 A
    Component: Parkingsyst. A4 RDW D09
    Coding: 00114
    Shop #: WSC 63351
    VCID: 43F99CAE429B
    1 Fault Found:
    00625 - Vehicle Speed Signal
    27-10 - Implausible Signal - Intermittent
    End --------------------------------------------------------------------------------------------------

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Anyone got any ideas?

  6. #5
    SL11CKK's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2011
    Location
    Barking & London
    Posts
    621

    Re: VCDS Expert required

    Are u retrofitting because when I did mines I had to enable it via the engine then it finally worked.

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Quote Originally Posted by SL11 CKK View Post
    Are u retrofitting because when I did mines I had to enable it via the engine then it finally worked.
    Nope, not retro fitting, just trying to get it working again. Cruise is enabled in all modules

  8. #7
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,776
    Whats weird is the pdc module is the only one with speed signal error, I wonder if this is inadvertedly causing a fault, maybe try unplugging pdc anyway to rule this out, but speed signal is usually from your abs sensors, so why isnt abs module showing a fault, ideally you need to log the sensors in abs & see if they register speed.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Where would I find the pdc module to unplug it. The pdc wasn't working and I had a bad sensor according to vcds. Then all of a sudden it started working and I'm getting this. How would I go about logging the abs sensors?

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    If I have my ignition on, I can access 03 - ABS and I can go into the log area for the ABS sensors.

    As soon as I start the engine, it kicks me out. The way it should above 20km/h, so I don;t know how I can log the sensors

  11. #10
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    635
    Drive below 20kph, log all four sensors, then play it back using the VCDSscope.
    The four trails should be within about 1kph of each other.

    Any intermittent fault shows as a spike
    1999 A4 B5 1.9 TDi FWD Saloon, Green
    2000 A4 B5 2.5 TDi Quattro Avant, Maroon, 'Panzer' Plated (currently sporting wrecked engine)
    2000 A4 B5 2.5 TDi Quattro Saloon, Blue, 'Panzer' Plated, Cruise Control retrofitted, OEM 6 Disc Changer retrofitted

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Quote Originally Posted by PAULF View Post
    Drive below 20kph, log all four sensors, then play it back using the VCDSscope.
    The four trails should be within about 1kph of each other.

    Any intermittent fault shows as a spike
    Yes I understand that, but as above, I can;t access the ABS module with the engine running. It instantly kicks me out when I start the car

  13. #12
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,776
    Is your shareware registered?

    I would contact RT if its licensed & see if they can advise if its a limitaton.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Quote Originally Posted by NHN View Post
    Is your shareware registered?

    I would contact RT if its licensed & see if they can advise if its a limitaton.
    yes it's a registered copy but I don't think that's the issue as I've tried a genuine cable and full version as well, just to rule out my cheap cable or the light version.

  15. #14
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,776
    Ok so only with engine running you cant access abs 03, very strange, I'll see if can get RT to have a look.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Kilmarnock, Scotland
    Posts
    298
    Quote Originally Posted by NHN View Post
    Ok so only with engine running you cant access abs 03, very strange, I'll see if can get RT to have a look.
    correct. Ignition on, works fine. Engine running, kicks me out or no access. I'm wondering if the speed sensor fault I'm getting means the car can't tell what speed I'm doing so for safety, it stops me accessing the abs module, the way it would if I was over 20kph

  17. #16
    bearthebruce's Avatar
    Ross-Tech, LLC

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Ambler, PA
    Posts
    326
    I have asked our tech staff to read this thread... they have been really hammered with phone calls today....

    But, what you just wrote makes perfect sense to me. If the module sees the speed signal totally out of spec, then it cannot know what speed you are traveling and makes the assumption that diagnostic reports are not important - they should not be processed. The module is paying attention to the work at hand because it assumes a much higher rate of speed and is giving all processing power to the control of the brake system - it's prime function.

    Our techs will chime in when they have a break. Hang in there.
    -Bruce-
    Ross-Tech, LLC
    Bruce@Ross-Tech.com

  18. #17
    Neutral

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    48
    Sorry for the delay. The ABS communication may be the end result of implausible speed signals .. or something unrelated such as a flaky module but regarding the CCS issue I was able to locate some info:

    066,0,Geschwindigkeitsregelanlage (GRA/ADR)
    066,1,Geschwindigkeit,(Istwert)
    066,2,Schalterstellung,(Bremse/Kupplung),Siehe Labeldatei
    ; 00xxxxxx = ADR/GRA nicht aktiv (steht auch für nicht verbaut)
    ; 01xxxxxx = ADR/GRA im Regelbetrieb
    ; 10xxxxxx = Zustand "übersteuert", Fahrer gibt mehr "Gas" als GRA-Regler
    ; 11xxxxxx = ADR nicht freigegeben
    ; xx1xxxxx = GRA/ADR aktiv durch Haupttaster
    ; xxx1xxxx = Automatische Distanzregelung (ADR) freigeschaltet
    ; xxxx1xxx = Geschwindigkeitsregelanlage (GRA) freigeschaltet
    ; xxxxx1xx = Kupplungspedalschalter betätigt
    ; xxxxxx1x = Bremspedalschalter betätigt
    ; xxxxxxx1 = Bremslichtschalter betätigt
    066,3,Geschwindigkeit,(Sollwert)
    066,4,Schalterstellung,(Bedienhebel),Siehe Labeldatei
    ; x0xxxxx? = GRA EIN (CAN)
    ; x0xxxx?x = GRA EIN (Gesetzt/Programmiert)
    ; x0xxx?xx = Verzögern (-)
    ; x0xx?xxx = Beschleunigen (+)
    ; x0x?xxxx = Setzen/Programmieren (SET)
    ; x0?xxxxx = Wiederaufnahme (RESET)
    ; ?0xxxxxx = GRA EIN (Hardware)

    Rather than paste that to Google translate and back into forum I'll let you sort that out - but it looks like MVB 066.3 is the specified vehicle speed and may only show after CCS is enabled/on. The lack of data in that field may be normal since CCS isn't working. Although I always prefer to work with the label for the engine controller in question the German text above may be difficult so this should help:

    Checking Cruise Control using Measuring Values - Ross-Tech Wiki

    If the speedometer works and live VSS data is logged properly while driving in other modules such as the engine I would like to rule that out as a possible cause of the CCS issue but have you checked the MVB data in address 16-Steering wheel yet?

  19. #18
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,776
    As always RT are very helpful

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

 

 

Similar Threads

  1. Key Coding with VCDS Report , Expert Required!!
    By Blacky165 in forum A3/S3/Sportback (8P Chassis)
    Replies: 10
    Last Post: 28th September 2012, 15:46
  2. VCDS help required in Bedford after RNS-E and Bluetooth retrofit
    By satj in forum VCDS (formerly VAG-COM) forum
    Replies: 2
    Last Post: 24th August 2012, 09:10
  3. RNS-E EXPERTS REQUIRED
    By Andy Shipton in forum Satellite Navigation
    Replies: 1
    Last Post: 9th December 2009, 17:09
  4. brake expert required.
    By Effect in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 22nd November 2008, 08:51
  5. Vag-Com Expert Help Required!!!!!!!!!!!!!!
    By mickpd3 in forum VCDS (formerly VAG-COM) forum
    Replies: 6
    Last Post: 24th April 2007, 20:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO