EM TuningAH Fabrications
Results 1 to 13 of 13
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11

    Help please. 01539-Headlights Not Adjusted 005-No or Incorrect Basic Setting

    I'd appreciate any advice on fault code 01539 which has recently apeared on my A5. The autoscan is at the bottom of this message. You'll see that address 55 has an 01539 fault. I've also attached a log of the measuring blocks. I have tried the Ross Tech reset directions but can't get to the Learning stage and just get an ADJUSTMENT INVALID ADJUSTMENT NOT POSSIBLE warning. I've reset the adaption to factory defaults but still no joy. I've even taken the car to the local Audi dealer who just scratched their collective heads and said they'll have to get advice from Audi Technical (warning that they could take some time to respond!).

    Could it be a sensor problem? They are shown in the log as having UNDEFINED output (strange that both should fail though). Other than that is the module itself faulty? (hope not!)

    You'll realise that I'm very frustrated by this, especially as even Audi can't come up with a quick fix. I'm sure the gurus on this forum might have some idea, I'd be extremely grateful for any help/advice.

    Many thanks, sorry that my first post is a plea for help.
    David.

    MODULE LOG:
    Address 55: Xenon Range (8H0 907 357 A)

    15:43:19 Group 001
    11.7 V Voltage (Terminal 15)
    42.23 s Time Constant
    0.00 m/s^2 Vehicle Acceleration)
    1.0 (no units)

    15:43:19 Group 002: Sensors
    Undefined Front Sensor Signal
    Undefined Rear Sensor Signal
    4.9 V PWM Sensors Voltage Supply
    N/A

    15:43:19 Group 005: Specified Positions
    Faulty Headlight Range Control
    0.000° Dynamic Cornering Left Light
    0.000° Dynamic Cornering Right Light
    N/A
    Wednesday,19,September,2012,15:43:48:55631
    VCDS Version: Release 11.11.4
    Data version: 20120807

    Address 55: Xenon Range (8H0 907 357 A)

    15:43:46 Group 001: Adjustment Position && Adjustment Learning
    Adjustment Status
    Invalid
    Adjustment
    Not Possible


    AUTOSCAN:
    Friday,14,September,2012,20:49:11:55631
    VCDS Version: Release 11.11.4
    Data version: 20120807
    --------------------------------------------------------------------------------
    Chassis Type: 8T0
    Scan: 01 03 05 08 09 10 15 16 17 19 3C 42 46 52 53 55 56 5F
    VIN: WAUZZZ8T0

    01-Engine -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    04-Steering Angle -- Status: OK 0000
    05-Acc/Start Auth. -- Status: OK 0000
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: OK 0000
    10-Park/Steer Assist -- Status: OK 0000
    15-Airbags -- Status: OK 0000
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: OK 0000
    3C-Lane Change -- Status: OK 0000
    42-Door Elect, Driver -- Status: OK 0000
    46-Central Conv. -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    53-Parking Brake -- Status: OK 0000
    55-Xenon Range -- Status: Malfunction 0010
    56-Radio -- Status: OK 0000
    5F-Information Electr. -- Status: OK 0000

    -------------------------------------------------------------------------------
    Address 01: Engine (J623-CCWA) Labels: 059-907-401-CAP.clb
    Part No SW: 8K2 907 401 A HW: 8K1 907 401 A
    Component: 3.0TDI EDC17 H01 0006
    Revision: 15H01---
    Coding: 0114002C180F0118
    Shop #: WSC 06325 000 00000
    ASAM Dataset: EV_ECM30TDI0118K2907401A 001006
    ROD: EV_ECM30TDI0118K2907401A.rod
    VCID: 2B53393C42DC7F40A47

    No fault code found.
    Readiness: 0 0 0 0 1

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes (J104) Labels: 8K0-907-379.clb
    Part No SW: 8K0 907 379 AF HW: 8K0 907 379 AF
    Component: ESP8 quattro H04 0210
    Revision: -------- Serial number: --------------
    Coding: 1B0500
    Shop #: WSC 06325 000 00000
    VCID: 7DF7C764E42821F04A3

    No fault code found.

    -------------------------------------------------------------------------------
    Address 05: Acc/Start Auth. (J393) Labels: 8K0-907-064-05.clb
    Part No SW: 8K0 907 064 C HW: 8K0 907 064 C
    Component: BCM2 1.1 H80 0145
    Revision: 00002001
    Coding: 031000
    Shop #: WSC 06325 000 00000
    VCID: 30692E5063FA1C98915

    Subsystem 1 - Part No SW: 8T0 959 754 D HW: 8T0 959 754 D
    Component: FBSAUDIB8 IDG H37 0060

    Subsystem 2 - Part No SW: 8K0 905 852 D HW: 8K0 905 852 D
    Component: ELVAUDIB8 H36 0041

    No fault code found.

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC (J255) Labels: Redir Fail!
    Part No SW: 8T2 820 043 S HW: 8T2 820 043 S
    Component: KLIMA 3 ZONEN H06 0150
    Revision: D0000000 Serial number: 01120120090806
    Coding: 36160000
    Shop #: WSC 06325 000 00000
    VCID: 428D7498DD569E08771

    No fault code found.

    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. (J519) Labels: 8K0-907-063.clb
    Part No SW: 8K0 907 063 C HW: 8K0 907 063 C
    Component: BCM1 1.0 H22 0253
    Revision: 04022001 Serial number: 00000000186493
    Coding: 260050914034AF010009000000005D5D001D03880001014100 0000
    Shop #: WSC 06325 000 00000
    VCID: 2F6B2D2C7EC4036088F

    Subsystem 1 - Part No SW: 8T2 955 119 C HW: 8J2 955 119 Labels: 1KX-955-119.CLB
    Component: WWS 041208 H11 0040
    Coding: 00FD11

    Subsystem 2 - Part No SW: 8K0 955 559 HW: 8K0 955 559 Labels: 8K0-955-559.CLB
    Component: RLS H04 0003
    Coding: 02532C

    Subsystem 3 - Part No SW: 8K0 941 531 AA HW: 8K0 941 531 AA
    Component: E1 - LDS H07 0080

    No fault code found.

    -------------------------------------------------------------------------------
    Address 10: Park/Steer Assist (J446) Labels: 8K0-919-475.clb
    Part No SW: 8K0 919 475 F HW: 8K0 919 475
    Component: PARKHILFE 4K H06 0040
    Revision: 11001001 Serial number: 40140900803049
    Coding: 000001
    Shop #: WSC 06325 000 00000
    VCID: 3C710A60BFB2E8F83DD

    No fault code found.

    -------------------------------------------------------------------------------
    Address 15: Airbags (J234) Labels: 8K0-959-655.clb
    Part No SW: 8K0 959 655 B HW: 8K0 959 655 B
    Component: AirbagVW-AU10 H27 0410
    Serial number: 0038JD1D6RW-
    Coding: 30323433363030303030554A305238543053
    Shop #: WSC 06325 000 00000
    ASAM Dataset: EV_AirbaECUVWAUDI010 A02007
    ROD: EV_AirbaECUVWAUDI010_AU48.rod
    VCID: 3C710A60B7B2E8F83DD

    Crash sensor for side airbag; driver side:
    Serial number: 6334MSME4613217B8

    Crash sensor for side airbag; passenger side:
    Serial number: 6344MSME43002B374

    Crash sensor for side airbag; rear driver side:
    Serial number: 6352QSME681B2B06M

    Crash sensor for side airbag; rear passenger side:
    Serial number: 6362QSME40184E38K

    Crash sensor for front airbag; driver side:
    Serial number: 63732SME74194F30%

    Crash sensor for front airbag; passenger side:
    Serial number: 63832SME06173F14.

    No fault code found.

    -------------------------------------------------------------------------------
    Address 16: Steering wheel (J527) Labels: 8K0-953-568.clb
    Part No SW: 8K0 953 568 F HW: 8K0 953 568 F
    Component: Lenks.Modul H13 0013
    Revision: -------- Serial number: 90319HLD000AO
    Coding: 000016
    Shop #: WSC 06325 000 00000
    VCID: 3D770764A4A8E1F00A3

    Component: E221 - MFL H02 0003

    No fault code found.

    -------------------------------------------------------------------------------
    Address 17: Instruments (J285) Labels: 8T0-920-xxx-17.clb
    Part No SW: 8T0 920 981 B HW: 8T0 920 981 B
    Component: KOMBIINSTR. H32 0224
    Revision: 00000000 Serial number: 9D6149FD8
    Coding: 2F0501000A002600010000
    Shop #: WSC 06325 000 00000
    VCID: 3B73097CBABCEFC0347

    No fault code found.

    -------------------------------------------------------------------------------
    Address 19: CAN Gateway (J533) Labels: 8T0-907-468.clb
    Part No SW: 8T0 907 468 Q HW: 8T0 907 468 L
    Component: GW-BEM 5CAN-M H10 0095
    Revision: FB600048 Serial number: 4800F08B27808F
    Coding: 000303
    Shop #: WSC 06325 000 00000
    VCID: 4FAB4DAC1E046360E8F

    Subsystem 1 - Part No SW: 8K0 915 181 B HW: 8K0 915 181 B
    Component: J367-BDM H04 0150

    No fault code found.

    -------------------------------------------------------------------------------
    Address 3C: Lane Change Labels: Redir Fail!
    Part No SW: 8K0 907 566 B HW: 4L0 907 566 B
    Component: J0769_SWA_MasterH01 0050
    Revision: 00H01000 Serial number: 6PZ 009 014-13
    Coding: 0001104
    Shop #: WSC 06325 000 00000
    VCID: 36651848419E32A8CB9

    Part No: 8K0 907 568 B
    Component: J0770_SWA_Slave_H01 0050

    No fault code found.

    -------------------------------------------------------------------------------
    Address 42: Door Elect, Driver (J386) Labels: 8K0-959-793.clb
    Part No SW: 8K0 959 793 E HW: 8K0 959 793 E
    Component: TSG FA H11 0250
    Revision: Serial number: 0000008227203
    Coding: 011002224001120102
    Shop #: WSC 06325 000 00000
    VCID: 428D7498DD569E08771

    No fault code found.

    -------------------------------------------------------------------------------
    Address 46: Central Conv. (J393) Labels: 8K0-907-064-46.clb
    Part No SW: 8K0 907 064 C HW: 8K0 907 064 C
    Component: BCM2 1.1 H80 0145
    Revision: 00002001 Serial number: 0116270621
    Coding: 011B068200390440002000
    Shop #: WSC 06325 000 00000
    VCID: 30692E5063FA1C98915

    Subsystem 1 - Part No: 8K0 951 177
    Component: DWA-Sensor H02 0040

    Subsystem 2 - Part No: 1K0 951 605 C
    Component: LIN BACKUP HO H03 1301

    No fault code found.

    -------------------------------------------------------------------------------
    Address 52: Door Elect, Pass. (J387) Labels: 8K0-959-792.clb
    Part No SW: 8K0 959 792 E HW: 8K0 959 792 E
    Component: TSG BF H11 0250
    Revision: Serial number: 0000008321371
    Coding: 011002224001120102
    Shop #: WSC 06325 000 00000
    VCID: 418F7B94D85085106EB

    No fault code found.

    -------------------------------------------------------------------------------
    Address 53: Parking Brake (J540) Labels: 8K0-907-801-V1.clb
    Part No SW: 8K0 907 801 F HW: 8K0 907 801 F
    Component: EPB Audi B8 H06 0070
    Revision: 00000003 Serial number: 10000000158476
    Shop #: WSC 00000 000 00000
    VCID: 326D24586DF62E88E71

    No fault code found.

    -------------------------------------------------------------------------------
    Address 55: Xenon Range Labels: 8T0-907-357.clb
    Part No SW: 8H0 907 357 A HW: 8H0 907 357
    Component: AFS 1 H01 0020
    Revision: 00000001 Serial number:
    Coding: 0000017
    Shop #: WSC 06324 000 00000
    VCID: 30692E50A3FA1C98915

    Part No: 7L6 941 329 C
    Component: AFS-Modul links H01 0004

    Part No: 7L6 941 329 C
    Component: AFS-Modul rechtsH01 0004

    1 Fault Found:
    01539 - Headlights Not Adjusted
    005 - No or Incorrect Basic Setting / Adaptation - MIL ON
    Freeze Frame:
    Fault Status: 11100101
    Fault Priority: 2
    Fault Frequency: 1
    Reset counter: 253
    Mileage: 121981 km
    Time Indication: 0
    Date: 2012.09.14
    Time: 20:35:40


    -------------------------------------------------------------------------------
    Address 56: Radio (R) Labels: Redir Fail!
    Part No SW: 4F0 035 056 B HW: 4F0 035 056
    Component: Radio U STD H44 0020
    Revision: AB001007 Serial number: 005LV087505247
    Coding: 010003020100000001
    Shop #: WSC 06325 000 00000
    VCID: 1F4BDDEC0E6493E038F

    No fault code found.

    -------------------------------------------------------------------------------
    Address 5F: Information Electr. (J794) Labels: 4E0-035-6xx-5F.clb
    Part No SW: 8T2 035 666 D HW: 8T2 035 666
    Component: H-BN-EU H63 0047
    Revision: -------- Serial number: 344L$087510578
    Coding: 01010102000681ED11000B1E000000030001
    Shop #: WSC 00533 210 97022
    VCID: 3C710A60BFB2E8F83DD

    Subsystem 1 - Part No: 8R0 060 884
    Component: EUROPE 2008 5505

    Subsystem 2 - Part No SW: 4F0 919 604 HW: 4F0 919 604
    Component: DU7 High H43 0306

    Subsystem 3 - Part No SW: 8T0 919 609 F HW: 8T0 919 609 F
    Component: E0380 Bedient H08 0100

    No fault code found.

    End ---------------------------------------------------------------------

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,087
    Did you use security access before doing the basic setting?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    Quote Originally Posted by NHN View Post
    Did you use security access before doing the basic setting?
    Thanks for the suggestion. Unfortunately I did enter the access code first.

    The really mysterious bit is why the sensor signals are shown as "Undefined". Is this part of the basic setting or adaption process? It's hard to believe that both sensors have failed simultaneously.

    David

    (I knew the VCDS cable I bought from you would be useful! )

  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,087
    Ok please detail exactly what you're doing.

    Worth its weight in gold

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    Quote Originally Posted by NHN View Post
    Ok please detail exactly what you're doing.

    Worth its weight in gold
    Thanks, I'll outline the steps I took:

    1. Select Control Module 55 - Xenon Range.
    2. Click on Security Access - 16 & wait for the correct code to be displayed.
    3. Enter code and wait for acceptance message. Click Done, Go Back.
    4. Click on Basic Settings - 04 group 001 and wait. The message stays at Adjustent Invalid Adjustment Not Posible so I can't move onto the learning phase.

    I then did the following:
    1a. Clicked on Adaption - 10 and reset to factory defaults. Done, Go Back.
    2a. Clicked on Coding - 07 to check the correct coding (00017 - Coupe, steel suspension). Cancel.
    3a. Tried the setting process above. No joy!

    I have tried Output Tests - 03 and all tests return a message saying Refused by control module - Message 7F 00 22
    I have tried Measuring Blocks group 002/003 and the sensor output is shown as Undefined.

    The only thing I can think of is that I might have clicked Save at stage 2a above. However, I made no changes so I wouldn't have thought this would cause a problem, or could it?

    I have tried it with the lights on and off, handbrake on and off etc., all to no avail.

    It's disappointing and surprising that Audi can't come up with a solution. I have rung the dealer and they have heard nothing from Audi (and they don't seem too interested in chasing it!).

    Any advice would be greatly appreciated. You may spot a glaring error in what I'm doing.

    Many thanks.
    Regards,
    David.

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,087
    Ok have you tried it without using the security access?

    Try recoding the suspension again, this may also require you to go into security access & iirc for some it was 02000, then try basic settings for sensors.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    Thanks, I shall try it again this afternoon. I'll let you know how I get on.
    Now, how many parts of my anatomy can I cross?
    David.

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    Quote Originally Posted by NHN View Post
    Ok have you tried it without using the security access?

    Try recoding the suspension again, this may also require you to go into security access & iirc for some it was 02000, then try basic settings for sensors.
    Tried it again as above but no joy.

    However, Audi have just rung to say they might have identified the issue but need to do a few more tests. They are collecting the car next Wednesday AM and say they will definitely get it fixed by Thursday PM.

    The car does have an after-market warranty although the time for dealer investigation won't be covered. So, if there are any more suggestions in the meantime it could save me quite a few beer tokens, some of which I am happy to pass on as a thank you!

    One way or the other the car should be OK (and legal) again towards the end of next week. I will, of course, share details of the fix to save anyone else the same hassle.

    Thanks for your help.
    David.

  10. #9
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,087
    Interesting, ok I have asked RT to get involved, so hold of the dealer for now mate as I'm sure we can look into & fix or at least answer why you're having problems, so hopefully get a cost free fix.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    Thanks Nigel.

    I have recently spoken to RT and Dana has been very helpful. On her suggestion I have today checked the sensor outputs and all seems OK. I plan to check the module 55 inputs tomorrow as this could be at fault. I need to find the module first mind - I believe it's behind the glovebox!

    It's frustrating that the problem suddenly appeared with no apparent cause as before this the car showed absolutely no faults. If I can find a quick solution I'll be over the moon, especially if I don't need to get the dealer inolved!

    Many thanks for your help, and that of RT. What a great setup!

    Regards,
    David.

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Cotswolds, UK
    Posts
    11
    An update. Apologies for the delay!

    As I mentioned previously, I had checked the sensor outputs and they seemed OK. I checked the inouts to the control module and they, too, seemed OK. This proved the wiring.

    So, what was next? ....

    The control unit monitors & controls the AFS power modules in the headlights so I decided to check these. I remember reading that the left module was the master (not sure if this is correct?) so I removed that headlight, removed the AFS module and found this:





    It's even worse than it appears in the photos! Obviously water had got in at some time and corroded the circuit board causing it to fail. The original module 55 scan showed the two power modules as on-line and operational so I was a little suprised to find such a mess. I checked the module in the other headlight and that was fine. Keeping my fingers crossed I bit the bullet and fitted a new module and all now works fine - coding wasn't a problem.

    Now I have no fault codes at all, and the lights swivel and level correctly when in showroom mode. I'll try them tonight to check they work when driving.

    Thanks to NHN and RT for their help. I hope my experience might help anyone else with a stubborn fault.

    Regards,
    David.

  13. #12
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,087
    Damn thats condensation I reckon mate, something wasnt sealed to well, if I was you mate I would check that headlight for air tightness as you dont want that happening again thats for sure, thats 1st time seen damage to that extent on a module, ones I've dealt with usually had some corrosion on which I've cleaned up & resoldered tbh & worked fine, but yours is extreme for sure.

    Glad 1st you found the issue & didnt give up, very well done & 2nd for the reporting back on here

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    48
    Thanks for the update David!

 

 

Similar Threads

  1. S3 not starting??? Help please....
    By Lacey123 in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 27th August 2009, 22:44
  2. Headlight/projector help please!!!!!
    By jamie_a3 in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 26th August 2009, 07:08
  3. S3 nearly not starting - help please?
    By dgannon in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 15th December 2008, 01:38
  4. S3 nearly not starting - help please?
    By dgannon in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 14th December 2008, 16:07
  5. Audi A3 Bonnert Bra or Not Help Please
    By ruairi83 in forum A3/S3 Forum (8L Chassis)
    Replies: 14
    Last Post: 3rd November 2008, 19:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO