Monster MotorsportChris Nott
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2007
    Posts
    29

    tt temp problem!

    Hi we have a tt 2001 model 225bhp. It recently started to go bit funny on the temp needle. When we are stuck in treffic it goes above the 90 mark and soon as you drive again it goes back to 90!

    We have had the thernostat replaced and had it on the diagnostics but no problem comes up. Also my mechanic had it turned on for 20 mins but the needle stayed dead on 90!! this is really baffling me. My mechanic also took it for a test drive to see if it happens but it was behaving ok at that time.

    Can anyone shed any light on this? Could it be the fan sensor etc?

    thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    ButchsTT's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Puerto Rico
    Posts
    69
    I have a 2001 and it was doing the same thing seems I replaced everything but the kitchen sink and then found out it was the water pump... something about it being made of Plastic also the mech said the large cooling fan may have been out . found out today that if the air is on the small fan will run continuously... not sure the same applies but it is a start

  4. #3
    Silversea's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2003
    Posts
    34
    As above, the plastic impellers on the water pump will have broken off.
    Not an uncommon fault on the 20vT engines.
    Best to change it when the cam belt and tensioners are getting done for piece of mind.

  5. #4
    Bong Water's Avatar
    In two minds

    Status
    Offline
    Join Date
    Dec 2007
    Posts
    785
    Could possibly be an air lock, though when you had the thermostat replaced they probably got all the air out? Best way to check is to see if the bottom pipe is heating up
    Skint because of my car, the forums made me do it

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2007
    Posts
    29
    funnything is that it does not happen everytime. for example I drove it yesterday and it was fine. Also the last owner had the timing belt changed not ong ago, as the cars mileage is only 85000.? Surely this wouldve been sorted?

    thanks

  7. #6
    Bong Water's Avatar
    In two minds

    Status
    Offline
    Join Date
    Dec 2007
    Posts
    785
    Contact the garage or check the receipt
    Skint because of my car, the forums made me do it

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO