EM TuningChris Nott
Results 1 to 15 of 15
  1. #1
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888

    bluetooth module upgrade and sds problems

    Hi There,

    I have a few problems with an upgrade.

    I recently fitted an 09 rns-e. I already had factory fit BT, and retro fbmfsw.

    The bt would pair with the rns-e, but would not display tel numbers/phonebook etc.

    After a bit of fishing around on here, it seemed apparent that my bt module was to old, (d version) So i bought a new s version to upgrade to.
    As i was going to be ripping the seat out etc to access the module, I decided it would be a good time to do the sds mod aswell.

    However, now i have problems.

    I cannot get the sds to work (no beep from steering wheel)
    And the phone book is still not being displayed.

    I can make and receive calls, But there is a slight buzz on the line . (it isnt as clear as it was with the old unit)

    Could anyone point me in the right direction for finding the problem?

    My coding is as follows

    instrument 0004443
    nav 0205715
    tel 0011420
    wheel 04022

    Sw 660 ~(for sds )

    following error codes


    Address 56: Radio Labels: 8E0-035-192-RNSE.lbl
    Control Module Part Number: 8E0 035 192 T HW: 8E0 035 192 T
    Component and/or Version: RNS-E HIGH EU H74 0690
    Software Coding: 0205715
    Work Shop Code: WSC 00441 210 88110
    1 Fault Found:

    01317 - Control Module in Instrument Cluster (J285)
    008 - Implausible Signal
    Freeze Frame:
    Fault Status: 01101000
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 85
    Mileage: 134908 km
    Time Indication: 0
    Date: 2010.01.14
    Time: 12:09:19

    Freeze Frame:
    Bin. Bits: 10110011
    Bin. Bits: 00

    Sunday,24,January,2010,12:19:17:65047
    VCDS Version: Release 908.1

    Address 56: Radio Labels: 8E0-035-192-RNSE.lbl
    Control Module Part Number: 8E0 035 192 T HW: 8E0 035 192 T
    Component and/or Version: RNS-E HIGH EU H74 0690
    Software Coding: 0205715
    Work Shop Code: WSC 00441 210 88110
    1 Fault Found:

    01317 - Control Module in Instrument Cluster (J285)
    008 - Implausible Signal
    Freeze Frame:
    Fault Status: 01101000
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 85
    Mileage: 134908 km
    Time Indication: 0
    Date: 2010.01.14
    Time: 12:15:05

    Freeze Frame:
    Bin. Bits: 10110011
    Bin. Bits: 00

    Sunday,24,January,2010,12:20:01:65047
    VCDS Version: Release 908.1

    Address 16: Steering wheel Labels: 8P0-953-549.lbl
    Control Module Part Number: 8P0 953 549 C HW: 8P0 953 549 C
    Component and/or Version: Lenksäulenmodul H21 0050
    Software Coding: 0004022
    Work Shop Code: WSC 06314 000 00000
    Additional Info: XXXXXXXXXXX Lenkradmodul H06 0030
    Additional Info: Geraet 00000
    1 Fault Found:

    01317 - Control Module in Instrument Cluster (J285)
    004 - No Signal/Communication

    Any help greatly appreciated
    Last edited by scottie123; 24th January 2010 at 21:09.
    05 SB SE BKD

    Build Thread

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    well according to wilki, this is the error code cause.

    http://wiki.ross-tech.com/index.php/01317

    Any ideas anyone?
    05 SB SE BKD

    Build Thread

  4. #3
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    Two things spring to mind...

    First of all the steering wheel does not need to be coded for voice control.

    Secondly the BT module should be recoded to 0011402 for full SDS operation from the RNS-E.

    I see you have an A4 unit recoded to A3 which may be why the you have the strange error messages. Have you rest the unit since it was coded for A3?

  5. #4
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    Quote Originally Posted by s8craig View Post
    Two things spring to mind...

    First of all the steering wheel does not need to be coded for voice control.

    Secondly the BT module should be recoded to 0011402 for full SDS operation from the RNS-E.

    I see you have an A4 unit recoded to A3 which may be why the you have the strange error messages. Have you rest the unit since it was coded for A3?
    The unit was recoded before I got it,which I didn't realise until I received it. so I got it reduced to a good price. I presume you mean reset? Is that through the actual unit or vcds?

    I will try the blue tooth code tomorrow, does my steering wheel lookokt then, as no coding is needed for voice control.

    I am also finding a strange interference like noise on certain occasions. When the phone/ car are in the initial connecting bit, the bong is now quiet,almost distant, And a background static hiss starts just before bong and stops just after. it sounds wrong. When i make a call however, there is no issue with noise.

    Thanks for your help so far
    05 SB SE BKD

    Build Thread

  6. #5
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,762
    Out of interest, try coding wheel 04011 assuming you have a rear wiper installed & no cruise, if have cruise the try 04041, wouldnt worry about hiss as iirc I get it on all cars & its only on BT connection initially, I'll check mine but rings a bell.

    Also for the record, the S module is for the 8P aswell as other chassis's from 08 onwards & I have the same one & it functions perfectly with no errors with cluster, I suspect coding is an issue here, which is why I suggest above as I can assume your coding has said it doesnt have a DIS which I'm guessing does have, so therefore its not seeing the correct module in dash, no harm in trying anyway as we can only but learn by our mistakes huh, hopefully that will resolve.
    Last edited by NHN; 25th January 2010 at 15:56.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  7. #6
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    But you don't need to code the MFSW in an A3 for anything to do with SDS, it just works out of the. I've added hundreds of A3/TT/R8 phone kits and the only things I program up are the following....

    Radio or Nav for phone fitted
    Can gateway for phone fitted
    Phone ECU for type of comfort or not, radio/nav. mfsw or not, and voice country.

  8. #7
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,762
    As already stated, changing the coding wont hurt, if it doesnt resolve then no loss, if it does then lesson learnt for all, have a go Scott.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  9. #8
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    Change the steering wheel code as much as you like, it will make no difference.

    The fact that the BT module is coded incorrectly is why the SDS is not working, the SDS in the BT module and the NAV unit are clashing, simply turning the SDS off in the BT module will fix the SDS issue.

    The SDS NAV mod is quite noisy in operation, lots of strange whirss and pops to the SDS voice, not as clear as the BT only SDS that's for sure.

    But as for the phone book not displaying, the coding of the BT & NAV are fine for that, first of all what phone are you using?

  10. #9
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    Thanks for the replies.

    NHN, my car doesn't have DIS,sadly But it is on the to do list

    I'm glad to hear that you have the same module as me. I was worried that it may be the route cause of a problem, but as yours is ok, mine should be to.

    I will have to try the coding tomorrow now as the other half has the car at work.

    I will recode the bt module to as mentioned. Is it best to do a hard reset of any sort after coding to test new changes? If so how?

    I did discover the bluetooth sds before I upgraded the bt unit, It was very clear with a crisp( and loud ) bong upon connection. I suppose I am comparing the bt sds to the full sds, making it sound incorrect.

    In regards to what phone is being used. I have tried a samsung m8800 and also a nokia 5800 express. Both connect the same way with no phone book etc.

    Thanks for your time on helping me with this matter




    Probably of no significance, but I also have the cradle base on the dash ( eughh ), don't think it will make a difference, but worth a mention.
    05 SB SE BKD

    Build Thread

  11. #10
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,762
    So the significant thing here is, you dont have a DIS & the errors are related to the cluster, so would seem logical its expecting a cluster DIS therefore faulting on these modules, thats my thought process.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  12. #11
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    Not having a DIS would not be an issue, but having a low line cluster with no radio station info etc would be a problem.

  13. #12
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    That sounds likethe cluster I have. Poverty spec I believe is the technical term

    So having this cluster could stop the phonebook etc working or just give a error code all the time?
    05 SB SE BKD

    Build Thread

  14. #13
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    Well the sds is working except she can't hear me.

    So I must have the + and - mixed up. Strange that normal hands free works ok though.hmmm

    Any way, one down , one to go

    I really would like to get the phonebook on the rns-e. It is why I just bought a new BT module, as I believed it was why I couldn't do this.

    It would seem that the coding is now ok on the BT module, and my rns-e seems ok. What else is left that I could try to get the phonebook displayed?

    Cheers again for the successful help so far!
    05 SB SE BKD

    Build Thread

  15. #14
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    Does anything else show in the RNS-E display for the phone system? dialled, missed etc?

    My gut feeling on this is because the cluster gets the phonebook first ahead of the RNS-E and your cluster doesn't support the highline function, then maybe that is why it is not passing onto the RNS-E.

  16. #15
    scottie123's Avatar
    (●̮̮̃•̃) (●̮̮̃•̃)

    Status
    Offline
    Join Date
    Oct 2008
    Location
    (.) (.)
    Posts
    1,888
    When I receive a call, the number will display on the screen,but not the persons name.

    Not sure about missed calls as , tbh I haven't used the car much lately as the missus has it most of the time.

    So If it is the cluster, is it possible to retro a DIS cluster into a non dis car ? Or is it possible to modify the wiring /unit in anyway?
    05 SB SE BKD

    Build Thread

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO