Monster MotorsportJMB Retrofits
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2013
    Posts
    10

    Screen keeps going off on sat nav/ radio system

    I've got a rnse sat nav/ audio unit that's got a fault ....the screen keeps going black but the radio still works fine ....can anyone recommend anyone to fix this for me ?
    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    AJC
    AJC's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Surrey
    Posts
    173
    Have the same problem Jakes3........It's most likely the ribbon that's at fault which will either be loose or slightly damaged at the end....you can either cut the damaged ends off and reconnect or try some flexible silver circuit board paint from Maplins for around £10

  4. #3
    Anthony566's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    North East
    Posts
    615
    Quote Originally Posted by Jakes3 View Post
    I've got a rnse sat nav/ audio unit that's got a fault ....the screen keeps going black but the radio still works fine ....can anyone recommend anyone to fix this for me ?
    Thanks
    Has this unit had its DVD drive replaced ? If it has the screen ribbon may have moved, I have replaced the drives in a few of these and it's easy to check the ribbon.
    2013 A4 2.0 TDi 177 quattro Black Edition - Glacier White

  5. #4
    AJC
    AJC's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Surrey
    Posts
    173
    Anthony566 - Can you explain how to gain access to the ribbon? Any user guides available for the DIY enthusiast?

  6. #5
    AJC
    AJC's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Surrey
    Posts
    173
    Quote Originally Posted by Jakes3 View Post
    I've got a rnse sat nav/ audio unit that's got a fault ....the screen keeps going black but the radio still works fine ....can anyone recommend anyone to fix this for me ?
    Thanks
    Jakes3 - have just fixed my own unit with this problem, happy to fix yours or talk you through it if needed

  7. #6
    Anthony566's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    North East
    Posts
    615
    Quote Originally Posted by AJC View Post
    Anthony566 - Can you explain how to gain access to the ribbon? Any user guides available for the DIY enthusiast?
    Hi sorry I didn't reply I completely forgot ... pm me an email address and ill send you a document I have with instructions and photos.
    2013 A4 2.0 TDi 177 quattro Black Edition - Glacier White

 

 

Similar Threads

  1. Help My Alarm keeps going off
    By MgHart in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 27
    Last Post: 16th January 2009, 11:16
  2. Audi TT - Alarm keeps going off!
    By Burnhamhurst in forum TT/TT-S/TT-RS Forum
    Replies: 0
    Last Post: 12th March 2008, 14:54
  3. Alarm keeps going off unprovoked
    By Red Head in forum A3/S3/Sportback (8P Chassis)
    Replies: 13
    Last Post: 3rd December 2007, 15:39
  4. urgent help needed Alarm keeps going off but it's very odd
    By GFORCE in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 18th April 2007, 22:59
  5. Damn alarm keeps going off. Any ideas as to the cause?
    By SyA3Turbo in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 4th February 2006, 09:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO