Monster MotorsportBadger5
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    5

    A3 8P Aftermarket Reverse Camera/DIS Issue

    Hi

    I thought I'd have a go at fitting a reversing camera to my A3 since I've got a new driveway and seeing down it to reverse is a bit difficult because of the angle.

    I've got RNS-E and an aftermarket AV input unit, (not the Kufatec one, it's from Poland), that works great with my iPhone 4 on video & audio. (I've run an Apple AV iPhone lead to the armrest and the iPhone sits in there. It charges with the help of a USB power port in the glove box next to the multimedia interface).

    I've fitted a number plate camera, (eventually - that was a SOB I can tell you), and have run the ground to a ground point in the boot lid and the +12 line to the reversing positive of the rear light cluster. I've fed the video lead to the glove box for the AV input prior to full install. I'm currently in the testing phase.

    As I suspected would happen, the car is throwing a fault code for reversing light failure, probably due to the CAN and diagnostics nature of the car. Also, the picture will flick on and off a few times when engaging reverse and then disappear. Not sure if this is also related to diagnostics but the long and the short is, no camera or reverse light.

    I'd love an answer to a few questions if anyone can help.

    1) Is the supposition about the CAN diagnostics correct?
    2) Is there a permanent 12V in the boot lid that won't throw a fault.
    3) Can I pick up the reverse signal to feed the RNS-E from the current line or do I need to find an alternative.

    I've searched the forums for help but am stuck. I got the inspiration from this thread originally, a brilliant thread BTW.

    Reverse Camera

    I'll PM Woorlord, the OP on the thread above and any help from anyone would be gratefully received.

    Car is 2004 A3 8P 3.2 Quattro S-Line
    RNS-E
    MFSW
    BT
    NAV
    SDS high
    Phat Box
    and 1/2 camera

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Woorlord's Avatar
    shifting to Hyperspace... .

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Tiptree, Essex
    Posts
    948
    Another A3 forum member reported similar problems!

    I would suggest you check all connections thoroughly with either a DVM (Digital Volt Meter) or 12v Test lamp.

    In summary, use the following points for Reverse Camera Power:

    • Camera +12v "Red" Wire -to- "Red/Blue" Reverse light feed (assuming same colour convention as A4 wiring loom). This feed can also be used for the RNS-E "RVSL" signal to auto-select the Reverse Camera feed.
    • Camera 0v "Black" Wire -to- light cluster "Brown" wire this is a good earth and more reliable than an earth post in the boot lid.
    Solder all wires for good connections as opposed to using Skotch locks. Use heatshrink or insulation tape to cover the joins.

    Always check all connections with a Test lamp and/or DVM.

    You say that the DIS is throwing up a reverse light bulb failure/error?
    (This is nothing to do with CAN-bus, this is used for data communication between units, like RNS-E to BT etc.)
    DIS is simply detecting if it can see a pre-determined current feed to the reverse bulb - if it is zero (bulb blown) or less than the expected current feed for a bulb then a DIS error will be reported.
    So you say you have no reverse light or camera power feed - re-check the connections you have made as this sounds to be your problem. Not surprised the DIS say Reverse light failure!
    Make sure any metal parts of the power plug are insulated and can not touch the chassis.
    2001 A4 Saloon 3.0 Quattro Sport Tiptronic - Platinum Leather/Heated Front Seats/BOSE/DIS/Cruise Control
    Retrofits:GmBH Bumpers, F&R Ambient LEDS, OEM Valeo Xenons (D2S) & Headlight Washers, Auto-dipping RVM, Footwell Lights, Vent Control illumination, ISO-Fix, RNS-E & OEM Bluetooth + VIMhack + Video i-pod & Aux inputs, Rear PDC, Powerflow 100mm Tips, Reversing Camera
    2012 A4 Saloon 2.0 TDIe Technik (163ps)
    Diagnostics:VCDS HEX+USB+CAN Cable

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    5
    Thanks for the help. I have the +ve to the blue/red and I'll move the -ve to the brown tomorrow. I'll also check the connection but I didn't scotch it, I cut the wire and inserted a spade connector with camera and RVSL wires paired in. I buzzed the connections to the terminal in the light housing where the bulb goes and to a random point on the body for earth and all buzzed through okay. It was getting dark and cold though so I'll double check tomoz.

    Cheers for your help.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    1
    Any luck on the reverse cam? I'm having the same problem ie image is garbled. There must be an interference somewhere. I tried connecting the camera to my ctek 12v battery charger on supply mode and the camera works fine. Right now the camera trigger and the +ve from the camera is connected to the reverse light bulb. Funny thing is, with the engine off and reverse gear selected, it works fine.

    Marc

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2010
    Posts
    5
    I've not had anyluck so I've wired direct to a 12V feed in the boot area rather than arse around with interference. It does mean that the camera is on all the time but I don't suppose that matters really.

  7. #6
    Woorlord's Avatar
    shifting to Hyperspace... .

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Tiptree, Essex
    Posts
    948
    On my camera wiring there was a moulded lump in the cable which gets warm when power is supplied to the camera. I am guessing that this is a voltage regulator taking the power from 12volts down to a lower voltage. You may want to check this on your camera loom if it is on with the car ignition.
    2001 A4 Saloon 3.0 Quattro Sport Tiptronic - Platinum Leather/Heated Front Seats/BOSE/DIS/Cruise Control
    Retrofits:GmBH Bumpers, F&R Ambient LEDS, OEM Valeo Xenons (D2S) & Headlight Washers, Auto-dipping RVM, Footwell Lights, Vent Control illumination, ISO-Fix, RNS-E & OEM Bluetooth + VIMhack + Video i-pod & Aux inputs, Rear PDC, Powerflow 100mm Tips, Reversing Camera
    2012 A4 Saloon 2.0 TDIe Technik (163ps)
    Diagnostics:VCDS HEX+USB+CAN Cable

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO