Volks AutosAH Fabrications
Results 1 to 2 of 2

Thread: Speedo Probs

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2003
    Posts
    1

    Speedo Probs

    Lo all

    just got my s2 a few days ago, been serching the net lookin for answers, and so far found nothing except this forum, so im hoping someone can help me please...

    Last night i was out in my s2 (3B) and speedo was working fine, no probs atall..

    Got up this morning, jumped into it to go to work and noticed the speedo not working

    checked it at lunch time and still nothing (only thing i noticed was the speedo flickers slightly, when ignition is turned on)

    when i left work tonight it still wasn't working, then when sat in traffic it started jumping slightly (approx 100 rpm) then all of a sudden, it started to work properly

    Had to stop at petrol station on way home, and when i started it up again, speedo had stopped working again

    so does anyone have any idea's as to whats wrong ? or how much to fix it ?? and a breif description of how to fix and what bits are needed would be very nice

    thanx in advance


  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Jan 2003
    Posts
    36

    Re: Speedo Probs

    It is probably the white plastic that has come away and fouling on the needle - very common problem.

    HTH
    PS - www.s2forum.com has lots of info on this

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO