Chris NottMonster Motorsport
Results 1 to 17 of 17
Like Tree2Likes
  • 1 Post By theblueflash
  • 1 Post By Cruiser89

Thread: trouble with bluetooth retrofit (tech advice needed)

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13

    trouble with bluetooth retrofit (tech advice needed)

    I was planning on fitting the kit (module, mic, antenna, loom) and coding this myself but after looking at the kit ive come across a problem



    I have no idea why the other end of the loom has been cut off but this is what ive received. It was a good price so Im not too annoyed but I now need some help getting it all wired in properly. Basically the wires in the pic are the other end of the bluetooth module.
    I believe there should be a plug on the end of all this? Which then plugs into the stereo block (pictured) and then into the stereo itself.

    If so is this available from audi or an electrical retailer? Or can it be hard wired in?

    Im obviously at a stop with the whole job until I can work this out so any advice or a part number if someone knows or is willing to look would be really appreciated

    car is an 8P A3 and the stereo is an Audi chorus if thats needed

    many thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    You've got the non pnp loom, you will need some repair wires from audi, possibly a 12 pin connector & solder some other wires to 4 existing ones.

    We offer install services if interested.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    Quote Originally Posted by NHN View Post
    You've got the non pnp loom, you will need some repair wires from audi, possibly a 12 pin connector & solder some other wires to 4 existing ones.

    We offer install services if interested.
    Thanks for the reply. I'd really like to have a go at installing it all myself as I bought a genuine vcds I feel I need to get my monies worth from it and my girlfriend will be rather impressed as its her car!

    I'll run into Audi and see about the repair wire and a relevant connector but would anyone be able to tell me which wires I need to connect up? Or a link to a wiring diagram. Hope I'm not asking too much?

    Cheers

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    ok so audi are useless!!! 2 dealerships are unable to help. Im considering going to an audio specialist now but even they cant help unless I drive there and show them what I need.

    is anyone with bluetooth willing to pull their stereo out and write the part number on the plug down?

    would be seriously appreciated

  6. #5
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    You still need to solder the canbus & power wires to existing & other wires need 000979009ea wires added to be able to plug into 12 pin connector, so unless you're confident doing this level then get someone else to do it for you.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    ok so got an entirely new problem

    as audi and vw were both useless in supplying me with what i needed i just bought a plug and play loom to try and get this finally finished.

    all plugged in and followed this guide OEM Bluetooth Kit RETROFIT GUIDE - With Pics :)...........to the letter even buying the loom from the link the op suggested all with the exception of actually installing everything

    So far all that works is the mic (can hear when speaking into it dialling out from mobile) and the bluetooth connection (phone to car)

    I dont have any audio though, in call or radio. the whole thing is on and working and the steering wheel retains its volume and frequency controls but doesnt access the phone book when connected to a phone or have sound through any speakers

    I have used the instructions to alter the coding in vcds but changing them as per guide or to what I think they should be based on the values in the popup balloon have not yielded any different results. regardless of what i change them to if i unplug the p&p loom and reconnect the original quadblock the radio fires straight up and the speakers work.

    so im lost now.

    fault codes from each controller

    Wednesday,09,October,2013,20:37:34:22549
    VCDS Version: Release 11.11.6 (x64)
    Data version: 20121223

    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------

    Address 56: Radio Labels: 8J0-035-1xx-56.clb
    Control Module Part Number: 8P0 035 152 C HW: 8P0 035 152 C
    Component and/or Version: R Chorus2+ H20 0270
    Software Coding: 0200221
    Work Shop Code: WSC 06314 000 00000
    VCID: 2B53393D8A5D2540A59
    4 Faults Found:


    01044 - Control Module Incorrectly Coded
    000 - -
    Freeze Frame:
    Fault Status: 01100000
    Fault Priority: 5
    Fault Frequency: 1


    00466 - Control Module for Steering Column Electronics (J527)
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 147
    Mileage: 114126 km
    Time Indication: 0
    Date: 2013.10.09
    Time: 20:28:26


    00874 - Treble Speaker Front Left (R20)
    011 - Open Circuit
    Freeze Frame:
    Fault Status: 01101011
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 107
    Mileage: 114126 km
    Time Indication: 0
    Date: 2013.10.09
    Time: 20:12:39


    00875 - Treble Speaker Front Right (R22)
    011 - Open Circuit
    Freeze Frame:
    Fault Status: 01101011
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 107
    Mileage: 114126 km
    Time Indication: 0
    Date: 2013.10.09
    Time: 20:12:39

    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------

    Address 16: Steering wheel Labels: 8P0-953-549-F.lbl
    Control Module Part Number: 8P0 953 549 F HW: 8P0 953 549 F
    Component and/or Version: J0527 H36 0070
    Software Coding: 0003012
    Work Shop Code: WSC 06314 000 00000
    Additional Info: XXXXXXXXXXX E0221 H02 0030
    Additional Info: Geraet 00000
    VCID: 418F7B9518D1DF106F5
    3 Faults Found:


    01304 - Radio
    004 - No Signal/Communication - Intermittent
    01303 - Telephone Transceiver (R36)
    004 - No Signal/Communication - Intermittent
    01301 - Control Module for Voice Recognition (J507)
    004 - No Signal/Communication - Intermittent

    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------

    Address 77: Telephone Labels: 8P0-862-335.lbl
    Control Module Part Number: 8P0 862 335 H HW: 8P0 862 335 H
    Component and/or Version: FSE_255x BT H21 0290
    Software Coding: 0001222
    Work Shop Code: WSC 06335 000 00000
    VCID: 3B73097D7A3DB5C0359
    4 Faults Found:


    00447 - Function Limitation due to Over-Voltage
    001 - Upper Limit Exceeded - Intermittent
    Freeze Frame:
    Fault Status: 00100001
    Fault Priority: 7
    Fault Frequency: 1
    Reset counter: 191


    01523 - Microphone for Telephone (R38)
    011 - Open Circuit
    Freeze Frame:
    Fault Status: 01101011
    Fault Priority: 5
    Fault Frequency: 2
    Reset counter: 107


    00466 - Control Module for Steering Column Electronics (J527)
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 82


    01304 - Radio
    004 - No Signal/Communication - Intermittent
    Freeze Frame:
    Fault Status: 00100100
    Fault Priority: 5
    Fault Frequency: 1
    Reset counter: 147
    Mileage: 114073 km
    Time Indication: 0
    Date: 2013.10.09
    Time: 17:54:21



    screen shots of coding with original values







    any suggestions for coding based on the above info or anywhere ive gone wrong or things ive missed pls dont hesitate to mention it.

    sorry for the long post but not sure where to go from here

    tech specs

    2008 Audi A3 8p
    multifunction steering wheel
    Audi Chorus

    cheers
    Last edited by theblueflash; 9th October 2013 at 21:49.

  8. #7
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    The radio isn't coded for telephone, 2 digit in needs to add a 4 to the existing 2 to make it 6.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    Ok so this morning had another go. I'd already tried your suggestion Nigel but did it again anyway. Tried a different steering wheel code so I've now got the mode button working.

    So I can now connect, scroll and dial out but there is still no audio in call and there is no music with or without a phone connected.

    Any other coding changes which will help this cos I'm starting to think there may be a fault in the lead I've bought.

    Many thanks

  10. #9
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    If you've coded the gateway, radio, steering module all correctly & its still not working, then wiring is the next port & if its still not working, then consider module at fault.

    TBH if you've exhausted your options, then get someone to come out & look at for you.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    UPDATE

    All up and running now. Many thanks to Nigel for coming out and diagnosing the faulty Bluetooth module. Managed to get another sent out by the seller next day. All wired in and coded and it works without fault. Much better than the aweful bury system that was in there when we got the car.

    Nice to meet you BTW Nigel. Cheers again
    NHN likes this.

  12. #11
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    No worries glad to have met you mate & found the issue, thanks for the tea

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    Quote Originally Posted by NHN View Post
    No worries glad to have met you mate & found the issue, thanks for the tea
    Twinings finest!

    *Update*

    Still can't get my girlfriends iPhone to connect. It can't even find it when searching. I can connect my nexus 4 within seconds and make calls perfectly (obviously as its android)

    Anyone got any tips for getting the silly apple thing to work? Its been through 2 iOS updates since I installed the module to the car but neither have changed its function. Little frustrating as it needs to work or I've wasted my money buying the kit in the first place

    Cheers

  14. #13
    Cruiser89's Avatar
    Advanced In Car Technologies

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Bournemouth, Dorset
    Posts
    1,397

    My Social Networking

    Follow Cruiser89 On Twitter Add Cruiser89 on Facebook Visit Cruiser89's Youtube Channel Visit Cruiser89's Instagram Channel
    Quote Originally Posted by theblueflash View Post
    Twinings finest!

    *Update*

    Still can't get my girlfriends iPhone to connect. It can't even find it when searching. I can connect my nexus 4 within seconds and make calls perfectly (obviously as its android)

    Anyone got any tips for getting the silly apple thing to work? Its been through 2 iOS updates since I installed the module to the car but neither have changed its function. Little frustrating as it needs to work or I've wasted my money buying the kit in the first place

    Cheers
    Biggest resolve I have found when I hear this is make sure your phone is nowhere near the car or make sure it's disconnected. Lots of my customers have had this problem and it turned out their phone was still connected.

    Rule of thumb is also to make sure you pair it within the first 30 secs. Some systems only search for a certain time.

    There shouldn't be any real reason why the iPhone won't connect.
    NHN likes this.

    Tim - Project & Marketing Manager of Advanced In-Car Technologies LTD. An Audi Approved OEM / Retrofit Specialist Company. All views expressed are my own and bear no reflection on Advanced In Car Tech.



    Audi Bluetooth -AMI/iPod - RNSE Navigation Units - Cruise Control - Optical Parking Systems - DAB (Digital Radio)- Audi Factory Retrofits- Stolen Vehicle Tracking - In-Car Cameras- Genuine VCDS Cables

  15. #14
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,774
    The module version also as an impact with some handsets, this is why I advised to have the latest version so you don't face potential headaches connecting, syncing, etc, what version did he supply you as a replacement?

    TBH you should be able to connect anytime with most modules, mine connects whenever, as I run custom roms on my droid OS, I often connect/disconnect when testing something & this is even when its a long drive, but certainly do as Tim suggests as at least it can be discounted, BT versions & compatibility is so flaky its unreal.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    Quote Originally Posted by Cruiser89 View Post
    Biggest resolve I have found when I hear this is make sure your phone is nowhere near the car or make sure it's disconnected. Lots of my customers have had this problem and it turned out their phone was still connected.

    Rule of thumb is also to make sure you pair it within the first 30 secs. Some systems only search for a certain time.

    There shouldn't be any real reason why the iPhone won't connect.

    Thanks for the tip. Although I dont think this is the problem. The phone isn't that old and its never been connected to any device and has never been connected to the car (despite a million attempts). Did try it anyway when she left her car at home and went out for the day but it made no difference.

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    Nigel. By version are you referring to the part number of the module?

  18. #17
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    13
    As I'm not an iPhone user I suppose I can be excused from not knowing. Apparently there is a setting which now stops the iPhone searching for 'all' Bluetooth devices and just those that appear in your contacts. Who knew? Helpful I thought. Only problem is that before I figured this out I could still find the neighbours ford galaxy Bluetooth when I was testing last weekend.

    Anyway. If you go into the airdrop settings there is the option to search for all Bluetooth devices which brings up the neighbours Ford and the audi. So now the iPhone connects and disconnects perfectly.

    Thanks for everyone's help and thanks apple for the headache. Problem solved

 

 

Similar Threads

  1. Tech advice needed regarding S3 8L
    By MILF in forum A3/S3 Forum (8L Chassis)
    Replies: 16
    Last Post: 15th November 2012, 19:05
  2. Another Newbie...with some urgent advice needed!!
    By Si_Sline_Cab in forum The Welcome Section
    Replies: 4
    Last Post: 8th June 2007, 00:30
  3. hids4u retrofit bi-xenon kit advice needed
    By skanky in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 13th September 2006, 22:27
  4. Urgent Advice Needed Please with my Audi S3
    By lUCKYS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 29th August 2006, 12:53
  5. Help / Advice needed with part number
    By LeeW in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 28th February 2006, 23:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO