Monster MotorsportVolks Autos
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    5

    Unhappy A3 8L TDi DIS Retrofit

    Hi,

    I have installed a DIS dash into my 2002MY Audi A3 8L TDi PD130 and has been coded by a dealer so it starts the car on all 3 keys.

    Previous dash part number was 8L0920950D > Which I changed to 8L0920980N (with the grey/white dials)

    I have Earthed the pins for the Washer Fluid/Bulb check warnings to the dash just behind the headlight switch, this turned the warnings off!

    Grey 32 Pin Plug on back of Dash Insert which I earthed:
    Pin 14 - Brake Light
    Pin 15 - Washer Fluid
    Pin 16 - Reverse/Sidelights

    Wiring for the Stalk:
    Pin 17 - Stalk control Left (wire colour- Green) -Connects to the black 6 pin plug on the Stalk (Pin 2)
    Pin 18 - Stalk control Right (wire colour- Blue) -Connects to the black 6 pin plug on the Stalk (Pin 1)
    Pin 17 - Stalk control Reset (wire colour- Grey) -Connects to the black 6 pin plug on the Stalk (Pin 4)

    The new dash works fine apart from the Radio does not turn on and off with the ignition neither will it illuminate with the sidelights/headlights but I can turn it on manually fine but with no button lighting. I believe this issue is to do with the CANBus wiring and the 20 pin Black Connector on the Concert 2 Radio.

    Looking at the wiring diagram I need to connect from the Grey 32 pin plug:
    Pin 5 > Pin 7 on the 20 pin plug on the radio (CAN high speed display (high +)
    Pin 6 > Pin 12 on the 20 pin plug on the radio (CAN high speed display (low -)

    My problem is that there are already wires in these 2 pin locations on the radio,
    Do I need to cut both wires and isolate the ones which are already installed and replace them with the wiring from the Grey 32 pin plug from the dash straight into the 20 pin connector?
    -or-
    do I need to join into the factory wiring so my radio will come on with the ignition and light up with the sidelights?

    Also I am trying to find the correct location to install the passenger door open warning, I have tried to use the Brown 10 pin Connecter in the passenger footwell/a pillar at Pin 7 but for some strange reason with the passenger door shut the warning stays on and keeps the interior light on when it should be off. Im finding that there is a feed coming through the Grey 32 pin connector from pin 8 which needs to be connected pin 7 on the brown connector which I believe is back feeding somehow?

    Please someone help, I'm having a mare with this :/

    Rich.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    5
    Forgot to add,

    On the wiper stalk 6 pin connector you need to install a wire from pin 3 (earth) to pin 6 (earth - brown) or else your wiper DIS switches won't work without being earthed from pin 3 as ive found out

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    49
    MR P,

    Did you ever sort this out?

    I have the same issue with the Radio.

    Thanks

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Posts
    5
    Hi, yes I got the issue fixed by plugging everything in, there are the 2 wires which have to be cut on the 20pin connector on the radio and joined onto the dash,

    Once this has been done you will need to code the dash to the radio by your local dealer as the radio will be confused as the signals it was receiving before the dis dash was installed have now changed and needs to be coded for the new dis dash infotainment can bus.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    1
    Quote Originally Posted by Mr.P View Post
    Hi,

    I have installed a DIS dash into my 2002MY Audi A3 8L TDi PD130 and has been coded by a dealer so it starts the car on all 3 keys.

    Previous dash part number was 8L0920950D > Which I changed to 8L0920980N (with the grey/white dials)

    I have Earthed the pins for the Washer Fluid/Bulb check warnings to the dash just behind the headlight switch, this turned the warnings off!

    Grey 32 Pin Plug on back of Dash Insert which I earthed:
    Pin 14 - Brake Light
    Pin 15 - Washer Fluid
    Pin 16 - Reverse/Sidelights

    Wiring for the Stalk:
    Pin 17 - Stalk control Left (wire colour- Green) -Connects to the black 6 pin plug on the Stalk (Pin 2)
    Pin 18 - Stalk control Right (wire colour- Blue) -Connects to the black 6 pin plug on the Stalk (Pin 1)
    Pin 17 - Stalk control Reset (wire colour- Grey) -Connects to the black 6 pin plug on the Stalk (Pin 4)

    The new dash works fine apart from the Radio does not turn on and off with the ignition neither will it illuminate with the sidelights/headlights but I can turn it on manually fine but with no button lighting. I believe this issue is to do with the CANBus wiring and the 20 pin Black Connector on the Concert 2 Radio.

    Looking at the wiring diagram I need to connect from the Grey 32 pin plug:
    Pin 5 > Pin 7 on the 20 pin plug on the radio (CAN high speed display (high +)
    Pin 6 > Pin 12 on the 20 pin plug on the radio (CAN high speed display (low -)

    My problem is that there are already wires in these 2 pin locations on the radio,
    Do I need to cut both wires and isolate the ones which are already installed and replace them with the wiring from the Grey 32 pin plug from the dash straight into the 20 pin connector?
    -or-
    do I need to join into the factory wiring so my radio will come on with the ignition and light up with the sidelights?

    Also I am trying to find the correct location to install the passenger door open warning, I have tried to use the Brown 10 pin Connecter in the passenger footwell/a pillar at Pin 7 but for some strange reason with the passenger door shut the warning stays on and keeps the interior light on when it should be off. Im finding that there is a feed coming through the Grey 32 pin connector from pin 8 which needs to be connected pin 7 on the brown connector which I believe is back feeding somehow?

    Please someone help, I'm having a mare with this :/

    Rich.

    Hello !

    Do you have dump eeprom file for 8L0920980N ?

    Best regards Martins

 

 

Similar Threads

  1. colour dis retrofit?
    By paulsb in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 8
    Last Post: 13th July 2010, 13:29
  2. Anyone done a Cruise and DIS Retrofit?
    By chrisash32 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 95
    Last Post: 20th March 2010, 15:52
  3. DIS Retrofit - Digital Speedo??
    By StagsyA4 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 6
    Last Post: 25th February 2010, 07:36
  4. DIS retrofit near bristol/Bath
    By nvc in forum A3/S3/Sportback (8P Chassis)
    Replies: 3
    Last Post: 13th December 2009, 14:47
  5. DIS Retrofit-- OH Yes
    By gregormac in forum A3/S3/Sportback (8P Chassis)
    Replies: 20
    Last Post: 11th April 2009, 19:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO