Monster MotorsportEM Tuning
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By quattro25years

Thread: Emisson control light on. DIAGNOSTIC RESULTS ADDED (from breakdown people)

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112

    Emisson control light on. DIAGNOSTIC RESULTS ADDED (from breakdown people)

    I have just noticed that my emissions control light has come on.

    This is whats happening.

    with the engine running it sounds like there is a throbbing noise coming from the exhaust.

    also from the engine there is a ticking noise that sounds like chattering relays (quite loud).

    i took the plastic engine cover off and some thing is moving while the "chattering is happening), not sure what it is , can post a pic of what is moving if needed.

    After turning the engine off I could still hear the ticking noise for a few seconds.

    Any help would be much appreciated.


    many thanks
    Last edited by quattro25years; 20th April 2013 at 13:02.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,487
    Pictures would be good, also which model and year as well please. Thanks. x
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP


  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Hi Sandra

    getting a bit dark to take pics now. Will take pics tomorrow.

    model is 3.0 tdi s-line on a 56 plate.


    thank you for responding.

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Hi again,

    only earlier today I was thinking of buying a Ross tech cable!(posted this earlier today)

    And only this evening the engine management light has come on

  6. #5
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,487
    Quote Originally Posted by quattro25years View Post
    Hi again,

    only earlier today I was thinking of buying a Ross tech cable!(posted this earlier today)

    And only this evening the engine management light has come on
    Thats really bad luck that this has happened. When you post pics, one of the guys will be able to advise you. If you decide to buy a vcds cable user and site sponsor NHN sells the genuine ross tech vcds cable. x
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP


  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Hi thanks for that,

    i can see the part that is making the noise, its at the top of the engine bay on the right hand side.

    will post pic tomorrow.

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    ******** UPDATE ******

    made a mistake , it is not the engine management light ,

    just looked in my q7 manual on page 16 , the light that has come up is the "EMISSION CONTROL SYSTEM" light.

    sorry for the confusion.


    ....I have driven the car with the light on,no loss of power,




    help still needed though.
    Last edited by quattro25years; 19th April 2013 at 22:25.

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Hi

    Update

    Noticed this morning the TICKING NOISE happens when the ignition is turned on, but without the engine running.

    when the engine is running, I can see what looks like a lever moving, this "lever " is behind the component that says "made in USA" .

    i have uploaded a video to you tube with the ignition turned on , but engine not running.


    here is the link



    YouTube


    Will post video of engine running later this morning.

    Many thanks

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Hi

    earlier today called breakdown recovery .

    they plugged into the socket under sterring wheel, and the following error codes came up.


    04203 INTAKE AIR TEMPRATURE CIRCUIT



    05504 INTAKE MANIFOLD RUNNER POSITION SENSOR - SWITCH CIRCUIT HIGH BANK 1





    any help would be appreciated on above

    DOES THIS MEAN I HAVE TO HAVE THE INLET MANIFOLD REPLACED ?




    i have booked my car in with Poole Audi main dealer this tuesday

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Problem solved.

    had to have the throttle body replaced...replaced under warranty .

  12. #11
    The911SC's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Sep 2003
    Location
    South Wales - Swansea
    Posts
    1,032
    Yes it does - there is a known issue with the manifold runners on the 3.0 tdi engine where the linkages breaks and stops working.
    Porsche 997 Carrera 4 S - Black, Sport Chrono, Sport seats, PCM, Nav, Tel, Park assist and rear wiper (Yes!, its an option!)
    2012 Audi Q7 Sline Plus - Daytona Grey ,Nav+, Wheel upgrade, Storage and tow pack.

    Gone -2007 S5 4.2 ,2008 S3, 2007 TTC 3.2, 2007 RS4 Saloon, 2004 S4 Saloon, 2006 A4 2.0T Sline SE,2002 A3 3.2 Sline, 2001 A4 1.8T,2001 Boxster, 1983 911SC,1992 Corrado G60,1988 GTi.

    (Vag com owner)

  13. #12
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    There is a repair kit for swirl flap links now ...

    Item 1 in kit is the swirl flap link arm, item 2 swirl flap follower, item 3 locking clip ...
    Repair kit P/N 059 198 212 , same P/N for 19 different VAG's with V6 ...



    Red arrow highlight item 2 location and item 3 clip...



    Here is a video showing effect of wear on swirl flap follower/link arm ...



    Wear can also happen on the bearings for swirl flaps as well ...



    There is a TPI / TSB relating to this repair kit ...

    Technical product information Transaction No.: 2016504/19
    Engine warning light on, intake manifold flap function - V6 2.7 l, 3.0 l TDI Release date: 28-Feb-2012

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    DORSET
    Posts
    112
    Although my problem has been solved -thanks gupsterg for more info
    gupsterg likes this.

  15. #14
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    No worries ...

 

 

Similar Threads

  1. Engine Management Light + Fault Codes - Help
    By leeds2592 in forum A3/S3/Sportback (8P Chassis)
    Replies: 3
    Last Post: 20th January 2013, 14:05
  2. Engine management light is on, HELP!!!
    By evilbane in forum A3/S3/Sportback (8P Chassis)
    Replies: 13
    Last Post: 2nd December 2011, 10:30
  3. Engine Emmision Light on, Please help
    By adamf200 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 1st May 2010, 12:14
  4. Engine management light on, help me help a friend!
    By Prawn in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 15th September 2007, 14:47
  5. Help Engine Management Light On
    By taj in forum TT/TT-S/TT-RS Forum
    Replies: 6
    Last Post: 13th January 2005, 20:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO