JMB RetrofitsSky Insurance
Results 1 to 34 of 34
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Apr 2013
    Posts
    42

    Creaky mmi screen

    Hi,

    Has anyone else had this problem? After 4000miles the mmi screen has begun creaking and squeaking when in the up position, even on quite smooth roads. Obviously not a huge problem, but not very Audi-like either....so its going in to tighten some screws on Friday.

    Wondered if everyone's is doing this?

    Cheers.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    I've noticed the same, its quite annoying since everything else is so well built!

    I would be interested to know how you get on.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    Jenks108, did you get yours fixed, did it take long? Ours is squeaking more than ever so I guess its a trip to the dealers.

  5. #4
    Chappy's Avatar
    Call me Dan :)

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Grimsby, UK
    Posts
    450
    Mine makes the odd noise now and then, although I thought it was the B&O speaker grill behind it.
    AudiA3 2.0TDI S-Line

    Phantom Black | Leather Seats | Heated Seats | Black Optics | AMI | Badges Deletion | Rear Sunblind | Armrest | Darkened Glass | S3 Chrome Grill | H+R 10mm Spacers up Front | H+R 13mm Spacer at Rear | Mtec Cosmos Blue Bulbs | Cared for Paint Work |



  6. #5
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    40
    I get the odd rattle and creak every now and again but no idea where it's coming from!
    Audi A3 8V 2.0 TDI S-Line Scuba Blue
    | Comfort Pack | Technology Pack | Interior Light Pack | Bang & Olufsen Sound | Advanced Key | Deletion of Model & Tech | Privacy Glass |
    | Elec Folding, Heated & Dimming Mirrors | Perf Alcantara & Leather Seats |

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    Mine is definitely the MMI screen, if I hold it it goes away

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    Aberdeen
    Posts
    7
    Same problem with mine, started at around 5k on the clock, only notice it when the music is off though, and with the B & O system its rarely off so not bothered me enough to take in to get looked at.

  9. #8
    snakehips's Avatar
    3rd Gear

    Status
    Online
    Join Date
    Aug 2013
    Location
    North Herts
    Posts
    604
    When I first saw it I figured it was inevitable that this one moving part in the dashboard was bound to end up creaking, and creaking in the car drives me nuts! Hope they have a fix before I reach 4K miles...
    A3 SB S-Line TDi 184PS Quattro S-tronic. Shiraz Red, Tech Pack, Comfort Pack, B&O, Sunroof, LED lights, lots of other stuff.

  10. #9
    SJW
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Posts
    209
    Yes I had this issue. I thought it was down to heat being generated around that moving part causing the casing to expand and contract giving rise to the creaking sound. It has settled down now and I have done 6250 miles. If It becomes noticeable again I will have it looked at. Seems okay now. Perhaps just needed time to settle down.
    Sportback / 2TDI / Manual / S-Line / Amalfi White / Sport Suspension /
    Alcantara Leather Split / Heated Seats / Elec Lumbar / Phone Box / Audi Sound System / Sat Nav /
    Privacy Glass / Through Load / Rear Side Airbags / Tyre Pressure Monitor

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    6
    I have exactly the same issue.that's really annoying! Is there any update?

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Apr 2013
    Posts
    71
    I had it the one day and it was doing my head in. I pushed the top and the screen actually popped back in to the dash. I've not heard it since. I do play my music loud tho.
    Audi A3 Sportback 1.4 COD S Line
    Glacier White, Advanced Key, Audi Sound System, Comfort Package, Hold Assist, Interior Light Package, SD Sat Nav.

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    6
    It's really annoying.It's like,it's the only thing I'm hearing now while driving I couldn't find any solution.You mean you pushed the screen from top towards the front window?

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Apr 2013
    Posts
    71
    I just put pressure on the top. Not towards the window. Not a lot of pressure, I doubt it has fixed it to be fair, it will probably come back at some point.
    Audi A3 Sportback 1.4 COD S Line
    Glacier White, Advanced Key, Audi Sound System, Comfort Package, Hold Assist, Interior Light Package, SD Sat Nav.

  15. #14
    6th Gear

    Status
    Offline
    Join Date
    Sep 2013
    Location
    East Sussex
    Posts
    1,558
    Is this issue only with the larger screens?
    Now a proud owner of a A3 1.4 tfsi Saloon S-Line, 6-speed, Daytona Grey, Technology Pack, Comfort Pack, Cruise, Advanced Key, Privacy Glass, Audi Parking System Plus, Interior Lighting, Folding Door Mirrors, Light & Rain Sensor. Hold Assist.

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Horsham
    Posts
    225
    A bit OT I know but can I ask if the screen pops up whenever you start the car or only when desired? If the former can you set it to stay down unless required?

  17. #16
    JohnnyM100's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2013
    Location
    Hampshire/Surrey border
    Posts
    461
    Screen always pops up at startup unless MMI is switched off (so no radio/SD card music etc)

    There is a button to retract the MMI display with the radio/media card still working but that only works until the next time the ignition is turned on when the display pops up again automatically.

    It does not remember the "audio on but keep MMI retracted" at next start-up.

    John.
    Enjoying my 8V

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Horsham
    Posts
    225
    Thanks, I thought that would be the case. I wonder if that can be changed in VCDS?

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    May 2013
    Posts
    3,225
    Being able to remember the screen position between ignition off/on would be pretty nice. The car does it for a lot of other things so not sure why it wouldn't for this.

    Same goes for music paused or not - music always starts even if you paused/muted it last time you turned off the car.
    Sport 2.0 TDI 150 Sportback in Scuba Blue, alcantara/leather, advanced key, audi sound system, comfort pack w/ ACC and park assist, deselect sports suspension, auto-dimming & folding door mirrors, electric lumbar support, heated seats, hold assist, non-smoking pack, side & lane assist, reversing camera, storage & luggage pack, tech pack with audi connect, tyre pressure warning, towbar, variable headlight range control, xenon light pack

  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    6
    Is anyone find a solution? those creaks makes me mad!

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    6
    Quote Originally Posted by Coxy234 View Post
    I had it the one day and it was doing my head in. I pushed the top and the screen actually popped back in to the dash. I've not heard it since. I do play my music loud tho.
    Thanks,I will try it.I hope it works

  22. #21
    Aran383's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Aberdeen/London
    Posts
    67
    Quote Originally Posted by Johnes View Post
    Is anyone find a solution? those creaks makes me mad!
    I had the same problem, so took it into audi back in September and they changed the mmi screen and the unit, haven't had any creaking since then!
    Sold- Audi A1 1.4 TFSI Sport

    Sold- Brilliant Black Audi A3 8V S-Line 1.4 TFSI, SD card based Sat Nav, Privacy glass, S-Line suspension, Hill Hold assist, Audi sound system, Parking system.

    Now- Brilliant Black Audi S3 8V 3dr S-Tronic, SD card based Sat Nav, Privacy glass, audi sound, parking sensors-rear, Black styling pack, light and rain sensor pack, Tyre pressure monitor, Alcantara seats.

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    12
    Took mine in to Derby Audi on Monday 24.03.14 for creaking mmi screen. They took it out and lubricated it, all seamed well until today now the creaking is back, very annoying.

  24. #23
    Neutral

    Status
    Offline
    Join Date
    Apr 2013
    Posts
    42
    The creaking on mine came back too, but now it's cured itself.

  25. #24
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    Apparently Audi changed our mechanism but it seems to have come back. I think it might be worse on sunny days. Most certainly it wasn't too bad over winter but now the sun has come out its getting worse again. Its so annoying sometimes I have to hide the display!

  26. #25
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    12
    Pressing the screen down by hand silenced mine for a few days. This has been my only issue with the car since owning it apart from someone scraping by bumper whilst parked

  27. #26
    pat15312's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Leicestershire
    Posts
    257
    Quote Originally Posted by Jenks108 View Post
    Hi,

    Has anyone else had this problem? After 4000miles the mmi screen has begun creaking and squeaking when in the up position, even on quite smooth roads. Obviously not a huge problem, but not very Audi-like either....so its going in to tighten some screws on Friday.

    Wondered if everyone's is doing this?

    Cheers.
    If you let the dealership p*** about with the dash it will most likely come back worse - got personal experience with this...

    I suggest you put the music up louder mate.
    Audi 8V S3 s-tronic
    Phantom Black | Black styling pack | Titanium 18" alloy wheels | LED headlights
    Super sports seats | mono.pur
    | Bang & Olufsen | Advance key | Interior LEDs
    Technology pack | Audi Connect | Parking System Plus | Reversing Camera
    ACC | Hold assist | Pre-sense | Headlight assist | Privacy glass | TPMS
    LTE data by EE | Paint protection by Gtechniq | more to come...

  28. #27
    snowfree52's Avatar
    Full LED baby !

    Status
    Offline
    Join Date
    May 2013
    Posts
    466
    you can't put it louder than the noise

    Anyway, I went already twice to the dealer, first time it went silent for 2 months then came back. This time they had a specifically made grease (what they said) by Audi Germany for this particular problem on the GPS. they know what part is causing it.

    A3 3-door TDI 184 Quattro Stronic Brilliant Red : Sline kit - Auxiliary heating - LED headlights - 18" 10-spoke rims - audi connect - magnetic ride - driver assistance package - side assist - rear camera + park assist - alcantara/leather seats - auto dimming mirror - panoramic glass sunroof - towing equipment - electric lumbar support - heated front seats - hold assist - high beam assist - advanced key - B&O sound system etc
    Tuning box DTUK, 235hp/480Nm
    1/4 Mile 13.84 @ 95.2 MPH
    Porsche BBK...

  29. #28
    PDA3's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2014
    Posts
    59
    Sounds loose! What's that other item you have attached to the dash too?!
    Using Tapatalk

  30. #29
    snowfree52's Avatar
    Full LED baby !

    Status
    Offline
    Join Date
    May 2013
    Posts
    466
    something I had for my phone, but the noise comes from the GPS screen
    A3 3-door TDI 184 Quattro Stronic Brilliant Red : Sline kit - Auxiliary heating - LED headlights - 18" 10-spoke rims - audi connect - magnetic ride - driver assistance package - side assist - rear camera + park assist - alcantara/leather seats - auto dimming mirror - panoramic glass sunroof - towing equipment - electric lumbar support - heated front seats - hold assist - high beam assist - advanced key - B&O sound system etc
    Tuning box DTUK, 235hp/480Nm
    1/4 Mile 13.84 @ 95.2 MPH
    Porsche BBK...

  31. #30
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    4
    I have the the same noise about 20 days now at 22000km. I will ask to replace my screen, since it is within the warranty time.

  32. #31
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    Quote Originally Posted by papaspeter View Post
    I have the the same noise about 20 days now at 22000km. I will ask to replace my screen, since it is within the warranty time.
    Let us know if this fixes the problem!

  33. #32
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    12
    Took my A3 back to Derby Audi again today, fingers crossed they cure it.

  34. #33
    1st Gear

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    103
    Quote Originally Posted by chute1860 View Post
    Took my A3 back to Derby Audi again today, fingers crossed they cure it.
    It would be great to hear your feedback and whether or not they fixed it!

  35. #34
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    12
    Got my A3 back yesterday, early yet but all seems well.
    fitted me a new mmi mechanism then rigorously tested it.
    Service and loan cars at Derby Audi very good even gave me a bottle of champagne for not fixing it the first time.
    hope this helps

 

 

Similar Threads

  1. How to remove the Anti-glare from the MMI screen?
    By Laz in forum A5/S5/RS5 Forum
    Replies: 13
    Last Post: 11th April 2013, 13:40
  2. MMI screen issue
    By WingoWango in forum New A3/S3 (8V Chassis)
    Replies: 9
    Last Post: 15th March 2013, 17:54
  3. MMI Screen on facelift C6 better res?
    By Teemsta in forum A6/S6/Allroad forum (C6 Chassis)
    Replies: 1
    Last Post: 3rd May 2012, 20:13
  4. My MMI Screen is very dim...
    By abyzz in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 1
    Last Post: 18th March 2012, 23:40
  5. Replacement of Sat Nav / MMI screen?
    By monkeytrousers in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 5
    Last Post: 11th February 2010, 21:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO