EM TuningJMB Retrofits
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2007
    Posts
    1

    Multitronic "sticks" in Sport mode

    Hi,
    Has anyone experienced the same strange fault that I am having? Any ideas from anyone on how to fix it?

    Car - 2004 A6 Avant, 1.9TDi, Multitronic, 90k miles

    A couple of minutes after cold startup, the gearbox selection (as shown on the dash) keeps changing from D to S and back on it's own. The gearbox responds by selecting a lower ratio. Whilst it is "stuck" in S mode, moving the gearstick to manual override has no effect, it stays in S mode. After a few seconds it returns to normal. It can do this 10~20+ times until it eventually returns to normal as the car reaches temperature.

    The temperature dependancy may be a red herring.

    My thought are that it's a simple limit switch in the gearstick or a bad contact in the wiring loom to the ECU.

    Any ides appreciated.

    Tim

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    foolish3uk's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2004
    Location
    in middle of nowhere
    Posts
    458
    for it to be flickering between d and s it has to be a switch fault, probably either a selector switch fault in the gear selector mechanism or a multi function switch which is built into the gear box control unit.
    its hard to say which it would be you need to have it scanned for fault codes, multitronics are always going wrong unfortunately!

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    2

    Multitronic "sticks" in Sport mode

    Hi Tim,

    Have you managed to sort the problem out yet ?

    I have the exact same problem, just as you described. I've got a 2005 A4 2.0L Multitronic with 135K KM (about 80K Miles) and it started doing this about 2 weeks ago. Took it to Audi and the Techs there do not have a clue as to the cause. They say that the Gearbox ECU is not recording any faults (even after a software upgrade) though they did physically see the car doing it for themselves while test driving it.

    They are of the opinion that the Gearbox ECU itself is at fault and want to replace the complete unit which is hellishly expensive.

    I'm no mechanic of any sort, but common sense is telling me that it cannot be the ECU as after a few minutes, everything returns to normal and the car runs 100% perfect for the rest of the time - so long as you don't let the Gearbox cool down (say leaving it turned off for more that 30-45min).

    Something else that I found is that as soon as the problem starts, you cannot select Reverse gear. You have to first select Sport mode, then push the selector into Neurtal - it will then switch over to the backup ECU program (indicated by the flashing P-R-N-D-S display on the Dash - which by the way seems to disable sport mode) and only then will the reverse gear engage.

    To me, it must be a switch of some sort, as foolish3uk says, either on the Gear Selector or the one build into the Multitronic Control Unit.

    Raven

  5. #4
    Gti Jazz Blue's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Feb 2007
    Location
    Hampshire
    Posts
    1,654
    Quote Originally Posted by Raven
    I'm no mechanic of any sort, but common sense is telling me that it cannot be the ECU as after a few minutes, everything returns to normal and the car runs 100% perfect for the rest of the time - so long as you don't let the Gearbox cool down (say leaving it turned off for more that 30-45min).

    Something else that I found is that as soon as the problem starts, you cannot select Reverse gear. You have to first select Sport mode, then push the selector into Neurtal - it will then switch over to the backup ECU program (indicated by the flashing P-R-N-D-S display on the Dash - which by the way seems to disable sport mode) and only then will the reverse gear engage.
    Is the Gearbox ECU actually mounted on the Gearbox ? If it is it sounds like the ECU has a cold fault and there is some kind of contact problem (connector or circuit board) when it is cold (could also be an ecu componant). There are firms out there that re-work ecu parts and it may be worth seeing if they can fix yours - other option is possibly a secondhand ecu from a breakers.

    See http://www.bba-reman.com/index.htm for help with ecu repairs.

    Just my thoughts BTW I'm not saying 100% it is the ecu but that would be my suggestion, could even be a loom issue where it hits the ecu. You really need a good auto-electrician or independant Audi specialist.

    Paul
    2011 (MY12) Skoda Octavia II FL VRS Manual Hatch 2.0Tsi in Race Blue.
    Gone not forgotten -
    2005 Black A3 (8P1) S-Line 2.0TDi DSG. Eibach Pro Springs, Koni FSD shocks and a few bling bits inside.
    Revo 99 GTi Turbo, too much to list mod wise.
    92 Golf Gti Mark 2 16V.

    VCDS HEX-USB+CAN

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    2
    Thanks for the suggestion Paul - I will see if I can find someone here that reconditions Audi ECU's.

    The Audi techs say they are waiting to hear from Audi Germany - which could be days or months. I just hope that I'm not damaging things further by driving my A4 in the meantime.

  7. #6
    foolish3uk's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2004
    Location
    in middle of nowhere
    Posts
    458
    what dealer are you taking it too, do they only have apprentices there?? this is a very common fault, we are doing a few a week on average, there can only be two possibilitys with this type of fault, either a gear box control unit or a selection plate on the gear selector, it probably 100% going to be a control unit tho, i hope they are not charging you as they dont know what is at fault, the gearbox ecu is at the back of the gearbox inside the box itself and bolts to the hydraulic control unit. the fault with it is the multifunction switch, this is not availiable seperately as with the standard gearboxs it is built in, unfortunately they are expensive and the time to replace on is about 2-3 hours depinding on which engine you have, sorry dude, take it to a gearbox specialist they might do recon units!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO