AH FabricationsVolks Autos
Results 1 to 9 of 9
  1. #1
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Problem fixing mates car

    Right before we start he owns a Rover 620ti ,i have spoke to him about his illness but he wont go and see the doctor about it [img]/ubbthreads/images/graemlins/bang.gif[/img]

    The problem is with the turbo as in lack of it ,no boost at all

    Hunts when ticking over

    Revs to 4500rpm under load but struggles to go any further with out a lot of engine noise

    My thinking it is the MAF?

    Checked for leaks

    Any help would greatful

    Cheers

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    TDI-line's Avatar
    Uber Post Whore

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Peterborough
    Posts
    8,885

    Re: Problem fixing mates car

    Sounds like RCS.






    Rover Car Syndrone.

  4. #3
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Re: Problem fixing mates car

    Yea i know ..........have been told it could be a crank sensor loose know ?

  5. #4
    28v6
    Guest

    Re: Problem fixing mates car

    Your on the right lines rev... look for the crank shaft sensor, clean until spotless then refit using carb cleaner.. also look for a camshaft sensor / hall sender and clean the same way and refit.. problem cured....

    Hunting on tickover could be the Idle stabilisation valve needing cleaned in the same manner and lubed with 3in1 oil.. then refit, don't panic if on refit the idle goes to about 1500rpm... it will reprogramme itself to the ECU, its like installing a new valve its not calibrated to the car.. also look for vacuum leaks , these also will make the idle hunt...

  6. #5
    pwnorman's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2003
    Location
    north yorkshire
    Posts
    402

    Re: Problem fixing mates car

    Think the problem could be solved by a good scrap yard.

  7. #6
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Re: Problem fixing mates car

    i said the scrap yard to but he just hit me,,,,,,

    Cheers 28v6 when it stops raining i will be on the case an dhope that sorts the problem

    Cheers

  8. #7
    28v6
    Guest

    Re: Problem fixing mates car

    Any News Rev??? [img]/ubbthreads/images/graemlins/beerchug.gif[/img]

  9. #8
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Re: Problem fixing mates car

    Working on it today or tomorrow been [img]/ubbthreads/images/graemlins/swear.gif[/img] down with rain here so not had a chance to look at it
    Will keep you posted

    60,000miles on the clock and having to do this OMG

  10. #9
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Re: Problem fixing mates car

    Right first look under the bonnet and a bit confused ,found the sensor for the camshaft took that off and cleaned up but could not establish were the maf was situated ,nothing connected to the air feed pipe going into the inlet manifold

    Anybody know and the crank sensor ?...Gings crivens thank god i have an Audi

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO