Sky InsuranceBadger5
Results 1 to 6 of 6
  1. #1
    macpdm's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Cheshire
    Posts
    409

    Help with car problem

    Hi guys

    I have noticed that my wifes Fiesta when hot gives of a smell like hot radiator water. I noted water under the car and at the back of the engine bay. I also noted the water in the reservoir has dropped. I thought it was HGF but the oil seems ok no evidence of water in the oil and the temp guage remains bang in the middle where it usually is. The radiator seems dry and the water is coming from the back somewhere but the engine block seems dry too. Any ideas ??
    Last edited by macpdm; 20th October 2012 at 19:03.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    sidibear's Avatar
    Looking for Zombies !!

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Birmingham UK
    Posts
    2,003
    Heater Matrix is my guess.

    JSD 2.59
    Synergy-Solutions

  4. #3
    macpdm's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Cheshire
    Posts
    409
    Quote Originally Posted by sidibear View Post
    Heater Matrix is my guess.
    Yes I had not thought about the matrix but there is no water on the carpets ?

  5. #4
    A4 S-Line 1.8T Avant 230 BHP

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Stourbridge, West Midlands
    Posts
    38
    air con? try putting some rad weld in and see if it stops otherwise a possible split pipe i guess

  6. #5
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,492
    ill go for the matrix aswell
    reason cos of the smell you get.

  7. #6
    macpdm's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Cheshire
    Posts
    409
    The car has no aircon though guys ?

    Im thinking its a split pipe somewhere, I hope.

 

 

Similar Threads

  1. Help with paint problem please
    By paddy in forum Detailing
    Replies: 4
    Last Post: 13th February 2011, 11:36
  2. Help with car radio can it take an Ipod.
    By holmefield in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 10
    Last Post: 9th January 2011, 21:21
  3. Need your help with a problem!
    By Mr.G in forum TT/TT-S/TT-RS Forum
    Replies: 5
    Last Post: 10th July 2010, 18:07
  4. Help With Some Problems With The Car
    By emzino in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 12th September 2008, 21:35
  5. HELP with Timing Problem!!
    By imported_alex100a in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 0
    Last Post: 31st March 2005, 01:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO