Sky InsuranceBadger5
Results 1 to 2 of 2
  1. #1
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    15,003

    showing off my Jukebox

    The internet is quiet, My work is quiet and I'm bored.
    So I thought I'd show you all my 1975 Juke Box.

    Its a AMI Rowe R-74 Juke Box that's been in the family since the 80s.
    My mum got it from some people, thats all I know and she gave it to me when she moved on to the boat.

    The Jukebox it self holds 100 7" records, play both A and B sides, so thats a total of 200 songs.
    I added a auto dinker to it about 8 months ago so it can play dinked and undinked records. The ones with the big hole is dinked and small hole is undinked.
    This made life alot easier for me to pick which records I can add to the play list and with almost 1000 records, the last thing I want to do is have to pick out the dinked and undinked ones every time I restock it.

    Not much else to say but here is some pics and a video.






    Half of the records. I Took owner ship of my dads collection and bought many more over the last 12 months.


    I really need to buy the credit computer so I can use it as a proper jukebox again.



    I've just been given this. :D

    Bring on the 8mms!!

    New Car, New Thread: Scott's Akoya Silver A8
    Gone But Not Forgotten: Audrey's Build Thread

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Sandra's Avatar
    MODERATOR

    Status
    Online
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,454
    That is totally awesome looking Scott. Sounds like you have a good collection of vinyls as well. Real blast from the past.

 

 

Similar Threads

  1. Upgrading the Jukebox HardDisk
    By Anito in forum In-Car Entertainment
    Replies: 1
    Last Post: 18th September 2011, 14:50
  2. MMI not showing some options
    By ringo_the_audio in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 1
    Last Post: 10th February 2011, 11:46
  3. couple of error's showing - need help :)
    By m8arx in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 24th June 2010, 19:54
  4. Ad not showing up??
    By ukhmartin in forum Site Support & Announcements
    Replies: 3
    Last Post: 2nd August 2007, 10:58
  5. DIS showing 0 mlies
    By WilkoS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 17
    Last Post: 9th September 2005, 22:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO