It seems like it's been a while since anyone has posted on this subject, so I was wondering if anything was still happening with these problems.
I have a 55 plate 2.0TDi Avant which has done 143K now and has the BLB engine.

Is there a known way to identify whether my engine has the geared or chain driven oil pump system?

Thakns in advance.


Quote Originally Posted by Unhappy Chris View Post
Hi again
You may be right. I also picked the following up from a thread on MoneySaving Expert:

2.0TDi Oil Pump / Balancer shaft problems - the definitive guide! Audi VW Skoda SEAT

Maybe this should be a sticky? Will clear up most of the common questions asked on all the VAG forums (ive been through them all while doing my A4 BLB balancer unit/pump):

I spent some time on ETKA a while ago trying to figure out why some 2.0PD oil pump drives fail and some don't. The BKD, AZV & BMN 2.0 engines (which is what found their way into the 2.0 PD Octavia, A3, Golf, various Seats) used a chain driven oil pump very similar, but not identical, to the old 1.9 130hp PD engine. This never seems to give any problems. I can tell from ETKA these engines don't have a balancer shaft which I think is the key to it - it's the balancer shafts that cause the problems on the 'posher' VAG 2.0 PD diesels eg Passat, A4, Superb. By trying to make the engine more refined for the more expensive models they destroyed it's reliability in the process.

Very briefly, the 2.0 PD differs from the 1.9 in having twin Lanchester balancing shafts which contra-rotate at 2x crank speed. The first engines used a chain drive which was a complete disaster (pictures on this website) and the later engines a gear drive. All 2.0 PD got the geared drive towards the end of 2005.

The problem with the 2.0 PD engine is the drive from the slave balancer shaft to the oil pump, which is a piece of 6 AF hex bar which has inadequate engagement depth with the grooves in the slave shaft. It's the torsional oscillations caused by the balance shafts which destroy the oil pump coupling (the 6mm AF bit of hex) and the chain drive to the balancer shafts before the gear driven systems came out, though these still give problems with the hex key rounding. Think washing machine -> unbalanced load -> keep doing it = new machine.

PSA had no problem at all driving their oil pump from the slave balancer shaft on the bigger HDi engines so it's poor VAG engineering at the bottom of it all - as usual.

As I said earlier, the problem is with lack of concentricity of the drive socket into which the drive rod/hex fits. Since I've started looking at this problem, I've seen three cars where the drive socket is off centre by at least 0.1mm. In engineering terms, this is a massive defect. Since I've starting checking the concentricity, all the drive sockets in the
failed units were off centre, but all the replacement balancer units were dead centre and have not led to a repeat failure in the people i have spoken too. Some replacement balancer units have now done 100k+ miles according to some garages.

So, to sum up. You will get this problem at some point if you have a 2.0TDi WITH balancer shafts. If your 2.0TDi does NOT have balancer shafts, you will be ok. If you fit the lastest balancer shaft/ pump assembley from VAG it will more than likely cure the problem for life as they have made the hex longer and centered it all properly.

Dealers do not admit any liability. You will not get any fiscal help with changing for the new balancer/pump unit. The fact that VAG have released and re-released different pumps/shafts/engines etc.. is "purely coincidence", according to Audi customer services! I am voting with my feet and never buying a VAG car ever again, they are not worth the extra money and the customer service is a disgrace. If you have this problem yourself, STOP driving the car. If you havent blown the turbo and your engine is not rattling you may get away with not replacing the lump, just the pump/balancer. If you havent had the problem yet and you do have a balancer shaft engine, I would advise either changing the balancer system now or getting rid of the car. From what i can assertain, CR engines are safe.
Anything before that..well, Audi/VAG wont say exactley when they started to fit the units that actualy work properly.....

GOOD LUCK!

N.B. Thanks to all the contributers from across the VAG network and various garages