Chris NottMonster Motorsport
Results 1 to 13 of 13
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    18

    Help !! v6 TDi issues

    After having the following done to my 1999 A6 Tdi 2.5 -

    Turbo Refurbed
    Injectors cleaned and tested
    Crankcase breather ( thanks to Audi-Sport for part nums)
    Timeing belt
    Injector pump belt
    all adjusters for above
    Cat bypassed
    EGR bypassed
    Full flush of fuel system twice using Wurth cleaner
    Full oil/fuel filter service

    My car wont run right, smokes black smoke when started and moving under load, timeing has been checked etc but no joy

    Im now over 1k out of pocket and going nowhere fast

    Any sugestions?

    Thanks in advance for your time and replies

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    PW-Motorsport's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Pembrokeshire
    Posts
    389
    Has the pump timing been checked on vag-com or similar?

  4. #3
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    London
    Posts
    3,072
    How is the camshafts condition ? Is the engine smooth on tickover or lumpy ? Get the timing(dynamic) checked as "pray and mark" jobs are not recomended on v6 engines...

  5. #4
    fjtwelve's Avatar
    Moderator

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Falmouth, Cornwall
    Posts
    765
    When i had the symptoms of black smoke and not running properly it turned out to be the N75 valve (the turbo boost control) that sits on the turbo. If your turbo has been refurbed maybe it hasn't been adjusted right, or has failed and not replaced. Would also suggest with the amount of work done that a VAG COM diagnostic is done to see if all your sensors are working properly and everything has been reset correctly. If you have bypassed the EGR and CAT the EMU may be getting sensor signals that are confusing it.
    2001 A6 Avant 2.5TDi quattro Sport 180hp+TurboDynamics MD438 hybrid+Bosio Race683s+3" exhaust+Celtic Tuning remap - now with adamss24 replaced with runabout
    2007 BMW 535d AM Sport + Celtic remap
    2004 A4 Avant 1.9TDi quattro Sport 130hp + Superchip - sold & replaced by
    2005 Audi TT 1.8T
    1988 Yamaha FJ1200 120hp finally traded after 23 years for
    1986 Yamaha FJ100 (1300 barrels shhh!) with too many bits to mention
    2011 BMW 320d M Sport son #1
    2004 Suzuki SV650 S son #2

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    18
    Im going to find someone wih VAG-COM

    My mechanic uses autodata and bosch but i think he's bit old school when i mentioned checking the timeing using VAG-COM or something like it

    At least if checked by that it will show if pump timeing is 100%

    He did read the faults a few times as we went along and im nearly sure the N75 was mentioned but after turbo was refurbed etc it wasnt persued as the faults all cleared

    Lots excellent info gents, i'll go down the VAG-COM route to start an keep thread updated

    Cheers again

  7. #6
    PW-Motorsport's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Pembrokeshire
    Posts
    389
    To check the pump timing you, using Vag Com, go into engine, basic settings, group 04, you will see a TDI graph box on the lower right. Open this and you will see a tab to select the engine code, select the correct code say AFB etc. You will see an upper and lower graph line. Your pump timing needs to be in the middle of these lines.

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    London
    Posts
    3,072
    I would time the pump so the injection is a bit advanced towards the top line on the screen. The only time i would keep the pump on the middle line is if the car had bigger nozzles fitted or some sort of tuning done (hybrid turbo, intercoolers, etc.) ! f you get a refurbished turbocharger, they should ALLWAYS replace the VNT actuator. Be aware that only fully registered VCDS/vag-com have the tdi plugin for timing v6 tdi engines so if you are thinking of getting a cheapo lead from ebay it wont work. Rule of thumb, if you keep the timing at: -2 degrees BTDC to +2 degrees ATDC the car will be fine... Make shure the engine is fully warmed up at 80 Celsius and you monitor engine in basic settings block 4 ! Hope this helps.

  9. #8
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,713
    there is a solenoidal that controls the vacuums to your egr valve and Turbo, they are at the front right hand corner of your engine bay, they sit just in-front of the power steering fluid bottle, you may find that the bigger one has an issue as i had the similar symptoms with my v6 and nobody could find the fault until they was looked at, i can take and post a photo later of the parts to look at for you,

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    18
    Sorry Gents A6 was left on back burner as bein to busy with work but now need to get it sorted properly
    Got a VAG technican down to have a quick look he says faulty injector for sure so im currently hunting down an injector which is fun
    Turkster could you post the photo and the parts needed please

    Thanks again for all the help and info

    the beast will go again.......oneday

  11. #10
    fjtwelve's Avatar
    Moderator

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Falmouth, Cornwall
    Posts
    765
    Check this thread he's just had his injectors reconditioned by diesel bob and says they are very good
    2.5 v6 TDi Quattro vibration under load
    noddyr
    2001 A6 Avant 2.5TDi quattro Sport 180hp+TurboDynamics MD438 hybrid+Bosio Race683s+3" exhaust+Celtic Tuning remap - now with adamss24 replaced with runabout
    2007 BMW 535d AM Sport + Celtic remap
    2004 A4 Avant 1.9TDi quattro Sport 130hp + Superchip - sold & replaced by
    2005 Audi TT 1.8T
    1988 Yamaha FJ1200 120hp finally traded after 23 years for
    1986 Yamaha FJ100 (1300 barrels shhh!) with too many bits to mention
    2011 BMW 320d M Sport son #1
    2004 Suzuki SV650 S son #2

  12. #11
    Turkster's Avatar
    Bro.Paul 2.5TDI Quattro Sport

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Northampton, Northamptonshire, United Kingdom
    Posts
    2,713
    Quote Originally Posted by Neutech View Post
    Sorry Gents A6 was left on back burner as bein to busy with work but now need to get it sorted properly
    Got a VAG technican down to have a quick look he says faulty injector for sure so im currently hunting down an injector which is fun
    Turkster could you post the photo and the parts needed please

    Thanks again for all the help and info

    the beast will go again.......oneday
    will do tomorrow mate,

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    18
    no further forward on this

    went to a "specialist" who wouldnt work on it...various excuses but hey ho

    said the compression needed tested and was off 2 cyl

    explain this then....why does this clear about 40mph? i had car well over 100...on private test track and the car runs like a dream!!

    Replaced faulty injector still same fault, smokes like 60 a day up to 40mph

    Intercooler was never cleaned after turbo went i was informed as well, slight bit of oil in there.

    HHEEEEELLLPPPPPPPPPP !!

    I'm pullin my hair out

  14. #13
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    London
    Posts
    3,072
    Quote Originally Posted by Neutech View Post
    no further forward on this

    went to a "specialist" who wouldnt work on it...various excuses but hey ho

    said the compression needed tested and was off 2 cyl

    explain this then....why does this clear about 40mph? i had car well over 100...on private test track and the car runs like a dream!!

    Replaced faulty injector still same fault, smokes like 60 a day up to 40mph

    Intercooler was never cleaned after turbo went i was informed as well, slight bit of oil in there.

    HHEEEEELLLPPPPPPPPPP !!

    I'm pullin my hair out
    Where abouts are you mate ? Came to N. London and i will have a look on your motor...

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO