Badger5JMB Retrofits
Results 1 to 14 of 14
  1. #1
    Bing_IRL's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Galway, Ireland
    Posts
    34

    2.0 TDI Random Stutter

    Hi Guys,

    Seems that I may have a problem somewhere and need some advice. I have an A4 B7 2.0TDI (33000 miles on the clock)that gives a little stutter randomly. I can be accellerating in 2nd gear or cruising in 5th but can still feel power drop for a split second. Car drives/performs fine otherwise but every couple of days this happens & am a little worried. Any ideas?

    Cheers,
    Bing

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    4th Gear

    Status
    Offline
    Join Date
    Oct 2003
    Location
    up north...
    Posts
    767
    could be a blocked fuel filter - mine gave intermittent stumbling / loss of power and its very cheap to do, but if you dont flush the new one full of fuel it can take 1/2 hour of cranking to get the engine to fire afterwards - i think its one thing worth paying a dealer or vag specialist garage to do
    TT-RS 410hp revo
    Fiat 500 1.3 tdi 120hp
    A3 8P 2.0tdi 240hp Autograph Cars
    RS4 B5 520hp MTM
    S3 8L 345hp MTM
    Volvo 850 T5 300hp BSR
    Fiat Punto GT 130hp
    Lancia Delta Turbo 185hp
    Lancia Beta Coupe 122hp
    Mini 74hp

  4. #3
    Bing_IRL's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Galway, Ireland
    Posts
    34
    Thanks Dunk. I'll pop up to them on Monday so. That couldn't be diagnosed via the OBD before they open anything up could it? Local dealers are a bit sloppy & I prefer to keep them as far away as possible.

  5. #4
    4th Gear

    Status
    Offline
    Join Date
    Oct 2003
    Location
    up north...
    Posts
    767
    no if its fuel starvation then i dont think vagcom will show up anything useful
    TT-RS 410hp revo
    Fiat 500 1.3 tdi 120hp
    A3 8P 2.0tdi 240hp Autograph Cars
    RS4 B5 520hp MTM
    S3 8L 345hp MTM
    Volvo 850 T5 300hp BSR
    Fiat Punto GT 130hp
    Lancia Delta Turbo 185hp
    Lancia Beta Coupe 122hp
    Mini 74hp

  6. #5
    Bing_IRL's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Galway, Ireland
    Posts
    34

    Update

    Hi Guys,

    Finally got around to changing the fuel filter & set about removing the old one. This has to be one of the simplest things to do, that is if you have the right part :-). Bloody motor factors guy gave me the wrong filter!!

    Anyway, since everywhere's closed till the morning I emptied out the contents of the old filter & there isn't even one partical of dirt in it. Do you guys know if I can just stick in the old one again or will the dirt just stay inside the filter?

    Cheers,


    2005 A4 S-Line B7 2.0TDI PD140, Pearlescent Garnet Red. Bluetooth, BNS 4.2 Sat Nav, Colour DIS, MFSW. Retro'd: Cruise Control, Ambient light, Dension Gateway CAN Enabled Ipod Interface
    2003 VW Golf IV Highline TDI PD100, Metallic Silver. Bluetooth, Fogs, Sport Seats, Air-Con, Trip Computer, iPod Interface, 18" RS6 Alloys, Colour Coded Bumper Valences, Retro'd Cruise Control.

  7. #6
    347
    347's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    253
    hi there , having simular issues with my a3 tdi

    have you sorted yours out yet ?

  8. #7
    tdisportuk's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    UK
    Posts
    459
    i was told it was the 'injector loom' which causes this stutter and needs to be changed after some time. Has the stutter ever happend in idle?

    the engine mounts in the car are not very clever too any minor rumble, you can feel it!
    Audi A3 2.0 tdi sport..many mods to follow...just too fussy when it comes to making decisions!

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    7
    ive got a tdi dsg with similar problems too!

    only happens in mine when mobile
    its smooth when idle
    Last edited by sticky; 22nd July 2009 at 21:43. Reason: spelling mistake

  10. #9
    JimC64's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Glasgow UK
    Posts
    242



    dunno if I'm glad I came across this or not.....

    I have the same thing in my 2.0 Tdi A6.
    It was fine, but I've been having lots of problems with losing coolant ( see my thread in the A6 section ) and have complained repeatedly resulting in the dealer replacing the cylinder head. Whilst they were at it and as the car has covered 60k I got them to do the timing belt.
    Car comes out of the garage has this stutter, usually in lower gears, say 2nd and 30mph and 3rd at maybe 35mph.....just alittle hesitation, almost barely noticeable....BUT IT IS THERE!
    I've noticed watching the rev counter which previously sat at a rock steady 800rpm.....now can be steady then waver between say 750rpm and 900rpm now n again.
    I've also noticed an oil leak that wasn't there before.....ITS GOING BACK..

    I'll update what I find

    Jim
    MY2008 (58) XJ X358 2.7 Tdvi Sovereign LWB remapped to 245bhp, Black, Ivory leather interior with black piping, 20" Alloys

    MY2007 Audi A6 2.0 Tdi SE
    176bhp Stratos Blue, badged as 3.0 Tdi Quattro.Front & Rear park assist,Comms Pack High,Sline grille badge added, 19" RS4 alloys,Rear tints,Dipped bulbs 80W,Mainbeams & Foglights 100W,Number plate LED's,Interior LED's,First Aid Kit,Bootliner,Mudflaps front & rear,Calipers & hubs painted


  11. #10
    JimC64's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Glasgow UK
    Posts
    242



    took the car in today.....oil leak definitely still there ( tech thinks its may be the head gasket? ).....decided to keep the car in to check properly and gave me an A4 2.0tdi (09) as a loaner.
    They're gonna check the hesitation / stutter while its in and also refit the drivers side wheel well liner properly.
    I'll keep you updated as to what they find and how it goes from here

    Jim
    MY2008 (58) XJ X358 2.7 Tdvi Sovereign LWB remapped to 245bhp, Black, Ivory leather interior with black piping, 20" Alloys

    MY2007 Audi A6 2.0 Tdi SE
    176bhp Stratos Blue, badged as 3.0 Tdi Quattro.Front & Rear park assist,Comms Pack High,Sline grille badge added, 19" RS4 alloys,Rear tints,Dipped bulbs 80W,Mainbeams & Foglights 100W,Number plate LED's,Interior LED's,First Aid Kit,Bootliner,Mudflaps front & rear,Calipers & hubs painted


  12. #11
    JimC64's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Glasgow UK
    Posts
    242




    UPDATE As you know the cylinder head has been replaced under warranty around a couple of weeks ago.
    I've since had an oil leak that wasn't there before which its been in for a few times and also a slight hesitation in the lower gears at around 3000rpm almost like a slight misfire which caused concern.
    The cars been back in for diagnosis and just had a call to advise the following.....
    They've found a a problem with the camshaft which seems to have been tearing the seal. They've already replaced the seal and found this issue as a result of that process.
    They are now going to replace the cylinder head AGAIN and also the twin fuel pump I think they said....something about the oil contaminating the fuel if I remember correctly....The result is that the car will be with them for another 4-5 days or so and then hopefully all will be good.

    Got an 09 plate 2.0 tdi sline avant at present - not a bad car although a little underpowered, but looking forward to getting back into my A6

    As much of a pain as it is with all the toing and froing....the dealers have been pretty good as sorting the issues and communicating with me as well
    MY2008 (58) XJ X358 2.7 Tdvi Sovereign LWB remapped to 245bhp, Black, Ivory leather interior with black piping, 20" Alloys

    MY2007 Audi A6 2.0 Tdi SE
    176bhp Stratos Blue, badged as 3.0 Tdi Quattro.Front & Rear park assist,Comms Pack High,Sline grille badge added, 19" RS4 alloys,Rear tints,Dipped bulbs 80W,Mainbeams & Foglights 100W,Number plate LED's,Interior LED's,First Aid Kit,Bootliner,Mudflaps front & rear,Calipers & hubs painted


  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Posts
    5
    I have a a3 2.0 tdi b7 which has a stutter/misfire at 2800 rpm which appears occassionallly. Audi haven't been able to sort it.

  14. #13
    JimC64's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Glasgow UK
    Posts
    242



    Hi all...had a few problems with my 07 A6 2.0 tid which have included cold / non start issues and loosing coolant among them.
    Having taken advice I've visited the dealer many times re the low coolant issue and they've replaced the cylinderhead around a month ago. Since that time I've experienced an oil leak that wasn't there before and the engine hesitation as mentioned......usually in lower gears 1st through to 3rd, sometimes 4th and around the 2000rpm mark, there's a slight flutter / hesitation in picking up, more noticeable at low speeds.
    Took it back to the dealer and complained - They've since fitted another new cylinder head as the cam shaft was out of spec and caused a problem with a seal seemingly.
    Car was in for around 8 days or so for this to be done and I wasn't best pleased to say the least.

    The issue now???
    Since I've had the car back Friday I think it was I've suffered with the same engine hesitation - something is definitely NOT RIGHT.
    The other issue is that on Sat am and early today on first start up the car wil not fire......almost like water in the fuel or low battery where it just turns n turns and eventually catches

    I'm gonna be on the phone to them tomorrow and see where we go from here.

    I'll keep you guys updated

    Thanks

    Jim
    MY2008 (58) XJ X358 2.7 Tdvi Sovereign LWB remapped to 245bhp, Black, Ivory leather interior with black piping, 20" Alloys

    MY2007 Audi A6 2.0 Tdi SE
    176bhp Stratos Blue, badged as 3.0 Tdi Quattro.Front & Rear park assist,Comms Pack High,Sline grille badge added, 19" RS4 alloys,Rear tints,Dipped bulbs 80W,Mainbeams & Foglights 100W,Number plate LED's,Interior LED's,First Aid Kit,Bootliner,Mudflaps front & rear,Calipers & hubs painted


  15. #14
    theo289's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Bristol
    Posts
    179
    Quote Originally Posted by JimC64 View Post



    Hi all...had a few problems with my 07 A6 2.0 tid which have included cold / non start issues and loosing coolant among them.
    Having taken advice I've visited the dealer many times re the low coolant issue and they've replaced the cylinderhead around a month ago. Since that time I've experienced an oil leak that wasn't there before and the engine hesitation as mentioned......usually in lower gears 1st through to 3rd, sometimes 4th and around the 2000rpm mark, there's a slight flutter / hesitation in picking up, more noticeable at low speeds.
    Took it back to the dealer and complained - They've since fitted another new cylinder head as the cam shaft was out of spec and caused a problem with a seal seemingly.
    Car was in for around 8 days or so for this to be done and I wasn't best pleased to say the least.

    The issue now???
    Since I've had the car back Friday I think it was I've suffered with the same engine hesitation - something is definitely NOT RIGHT.
    The other issue is that on Sat am and early today on first start up the car wil not fire......almost like water in the fuel or low battery where it just turns n turns and eventually catches

    I'm gonna be on the phone to them tomorrow and see where we go from here.

    I'll keep you guys updated

    Thanks

    Jim
    Hi,

    I have exactly the same issue with my car. Did you manage to get to the bottom of this fault?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO