Monster MotorsportSky Insurance
Results 1 to 20 of 20
  1. #1
    V6 TDI

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Worcester
    Posts
    22

    2.5 TDi A4 power irregularities

    Hello all,

    My 1998 A4 Avant 2.5 TDi is the classiest thing I've ever owned (by some margin) - a truely fabulous car. I feel I can say that, as it's now done 177K and still does 51mpg on a long trip and 37.5 mpg round town!

    I've noticed a tendancy now though, whilst booting it, for the power to die off quite a bit just after 3k. It has the usual complete and total lack of power under 1500 but seems to be developing a 'power hole' just after 3K. The power picks up again after this dip too. This is a bit strange really... Also - If I depress the accelerator smoothly - matching the actual acceleration it's not as bad, but if I push the accelerator right down, the accleration almost stops. There's no smoke whatsoever either. My guesses are:

    a) due to the now astro mileage!
    b) the MAF - it's on it's 3rd, last one installed at 140K, so 37K ago.
    c) the turbo - they don't live for ever, and I reckoned on replacing it at some point...

    What do people think, new MAF as a first base? Maybe just disconnect it and test it for a mile?

    Cheers
    Last edited by cluelessgoon; 6th July 2006 at 00:32.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    icenutter's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    595
    Just a few suggestions based on supersition an gut feeling; On most turbo charged cars you get a peak and steady state boost pressure, the peak is reached a short while after applying full throttle then it eases down to a steady state. It sounds to me like that peak pressure is too much for your your car. So maybe you could start by looking for leaks in the hoses under the bonnet?

    Feel free to flame me if I am wrong.

  4. #3
    Olly_K's Avatar
    Administrator

    Status
    Offline
    Join Date
    Jun 2000
    Posts
    2,643
    it could be down to overboosting (the car trying to compensate for the air leak) like icenutter says but I would check/replace MAF 1st. Could well be the turbo also at that kind of mileage. Is it chipped ?

  5. #4
    V6 TDI

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Worcester
    Posts
    22

    Leaks

    It's not chipped, and to my knowledge never has been. I think it's still on it's first turbo, so it's done well as I have seen more of these fail <100k than survive (could be all the chipping I guess ). Personally I don't really want to chip it, as it's actually so powerful still that it struggles to put down all the power through two wheels. It's just the hole after 3K that lets it down. The peak pressure theory sounds very plausible indeed - it's exactly the kind of feeling I'm getting as I drive. I'd have expected more smoking from overfuelling though in this case.

    I'll have to check all the hoses/intercoolers for leaks really, but with two intercoolers and miles of hosing / no space / no offroad parking, it'll be great fun ! I've ordered some of the insulating grease for the MAF connector mentioned on another thread on this excellent forum, but it could well be knackered already & after 40K I should probably consider replacing it. The problem sounds solvable though.

    I got a quote for a new turbo when I bought the car! Looking at about 500.

  6. #5
    fjtwelve's Avatar
    Moderator

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Falmouth, Cornwall
    Posts
    765
    Sounds like the MAF or N75 boost control valve.
    Disconnect Maf is an easy test so do that.
    Hunting leaky air hoses is difficult but they are cheaper than Maf and EGRs and i know 2 people who have had a leak so well worth checking
    If you can't hear the turbo whistle sound as the revs build i would suspect the N75
    Could be the EGR sticking, thats easily cleaned, after your mileage it could be full of gunk.
    I would be very surprised if it was the turbo, my Passat went to 215000 no problem and the highest TDI mileage i've heard is 756000 so i think its unlikely.
    2001 A6 Avant 2.5TDi quattro Sport 180hp+TurboDynamics MD438 hybrid+Bosio Race683s+3" exhaust+Celtic Tuning remap - now with adamss24 replaced with runabout
    2007 BMW 535d AM Sport + Celtic remap
    2004 A4 Avant 1.9TDi quattro Sport 130hp + Superchip - sold & replaced by
    2005 Audi TT 1.8T
    1988 Yamaha FJ1200 120hp finally traded after 23 years for
    1986 Yamaha FJ100 (1300 barrels shhh!) with too many bits to mention
    2011 BMW 320d M Sport son #1
    2004 Suzuki SV650 S son #2

  7. #6
    V6 TDI

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Worcester
    Posts
    22
    The turbo spins up nicely, in fact the engine sounds incredible - even with aircon I have the windows down just to listen to it !

    EGR - could certainly have made everything filthy by now. I disconnected it on my old audi 80 1.9 td, but I'm not sure about the TDi and EGR.

    I'll try disconnecting the MAF (how long is it safe to do that for - I was thinking about a mile or two) first of all.

  8. #7
    V6 TDI

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Worcester
    Posts
    22
    After disconnecting the MAF and driving for a bit I found that the power was only very slightly lower - if at all. The pull low down (the infamous 1500 2.5 barrier) seemed better and the power was very smoothly delivered. When I put my foot down the car seemed quite a bit more responsive - even if the final surge was not quite as hard. I reconnected it after a couple of miles and carried on. The 'power hole' I've noticed (after 3K) is worse during hot weather - and much worse going uphill.

    I guess that the MAF should make quite a big positive difference really - shouldn't it? Therefore given that mine was slightly worse but smoother, I could benifit from replacing it...

  9. #8
    fjtwelve's Avatar
    Moderator

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Falmouth, Cornwall
    Posts
    765
    OK, sounds like the MaF is dodgy, get an exchange one, about 75. Going uphill is putting the engine under load which means you need boost, and you are not getting it. If the turbo sounds fine could be an air leak in the hoses.
    I think you can take the EGR off 1.9TDi engines,see tdiclub.com, but not sure about the v6. Its almost identical in appearence so cleaning it out should be easy enough
    The only other thing l can think of is the temperature sensor. When it went on my Passat the VWgarage said I needed a new turbo. My local garage fixed it with a 15 part.
    Your note about temperature is interesting- mine is definitely on song at 13-14C, and feels a bit short of torque when its 2O+C,
    2001 A6 Avant 2.5TDi quattro Sport 180hp+TurboDynamics MD438 hybrid+Bosio Race683s+3" exhaust+Celtic Tuning remap - now with adamss24 replaced with runabout
    2007 BMW 535d AM Sport + Celtic remap
    2004 A4 Avant 1.9TDi quattro Sport 130hp + Superchip - sold & replaced by
    2005 Audi TT 1.8T
    1988 Yamaha FJ1200 120hp finally traded after 23 years for
    1986 Yamaha FJ100 (1300 barrels shhh!) with too many bits to mention
    2011 BMW 320d M Sport son #1
    2004 Suzuki SV650 S son #2

  10. #9
    V6 TDI

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Worcester
    Posts
    22
    ok - I'll get another MAF. Did you mean the air intake temperature sensor? I've just had a new radiator and don't think they changed the thermostat when that was done - a contribution perhaps?

  11. #10
    DIPS_A4's Avatar
    SEAT LEON CUPRA R (225)

    Status
    Offline
    Join Date
    Mar 2006
    Location
    Leicester
    Posts
    566
    I had my air intake temp sensor replaced due to my powerloss problem but now i find when i put my foot down from take off and rev through it loses power over 3k and some days it picks up and some days it doesnt. i tink my n75 might be on its way out. not sure but also hot weather can cause the car to run poorly.

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Aug 2004
    Location
    Hertfordshire UK
    Posts
    162
    had to replace the maf on mine a while back, solved this problem.
    doubt its the turbo, mine has now crept upto 151k and is still running sweet as a nut
    great cars these
    ps chip it, decent tyres (ie toyo t1r's) solves the grip struggle even when chipped
    Formally a4 2.5 tdi (b5)
    Now Seat Ibiza tdi 130

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Mar 2006
    Location
    Culmstock, Cullompton, Devon
    Posts
    67
    how do i disconnect the maf to check mine? I don't know where it is either so any help appreciated.

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Aug 2004
    Location
    Hertfordshire UK
    Posts
    162
    i between where the air leaves the airbox and before the turbo there is a big lump of plastic that has a rubber intake pipe connected to at each end that the air passes through, this has a plug attached to it. unplug this.
    Formally a4 2.5 tdi (b5)
    Now Seat Ibiza tdi 130

  15. #14
    owdgit's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    UK North West
    Posts
    112
    My 2.5 is doing the same, I guess its time for a new MAF for me too.
    I like to think I'm an optimist.

  16. #15
    Neutral

    Status
    Offline
    Join Date
    Mar 2006
    Location
    Culmstock, Cullompton, Devon
    Posts
    67
    i unplugged the maf and the car seem to have more power if anything. does that sound right?
    If i need a new one, when i get it do i just take out the old one plug in the new one and start up the car or do i need to reset anything?

  17. #16
    icenutter's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    595
    Yup. No maf makes the car think there is maximum airflow so it puts in maximum fuel. Doesn't do the engine much good in the long run...

  18. #17
    Jason's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2005
    Location
    France
    Posts
    186
    Just changed the maf on the wife's tdi beetle!
    It was running really badly,very slow, no acceleration,big flat spots!!
    Tried disconnecting the maf and this made no difference,tried cleaning it and it was worse after. So I bit the bullet and got a new one from VaG for 70.

    WOW! What a difference! Completely transformed the car and it now goes like s**t of a stick!!!!
    Last edited by Jason; 27th July 2006 at 15:53.

  19. #18
    Neutral

    Status
    Offline
    Join Date
    Mar 2006
    Location
    Culmstock, Cullompton, Devon
    Posts
    67
    I've replaced the MAf and the car has been transformed - its amazing and great for overtaking. i must have been running around 120hp as opposed to the 150hp i appear to have on tap now.

    Now that i've replaced the maf do i need to reset anything using vag com? i don't have this software so will i need to go to a garage. any advice appreciated asap as i don't want to be damaging hte car in the mean time!!!

  20. #19
    icenutter's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    595
    No is the simple answer.

  21. #20
    owdgit's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    UK North West
    Posts
    112
    I have replaced my MAF today and think I must have changed the car aswell, it really has transformed it. To think I have been driving around for the last 12 months thinkng that the acceleration was normal! For the first time since I have had the car the traction warning light has been flashing at me when I set off. It has been the best 70 I have spent on the car. Maybe the remap will come next!!
    I like to think I'm an optimist.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO