Badger5Chris Nott
Results 1 to 17 of 17
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    UK
    Posts
    1

    A4 19. TDI Flat spot

    Hi

    I have had my A4 for a while i have got a miss when you take your foot of the accelerater and then reapply. Been to Audi garage they had it for 2 days and i even road tested it with them, did'nt miss once!!! they claim everything is ok but not right still missed on the way home. I know sods law. Have tried all types of driveing up hills, hot, cold seems to be there what ever i do. Just clocked up 90000 full audi service history

    Any Ideas !!!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Milton Keynes UK
    Posts
    248

    Re: A4 19. TDI Flat spot

    MAF sensor?

    Just a guess.

  4. #3
    tubtub's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    SW England
    Posts
    160

    Re: A4 19. TDI Flat spot

    Yup, sounds like the MAF sensor to me too. Either clean it or replace it - have a look on e-bay, they're selling quite cheaply but make sure you match part numbers.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    uk
    Posts
    5

    Re: A4 19. TDI Flat spot

    sorry to be a nutter but what is the maf sensor ? is it the airflow meter ? just i have a similar fault ta

  6. #5
    tubtub's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    SW England
    Posts
    160

    Re: A4 19. TDI Flat spot

    That's it - Mass Air Flow sensor, a Google search should produce plenty of information.
    They're prone to failure; some people suggest cleaning them but new ones cost from 50. You'll probably need a 5-star torx to replace it, for some reason Audi fitted anti-tamper bolts.
    I think there are a few threads on the subject in these forums.

  7. #6
    arthurfuxake's Avatar
    Controversial & Contradictive

    Status
    Offline
    Join Date
    Mar 2004
    Location
    Manchester
    Posts
    1,306

    Re: A4 19. TDI Flat spot

    Could be either MAF or EGR solenoid valve. I think the MAF will throw up a fault code on the diagnostic machine, but EGR will not show up as a fault code. MAF is cheapest and easiest to replace, so try that first.

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Milton Keynes UK
    Posts
    248

    Re: A4 19. TDI Flat spot

    When I replaced my MAF there was no fault code. I have been told that sometimes this can happen if the MAF is on its way out and it has not qiute reached the threshold to flag up a fault.
    If you can find someone with VAG-COM they can do an output test that will check that the EGR is working.

    Jim.

  9. #8
    tubtub's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    SW England
    Posts
    160

    Re: A4 19. TDI Flat spot

    Same here, no fault code although the flat spots and lack of power across the rev range were very noticeable.
    Though they can fail from 60,000 miles, the one in my 180,000 mile car is still going strong.

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Milton Keynes UK
    Posts
    248

    Re: A4 19. TDI Flat spot

    TubTub,

    Mine failed at 40K miles, I have heard of some failing at 15K.

    You are doing well to be on 180K miles on the same MAF. Well done!! [img]/ubbthreads/images/graemlins/smile.gif[/img]

  11. #10
    tubtub's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    SW England
    Posts
    160

    Re: A4 19. TDI Flat spot

    Don't I know it.... the car has been a faithful friend since we bought it in 2000 (with 96,000) and I just can't bnring myself to get shot of it.

  12. #11
    hannahj's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    WALES, UK
    Posts
    8

    Re: A4 19. TDI Flat spot

    Hi Guys, I have been having a problem when my 1996 110 red I hits 2500rpm, shut off ignition and re-start clears the problem. I have cleaned the MAF (no change), removed the EGR and found it totally caged in oil/carbon, so removed inlet manifold and found it to be the same. Cleaned EGR with petrol/small brush and soaked the manifold before brushing. What a differance!!!

    But after 5000mls it has come back, so now the MAF is to be changed, I will also look at the solinoid that controls air to the EGR, and all concerned pipework...

    I will let you know how I get on soon....

  13. #12
    hannahj's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    WALES, UK
    Posts
    8

    Re: A4 19. TDI Flat spot

    Hello all,
    This is the follow up story so far!!!
    Changed the MAF (mine is the more expensive Pierberg type), got this item from GFS car parts (nationwide chain). Small improvement initially but not the big difference I was hoping for (but the MAF was wacked, inside probe broken off) Cost 95.00+vat.
    Then started to monitor the movement of the turbo actuator rod, very difficult to see this operate but with my neighbour's help we did it (basically revved the titties into the engine....nice). It moved as per design.Started to inspect the N75 actuator and found this to be faulty!!! plastic pipe cracked, changed for new 69.50+vat (from dealer only)
    Noteble whistle from the turbo now, also changed all hoses that supply pressure/vacume, goes like a rocket (below 2500rpm) but alas still loses power above 2500rpm....

    What now!! the EGR actuator maybe, the relays that control the 2 off actuators, the turbo!
    There has to be a simple explaination to the fault, come on Audi, spill the beans....

  14. #13
    hannahj's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    WALES, UK
    Posts
    8

    Re: A4 19. TDI Flat spot

    Hi there,
    I have just had an interesting development with my power loss problems.

    While playing with the EGR actuator I inadvertantly leant on a hose that goes into the bulk head and towards the master cylinder ???, as i touched the pipe it let out a "hisss", I again repeated this and lo and bohold more air bypassed the joint, took it out of the rubber connector and smeared the pipe with silicon rubber grease "made by RS componants".
    This has stopped all leaks !, now both my EGR / turbo actuators are freely moving and best of all "NO POWER LOSS"(AT ALL) Does anyone agree with my comments above, please post a reply, it has worked for me.
    PS I will photo the pipe in question and post later today for all to see.

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2006
    Location
    UK
    Posts
    19

    Re: A4 19. TDI Flat spot

    I think that pipe's the brake assist pipe. Presumably a leak there would affect the vacuum/boost which actuates the EGR and turbo control valves. Or something...

  16. #15
    hannahj's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    WALES, UK
    Posts
    8

    Re: A4 19. TDI Flat spot

    Hi Grifter,

    Yes I agree, most probabley brake servo assist, but an air leak here will give air pressure concerns further down the line.
    Mine has been so much better since I "fiddled" with it, i even hit 120mph last week (a first since owning the car)
    Now my "plug in chip" will be replaced to hopefully improve even more.
    Keep you all posted.....

  17. #16
    Neutral

    Status
    Offline
    Join Date
    Oct 2004
    Posts
    41

    Re: A4 19. TDI Flat spot

    I have recently developed what sounds like the same fault on my B6 130 tdi. It has suddenly started to hesitate when you let off the accelerator at speed and then re-apply the power. I have definitely noticed a drop in torque above 3000rpm.
    I removed the MAF sensor the other day to see if I could see any damage but it looks brand new, although I couldn't see much as it seems to be all enclosed.
    I have noticed that when I stop the engine I do hear a hissing sound for a while which looks like its coming from the metal pipes goiing into the bulkhead A/C pipes I think.
    I don't know whether I should buy an OBD2 USB cable and download the VAG software to try solve the fault myself or just pay the audi garage 30 mins fault finding labour.
    I would be grateful for Pics hannahj but I think our engines are different. Any Idea's?

    regards

    Jonathon

  18. #17
    hannahj's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    WALES, UK
    Posts
    8

    Re: A4 19. TDI Flat spot

    Hi John,
    I think the "hissing" sound is probably the air-con, run the car with it off then see if it stops.
    Our engines are not the same, 99% sure of this, mine is an "AFN", you can check yours by looking at the sticker/label inside the spare wheel well or in the front of your service booklet.
    MAF sensors, well what can I say, but if you disconnect yours and run/drive the car and see no change this is a good indication it's dead or dying. GFS, or Europarts can easilly supply at 45% of the dealer cost.
    Is service up-to-date, ie filters etc.
    If you want a pic i will post, just ain't had time yet.

    Cheers James.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO