Volks AutosSky Insurance
Results 1 to 5 of 5
  1. #1
    TGM
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    4

    Talking Possible MAF Problems

    Hi All

    I am having issues with my A4 2.0 TDI 170.

    The car feels under powered and not overly prompt on starting. Low revs are a real struggle. It is an 07 plate and has just hit 86K.

    On a reasonably fast motorway run for 2 hours I am hitting around 34 mpg (a little low)

    On occasion the idle is erratic too.

    I have been asking around and a few people suggested that my injectors may be blocked. After several months now of various diesel injector cleaners I am seeing no results.

    I asked around some more and have read a few forums and the diagnosis maybe the MAF.

    Before I spend money to change this, does anyone have any suggestions for cleaning them or is it not worth it?

    Are there any other things i should be looking out for?

    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    4th Gear

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Bradford, WY
    Posts
    788
    Simple test to check if it is the maf. Unplug maf, go for a quick drive. Is power the same? If yes maf is knackered. If power is reduced maf is ok. You cam clean it with some brake fluid cleaner spray thingy


    A3 2.0 TDI Optics Black S-Line, FR&RTuning Stage 3! GT20 Hybrid Turbo, THS TFSI FMIC, Sachs performance clutch kit+SMF, Milltek 2.5" Turbo-Back Non-Res Exhaust, ITG Maxogen Induction, EGR Delete with FR&RTuning Map out, Custom Black 18" RS4, 35mm H&R springs, S3 brakes, EBC Yellowstuff, front splitter, HID Xenons, S3 tailgate Spoiler, 09 Rear Lights, Retrofit Audi Ipod, S3 Air vents, Bose sound+retrofit JBL Subwoofer 1200W.
    Milltek Cat-back Non-Res for S3 2.0T FOR SALE both 3dr and 5dr PM

  4. #3
    TGM
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    4
    Thanks navnayvar.

    Intrestingly last night the oil light came on. About one month ago the oil was fine. Now it is on minimum.

    Could this be all related?

  5. #4
    TGM
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    4
    Hi All

    Changed the MAF and still no change.

    The MPG is still 32 on the motorway and still under-powered.

    Linked the ECU to a fault reader but no codes displaying and parameters are coming out normal. However it took several attempts to access the ECU as it kept booting the computer out.

    Any Ideas anybody?

  6. #5
    TGM
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    4
    Further update:

    Loaded the car on a rolling road. The Car is a BRD 170 bph 2.0 TDI but I was gettting 100 bph out the wheels and around 130 bph out the flywheel.

    Performed a full engine flush and oil change as I had heard rumours that Audi garages are reknown for not putting the correct oil in these engines.

    anyway, the next day I was driving and the brakes went rock hard and didnt perform and the engine cut out at 80mph on the motorway.

    I think the added load of the rolling road plus the full engine flush may have caused my tandem pump to pack up. Interestingly no oil is in the fuel line yet.....

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO