JMB RetrofitsVolks Autos
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2007
    Posts
    3

    1990 90 quattro 20v

    Hi guys, ive searched this forum back cant find anyone with a similiar prob, so if anyone can help ?..just bought my first audi n love it!however, it has a miss - ie when taken over 4000 rev it coughs and continues to misfire especially at lower revs/speed - it can be revved thru 4000 and its as if a turbo kicks in - it releases power n feels great but dropping back down it begins to misfire badly; just spent 600 on custom stainles exhaust as the old one blew up - back box literally blew a hole out so excess unburnt fuel getting thru ...anywhere in scotland i can have it looked at ?...

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    South Wales
    Posts
    155
    I would try to work out which cylinder(s) are not firing at low revs, check leads swap them over etc, check compression. Have a look at www.20v.org theres a section on engine troubleshooting, try pulling fault codes from the ECU: http://www.20v.org/fault.htm

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2007
    Posts
    3

    thnx

    Hi scotty..tried removing leads one by one during tick over - makes no difference; the 20v site is great and will work my way thru it; im thinking its connected with the fuel supply - it blew up the last exhaust as there was excess fuel getting dumped thru it; so, maybe airflow meter, fuel pump, etc.....

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    South Wales
    Posts
    155
    Hi Jakey, Ok not ignition then, Are you sure it's too much fuel? a lambda probe problem, or coolant temp sensor/stuck open thermostat can all cause rich running, but possibly not as bad as yours is?
    There is a series resistor (fag packet sized module, alongside the fusebox) this can affect the injectors if faulty. It should show up in fault codes, airflow(MAF) sensor, coolant temp sensors, also should. Fuel pumps usually give too little fuel when faulty, I guess the fuel pressure regulator could be faulty?
    The injectors themselves are a known weakness of this engine, if it is them, I would consider upgrading to ones from 034 efi:

    http://www.motorgeek.com/phpBB2/viewtopic.php?t=8198


    Probably worth posting your problem on Motorgeek too!

  6. #5
    S6 avant

    Status
    Offline
    Join Date
    Oct 2006
    Location
    bewdley Worcestershire
    Posts
    689
    2 probs i had with my 90 20v were distributor drive wearing out causing ignition timing to go out. they usually break and it wont start though. the other was a blocked cat. this caused me a load of hassle as the car had erratic flat spots and lack of power, changed loads of stuff before i found it! had a cat bypass made and it was really fast after. might be some help?
    2000 s6 avant, special order met, green, satnav, Bose, tv, solar roof, privacy glass, recaro silver nappa.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO