Monster MotorsportJMB Retrofits
Results 1 to 11 of 11
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2005
    Location
    Colchester, Essex, UK
    Posts
    7

    Cabriolet Roof Problem - Please Help!

    I have '94 Cabriolet Auto 2.8E with power roof. When I start the car, the 'roof' icon flashes in the instrument panel and will not stop unless I disengage the handle that opens the roof and close it again.
    Also when I try and open the roof, the hood lid that the roof drops into will not lift, and the roof icon flashes in the instrument panel.
    I have had a company called John Austin (Independent Audi Specialist) in Colchester look at it. I had to take the car back twice, but although they are an Audi Specialist garage It seems all they did was contact an Auto Electrician who visited the garage to fix the problem. He thinks that I need an ECU.
    This all started after the car went in for a service and had a new off-side rear light bulb fitted!
    The roof was repaired last year with the same problem and had a new wiring loom fitted (how much!!!) to the off-side, so I am feeling a bit peeed off with the garage and their lack of concern.
    Anybody got any ideas?
    There is an cheap ECU ( PART NUMBER 8G0959723E ) available, but Im not sure if this is the right part, or, will in fact, fix the problem.
    Cheers
    Stuart

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Rev-head's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Location
    Perthshire
    Posts
    2,955

    Re: Cabriolet Roof Problem - Please Help!

    Quite a hard question as i am sure there is not that many of them kicking about but if you post this here i am sure you will get the answer allot of cab owners
    http://www.audiworld.com/forum/9080.html

    If i were you i would go to different garage sounds like they are taking you for aride

    ECU to fix the roof eehhhhhh!!! never heard of that before (correct me if i am wrong somebody)

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2005
    Location
    Colchester, Essex, UK
    Posts
    7

    Re: Cabriolet Roof Problem - Please Help!

    Thanks Rev-Head,

    I'll have a nose around there and see what happens [img]/ubbthreads/images/graemlins/cool.gif[/img]

  5. #4
    Guest

    Re: Cabriolet Roof Problem - Please Help!

    Hi

    I have exactly the same problem on my 2.6 Cabrio and have also had a new wiring loom. Didn't work for me either.
    Did you manage to get a fix for your roof?

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2005
    Location
    Colchester, Essex, UK
    Posts
    7

    Re: Cabriolet Roof Problem - Please Help!

    So far no luck, I 've been posting here:
    http://www.audiworld.com/forum/9080.html
    as per advise...Car is going into car electrical garage this Friday...I'll let you know

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Yorkshire
    Posts
    1

    Re: Cabriolet Roof Problem - Please Help!

    I have the same problem on a 2.0 94 Cabriolet. Again replaced the wiring loom in the boot that was told was the problem but did not help. I have in recent times started getting in about it and managed to get a hold of a wiring diagram and sussed out how it operates. The only thing I am short of is a description that tells me what the system looks for before starting the sequence. I have checked all the switches in and drivers out at the ECU and can run the roof through a cycle by putting gnd etc onto each realy/solenoid (got to be careful on this or it can get in a knot!!!). The ECU works to a certain extent as it looks and unlocks the boot via the central locking which is driven via the roof ECU and also drops the windows when the roof handle is turned. There is one signal from the dash that I aint too sure on which is why I could do with the audi desciptive stuff. To cut a long story short I am looking to design my own roof ECU to replace the existing unit as I am so p#*&$d off with the thing (got all the programming kit etc within the business). Let me know how much the ECU is that you can get and will keep you posted on my progress.
    Cheers
    Alid1000 [img]/ubbthreads/images/graemlins/noidea.gif[/img]

  8. #7
    imported_merl1nuk
    Guest

    Re: Cabriolet Roof Problem - Please Help!

    Guys,
    you mention having a wiring loom in the boot replaced , do you mean the 1 that is attached to the boot hinge ?
    If so might be be worth checking the 1 on the other side as well.

    Most roof problems are assoc. with these looms failing , they look good from the outside but inside the insulation the wires fracture making and breaking the connections as the boot is opened & closed.

    Have a look here for more idea's

    http://www.audifans.net/modules.php?...forum&f=45

    Cheers

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2005
    Location
    Colchester, Essex, UK
    Posts
    7

    Re: Cabriolet Roof Problem - Please Help!

    Thanks merl1uk,

    I'll post this there as well.

    Had a quick look-see and there are lots of posts from early 80 cabs.

    cheers,

    Stuart

  10. #9
    imported_silversurfer7
    Guest

    Re: Cabriolet Roof Problem - Please Help!

    Has anyone had any luck with this? I have nearly the same problem the my 97 cabriolet.
    The compartment lid where the hood goes doesnt open when I go to put the hood down, and then the lid doesnt close when I put the hood back up!?

    Sods law this happens when the sun comes out too!

  11. #10
    imported_silversurfer7
    Guest

    Re: Cabriolet Roof Problem - Please Help!

    can anyone tell me how to check the looms in the boot? I had one replaced last year as the boot lock wasnt working

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    3

    Thumbs up Roof problem

    Hello

    I,ve just read about your roof problem. I,ve got a 97, 2.8 Cabriolet and had an intermittent problem with roof opening. I found a break in the boot loom going from the boot to the boot lid, where the cables bend at the hinge position. The problem was found by luck when I noticed the boot was not locking with the central locking. This fault occurred at the same time the roof problem started.Before the hood valance will open it looks for the boot lock to engage so you can,t open the boot as the roof is opening, so not boot lock, no roof open. Repaired the loom, all fine since!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO