AH FabricationsVolks Autos
Results 1 to 4 of 4
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    269

    Switch Feed to Aftermarket headunit

    Hey guys i have been reading on a few forums how to get a switch feed to my aftermarket headunit as it will not turn off when keys are out of ignition.


    i have read you need to run a wire in from somewhere under the dash to the headunit.??..

    Can anyone help on which cable i need to connect the switch wire to as am totally lost at the moment?.

    Thanks

    Kev

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    Not sure on the 8P A3 bu on the B6/B7 A4's it's the ultra skinny red wire coming from the ignition. It's the only one among a whole bunch of 5 amp cables so it's really easy to spot as it's very very thin. Because it's so thin you can't run the HU directly off it. You need to cut it, then rejoin it using a small terminal block whilst adding an extra wire. Run this wire up to the HU then use it to trigger a small relay. Wire up the relay using the perm live & earth already there, with the new wire as the switch on trigger and then the remaining terminal going to the "ignition on" feed on the new HU. This will give you "ignition on" turning the HU on and it will stay on then until you pull the keys out.
    The easiest way to ensure it's the right cable is to use a 12v testing screwdriver with a sharp sewing needle attached to it. Then use the needle to poke through the insulation to check it's live with ignition on and stays live until you pull the keys out. This way you're not damaging any of the wiring unnecessarily.
    Last edited by AndyMac; 8th December 2008 at 16:41.
    "How to tear apart the ties that bind, perhaps fcuk off might be too kind"
    Alex Turner

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    1

    Talking

    You the man Andy, just finished installing my Kenwood HU in my A4, just as you suggest, feeding a relay of the small red key switched wire. Not that easy getting the wire from the HU through to the barrel mind you! these things are sent to test us!!

    On my 2005 A4 original Non Bose Concert Half Amplified rear system I had to fit the relay switching the permanant car loom feed to the HU (red iso wire) and also to the rear amplifier feed through a 5A fuse. The permanent feed then connected to the stereo memory (yellow iso).
    Had to put the amp feed through the relay so as not to flatten the battery!!
    Soldered on some rca cable sockets onto the factory amp channels and plugged my HU rear(sub) rca's into them.
    Happy days, sounds pumping. Need a fair bit of fader to the rear as the back's a bit quieter, I can live with that!!

    Now all I need is to butcher a 99p ebay 12v ciggie usb supply to fit in a small box behind the HU, supplying extra power to my Hard Drive as the HU won't.
    Loads of music to drown out the wife and kids.

    Thanx
    Last edited by tommytoop; 9th December 2008 at 22:06.

  5. #4
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    Nice one. You could have just connected the amp feed to the remote on from the HU!
    Also you really need to rewire the rears directly to the HU then use the sub out purely for the sub, that will bring the rears up to match the fronts, but you're nearly there.
    "How to tear apart the ties that bind, perhaps fcuk off might be too kind"
    Alex Turner

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO