EM TuningJMB Retrofits
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By s8craig

Thread: Help

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172

    Help

    Hi guys,

    This is my first post so be gentle!

    I have a 2005 a3 DSG 2.0 tdi, and my brother has a 2004 a3 manual 2.0 tdi, weve both bought them to find the stereo wiring harness has been hacked and bodged! I cannot stand it when people do this! I am a fully qualified mechanic so have technicial background, Ive recentley bought a propper version of VAGCOM however i have recieved it yet and never used it. Both cars have multi funcional steering wheels however they're not wired up, they illuminate so not sure what i need to do to get them working. They both have rnse sat nav units, one is a 2009 and one is a 2012 led version, they both have Parrot MKI9200 blue tooth kits. I can solder fine but what id like to do is find out what connectors i need to put back on to the original wiring harness thats been chopped of. So can you telle for example if this is what i need: Where to purchase a quadlock for the rnse, where to purchase the receptacle terminals so i can crimp the original wires and put them back into the connector. The only connector that hasnt been chopped on the 2005 has 6 thin wires going into it and its not for the power wires or speakers any idea what it is? Also where to get one of those connectors for the 2004 that has been chopped.

    The 2005 doesnt turn on and off with the key but does have its own ignition live so im guessing the red and yellow wires need swapping? Also the illumination doesnt light up on the rnse. Also the rear speakers dont work but there are speakers there. The other thing is the radio reception is rubbish and i have no idea why?

    Once the original wiring is sorted i can then look at getting the correct adapters. However ive no idea how to find out if they have bose or if theyre half amplified or fully? I think the 2004 may be half amplied and non bose, as the speaker grills dont say bose and with the ignition off and music playing its only the front two speakers but with ignition on its all four and what sounds like a sub.

    So eventually what i need is an adapter to make my parrot kit work in conjuntion with my rnse and the multifional steering wheel and depending on wether they are fully amplified or half.

    Also pretty sure the rnse havent been programmed with vagcom.

    Please help.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    The RNS-E doesn't use a switched live, the reason it doesn't switch on and off, the illumination and the MFSW steering wheel doesn't work is that the can bus wires are not connected. Sounds like a 3rd party stereo has been hacked in and a switched live connected. It's no longer needed, but the can bus wires are, check out pins 9 & 10 and the D connector marked can HI & LO. They connect to the orange/green orange/purple wires in the harness.

    Your probably missing the rear line outs ( a 12 pin green block) to drive the rears, but without seeing what they have hacked, try posting pics, then most of it will be guess work.

    You can buy all the parts for the quadlock and repair wires from your Audi parts dept. They only cost a few pounds.

    As for the radio reception, well the RNS-E uses diversity, so the two fakras must be connected to get good reception.

    Are the radios the original ones, ie were the nav units factory fit?

    One last thing, don't cross post into multiple sections as your answers will be diluted across the threads, delete your cross posts.
    Last edited by s8craig; 22nd April 2013 at 07:44.
    NHN likes this.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    stereo.jpgstereo2.jpg

    First picture is the 2005 (mine) When i first got it the parrot kit didnt work so i tested everything and i had a spare Vauxhall iso adaptor to use for now hence the tape on the spare quadlock, all the wires were just cut,twisted and gafa taped! so i soldered them for now. I have no idea whats right and wrong? When i bought the car it had a concert in it which didnt turn on and off with the key, but im sure it originally had a symphony as in the cars history theres info on a syphony. I then ran a switched live from the fusebox to get it to turn on and off properly. I then got the rnse plugged it in and now this doesnt turn on and off. What is the only connector that hasnt been chopped for thats not plugged in? On my brothers this has been chopped but is connected to other wires? I understand that if the wiring was facotry and i was retrofitting the rnse i would need an adapter for a simple solution but as my connectors have been chopped can you tell me what id need to make the factory wiring correct for the rnse?

    As for my brothers (2004) second picture. I have the reciept for it being supplied and installed in 2009 for £999! and it turns on and off with key, it only sounds front speakers with no ignition and then all four and what sounds like a sub when the ignition is on which im guessing is correct, i think again it just need all the correct connectors putting back on.

    As i said both have poor reception, i dont know if the pictures can tell you if they have the correct adapters? I can hardly get any radio channels on either when i search?

  5. #4
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    I really don't understand why you required a switched live, neither the concert, symphony or RNS-E need one. They all work off can bus for ignition, lighting etc.

    All RNS-E wiring is the same 2009 or 2012 LED ones, no difference, so if you can get the wiring right for one, then it's the same for the other.

    As I said check pins 9 & 10 of the D connector. Your pictures are too small to make any sense of the wiring.

    Your cars are old enough to have the correct antenna systems (diversity) which is what the RNS-E's require and I can see from the first picture that you have them wired correctly for ZF/HF. So why your radio reception is poor I have no idea, a scan with VCDS may tell us more about what the antenna inputs are seeing, but that won't be possible until your can wires are connected correctly as the A3's have diagnostics over can bus and yours aint working.

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    So are you saying for mine to work from the ignition i just need to program it with vcds?

    Ok ill try and figure it out from my brothers that works.

    What is the D connector? If you open the picture in a new tab they are bigger and can zoom in.

    Could it have anything to do with the ariel amplifier?

  7. #6
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    The QUAD lock is split into 4 sections, hence the word "QUAD", the sections are:-
    A (front speakers)
    B (CDC changer/Ipod/BOSE)
    C (line levels and telephone, mic)
    D (power, can, remote).

    All of these connections are printed on the lid of the RNS-E so are pretty obvious what they are.

    Your should not need to program anything to get it working, maybe just the final tests and settings, but you can swap a concert/symphony to RNS-E without any programming and it will work as long as your connections are OK.

    Looking at your first picture in a new tab I can clearly see that the 20 pin MINI ISO connector that has the rear line levels and can bus connections is not connected to anything. Why not just chuck all the crap out and replace it with this and it will work.

    Audi adapter head unit RNS-E-33405

    You can chose the options you need, BOSE, CD/IPOD etc and it will work first time.

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    Thanks for your replies. Ill buy that, is that the cheapest place to get it from? What if at a later date i want to add, IPOD, genuine bluetooth etc will i need a new adapter or should i buy one that will suit what i want to get done eventually?

    Got my VCDS today, no idea what im doing though lol

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    BUMP

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    Right Ive made progress, bought a iso repair kit and crimped the terminals on. Heres what ive got:
    I only have the live and earth from the cars wiring, should there be more? Also my rear speakers and sub still dont work, Still not sure how to code it. The illumination now works on the rnse. But my MFSW buttons still dont work but they light up? Is there a wire i can connect from the parrot kit to make the rnse mute and be able to control the parrot volume with the MFSW?


    IMG_4389.jpg


    That is then plugged into my Parrot adapter:


    IMG_4390.jpg


    Other end of the parrot adapter:

    IMG_4391.jpg

    Then into the rnse Adapter

    IMG_4392.jpg

    Speaker wires from car loom:

    IMG_4395.jpg

    To parrot adapter:

    IMG_4396.jpg

    Other end of parrot adapter:

    IMG_4397.jpg

    To rnse adapter:

    IMG_4399.jpg

    And finally this plug:

    IMG_4400.jpg

    To this plug on the rnse adapter:

    IMG_4401.jpg

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Kettering, Northamptonshire
    Posts
    172
    BUMP

 

 

Similar Threads

  1. Help! Need a new coilpack!
    By SteveS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 23rd January 2003, 22:29
  2. I.T. help please!
    By MisterD in forum General Chat
    Replies: 8
    Last Post: 20th January 2003, 21:19
  3. Please help, my hard drive has disappeared !!
    By sidicks in forum Home Cinema, Hi-Fi and Gadgets
    Replies: 4
    Last Post: 17th January 2003, 15:43
  4. Help Wanted - Amusing slogan
    By Moresauce in forum General Chat
    Replies: 8
    Last Post: 13th January 2003, 01:18
  5. Banner AD include help????
    By Administrators in forum General Chat
    Replies: 3
    Last Post: 7th January 2003, 15:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO