Monster MotorsportSky Insurance
Results 1 to 8 of 8

Thread: NO RECEPTION

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    MD
    Posts
    11

    NO RECEPTION

    My Symphony Head Unit has stopped picking up radio channels but the CD player works fine. I have checked the aerial connection on the back of the head unit and at the aerial and these both appear to be ok. Any ideas?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    audi5e's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Johannesburg, South Africa
    Posts
    809

    Re: NO RECEPTION

    Is there a booster somewhere in the aerial circuit? if so check if that is getting power/working

  4. #3
    audi5e's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Johannesburg, South Africa
    Posts
    809

    Re: NO RECEPTION

    Have a look near the external aerial, if there is one it will be a small box with a power lead going to it.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Kent
    Posts
    29

    Re: NO RECEPTION

    I had exactly the same problem and it sounds like yours is also related to the signal booster.

    The booster circuit board is built into the bee sting aerial base and in my case the central core wire had corroded and come away from the circuit board. The solution was to remove the aerial base (you can access it by removing the rear courtesy light cluster and undoing the aerial retention bolt) and then re-solder the wire to the circuit board.

    For good measures I would pack the whole circuit board with dielectric grease to stop water ingress > further corrosion. In my humble opinion it is very poor design to put such a sensitive component out there exposed to the elements.

    Carlos

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    brighton
    Posts
    27

    Re: NO RECEPTION

    Hi
    Sorry to hijack this thread but in an effort to improve my radio reception, I have just removed the b-sting aerial base but cannot find a way into the booster circuit board.
    Does the unit slip out of the black shroud when the 2 screws are removed or do you have to force it? I really do not want to cut the coax or the power cable cos there is little or no slack to make a new connection.

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    MD
    Posts
    11

    Re: NO RECEPTION

    Just had mine off and i can confirm that the booster circuit just slips out of the black casing once you have undone the 2 screws.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    brighton
    Posts
    27

    Re: NO RECEPTION

    cheers Wislun
    will give it another try - mine seems stuck but maybe some WD40 will do the trick

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2005
    Location
    MD
    Posts
    11

    Re: NO RECEPTION

    Problem solved.

    I eventually traced the problem to a dry joint in the aerial switching box located ontop of the sub enclosure.
    Thanks for everyones help.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO