Badger5Volks Autos
Results 1 to 10 of 10
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    85

    Oil level sensor problem ?

    Hi,

    when I try to "read" the oil level on the MMI sometimes I get a message like this:

    "The MMI displayed a message stating that it was unable to display the oil level information at this time."

    The engine is warmed at the service temperature and I try to read the oil level exactly has is written on the manual.

    Does anyone have a idea about this ?

    Another question, is that if I try to measure the oil level on the same place and following the same procedure I get different readings . . .

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    85
    Well, after almost 12 000 miles I got this reading on my MMI.
    http://img710.imageshack.us/img710/8946/dsc00065oi.jpg
    What's strange is that I dont get the warning to add some oil to the engine . . .

  4. #3
    6th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Coventry
    Posts
    2,219
    I had the same problem as luis.Took 10 days before i could get a reading.So off to the dealers (I live there) to get myself an advanced piece of technical equipment called a dipstick.But they dont make one for my 2ltr tdi.Bugger.How daft is that?Trust the MMI i dont think so.
    Pass me my sock

    Want to help cure cancer? http://folding.stanford.edu/English/HomePage

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    85
    During the last few miles, I continue with the same problem, sometimes I get a reading, then during a week or two I'm not able to check the oil level . . .
    Meanwhile I'm with 12 700 miles no oil warning light came on, which might be good or not, I guess that on the next couple of days the car will go to the dealers, at least I'll have a piece of paper statint that everything is ok . . . Let's wait and see

  6. #5
    HardShoulder

    Status
    Offline
    Join Date
    Mar 2010
    Location
    STOCKPORT
    Posts
    7
    I have had the same problem on mine, i noticed whenever i take the filler cap off, i get the error message for a couple of hours, makes refilling a bit of a nightmare

    DavyBoy

  7. #6
    HardShoulder

    Status
    Offline
    Join Date
    Mar 2010
    Location
    STOCKPORT
    Posts
    7
    mine has now decided to say " Drain Some Oil" which is odd as i have not added any, the dealer has it booked in for the sensor to be replaced - 5 Day old 2.0 TDi

    DavyBoy

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    1
    I bought brand new A4 2.0T. the MMI started reading less oil level after about 2500KM then it showed minimum on 4000KM. I took the car to the dealer which kept saying this is normal unil the expert saw the car and was worried the consumption is more than usual. They toped the oil up and said i have to watch it as they cant measure the consumption before 5000KM. after two days only the MMI read the oil level less than the max by a very small amount. I parked the car for one day and when i started it again the MMI showed empty oil but no light came on the dash board.I switch off the car then on again, i got the message "there is no information about engine oil level" car now is on 4000 KM but what worries me is that one week after i toped it up the MMI reads empty. Is that oil problem or MMI reads wrong? help me please in this..

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    334
    Quote Originally Posted by luis.filipe View Post
    Well, after almost 12 000 miles I got this reading on my MMI.
    http://img710.imageshack.us/img710/8946/dsc00065oi.jpg
    What's strange is that I dont get the warning to add some oil to the engine . . .
    I think that message means it IS time to add oil. The motor is not literally empty of oil

  10. #9
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    334
    Quote Originally Posted by johnnythepie View Post
    I had the same problem as luis.Took 10 days before i could get a reading.So off to the dealers (I live there) to get myself an advanced piece of technical equipment called a dipstick.But they dont make one for my 2ltr tdi.Bugger.How daft is that?Trust the MMI i dont think so.
    I have a 2010 2.0 TDI bought a dipstick off an earlier B8 2.0 TDI, but it is too long.... the dipstick tube was longer on the earlier car.

    If you measure the Audi workshop tool its about 497 to high mark, 522 to low mark.

    A VW Passat 1.6 bluemotion has a dipstick that is pretty much those dimensions, but the thick part under the collar at the top is slightly different to the A4 blank, its as if the dipsticks are coded by having vanes on the top in different places.

    So I am going to buy a VW one and grind the vane off the collar..... cos the guy I borrowed the dipstick off would not let me grind his

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Bourneouth, UK
    Posts
    11
    did anyone ever get a conclusion on this?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO