JMB RetrofitsBadger5
Results 1 to 9 of 9
  1. #1
    Big Bird's Avatar
    Neutral

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    81

    Emissions warning light

    4 years, 54k miles and my car has never missed a beat. until yesterday......

    the engine management light or as I now know, the emissions control warning light, illuminated and stayed on. Car seems to be running fine. It's due a service inc air filter in 2 months.

    any experience of this before I call audi and book it in?

    its a 2.0 tfsi quattro on 09 plate.....
    2009 A4 Avant, 2.0T Quattro S-Line, 19" alloys, B&O audio, Satnav, Reversing camera, Milano leather, misano red, light pack, heated seats, bluetooth phone prep

    Honda VFR 800 VTEC - Italian Red

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,530
    needs pluging in for fault codes
    could be anything so no point in a guess

  4. #3
    Anthony566's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    North East
    Posts
    614
    Quote Originally Posted by Big Bird View Post
    4 years, 54k miles and my car has never missed a beat. until yesterday......

    the engine management light or as I now know, the emissions control warning light, illuminated and stayed on. Car seems to be running fine. It's due a service inc air filter in 2 months.

    any experience of this before I call audi and book it in?

    its a 2.0 tfsi quattro on 09 plate.....
    Where are you based ? Someone on the forum with a vcds can plug into it ...
    2013 A4 2.0 TDi 177 quattro Black Edition - Glacier White

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2014
    Posts
    3
    evening i too have just had my light come on - car runs fine but would like to scan for correct code.

    live in portsmouth area so any hepl would be much appreciated

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Southern Scotland
    Posts
    254
    Quote Originally Posted by bez101 View Post
    needs pluging in for fault codes
    could be anything so no point in a guess
    Exactly, if you were really worried you could read some other threads on issues with 2.0TFSI - then --------------!

  7. #6
    ScottishS3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    May 2011
    Location
    Moray
    Posts
    1,489
    Is using a lot of oil? Is your tailpipe constantly being covered in black soot?
    2009 Audi A4 2.0 TFSI S line, Misano Red, 19" Black Edition Rotors, RS4 Grille, Sat Nav, AMI, Bluetooth, Phone & Voice Prep, CD Changer, Gloss Pack, Heated Seats, Cruise Control, Electric Folding Mirrors, S line Suspension, Dynamic Boot Spoiler, K&N Typhoon Induction Kit



  8. #7
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Southern Scotland
    Posts
    254
    Quote Originally Posted by ScottishS3 View Post
    Is using a lot of oil? Is your tailpipe constantly being covered in black soot?
    Or even showing "wetted" on the outside? I've seen an Avensis with that (as well as my wife's 1.4 16V BBY engine Polo).

  9. #8
    Big Bird's Avatar
    Neutral

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    81
    Ok, thought I'd better update this!

    Took the car to audi who indeed informed me the car required a new complete inlet manifold. The issue was a plastic rod type assembly at the rear vacuum unit on the manifold - not available to change on its own!

    The cost for parts? £900 plus!!!

    However, as I've a full history with the dealer, they agreed to replace the manifold for £150. The remainder was covered by a mix of Audi uk and a dealer goodwill gesture, so I'm well pleased.
    2009 A4 Avant, 2.0T Quattro S-Line, 19" alloys, B&O audio, Satnav, Reversing camera, Milano leather, misano red, light pack, heated seats, bluetooth phone prep

    Honda VFR 800 VTEC - Italian Red

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Southern Scotland
    Posts
    254
    Well that was a good enough result!

 

 

Similar Threads

  1. emission warning light! any ideas.
    By jonny flares in forum Diesel forum
    Replies: 3
    Last Post: 10th December 2009, 16:52
  2. Emissions warning light......still not fixed!!!
    By RicoS3 in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 21st August 2009, 15:45
  3. 'Emissions' warning light - anyone else had this?
    By Richardesty in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 3
    Last Post: 1st May 2009, 18:35
  4. Emission Warning Light
    By Highwayman in forum A3/S3/Sportback (8P Chassis)
    Replies: 10
    Last Post: 7th August 2008, 22:25
  5. emission warning light
    By slater170 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 16th March 2008, 21:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO