Badger5Sky Insurance
Results 1 to 22 of 22
  1. #1
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66

    Question Cruise control Troubleshooting

    Hi All!

    My cruise control has suddenly stopped working on my Audi A4 TDI, not sure what has caused this as one day it was working and next it had stopped,

    what steps can i take to troubleshoot before taking it to an audi garage?

    cheers

    jason

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Online
    Join Date
    Feb 2010
    Posts
    2,170
    Your going to need access to vag-com to see why the cruise is not working.

  4. #3
    jwhat's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Ireland
    Posts
    524
    Are your brake lights stuck on? If so it could be your brake light switch. Clutch switch might also be the issue. But use vag-com to make sure before you start spending money.

  5. #4
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    remove the clutch switch and bridge the connections together, this would deffo be my first port of call, also this fault will not show up on vagcom
    LOTS DONE, LOTS SPENT !!!!

  6. #5
    6th Gear

    Status
    Online
    Join Date
    Feb 2010
    Posts
    2,170
    This can be done via vag-com, you can monitor the clutch switch, brake switch & accelerator peddle without having to disconnect any wiring or switches.

    Many members on here have vag-com just post your location, I'm sure someone can help

  7. #6
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    ah yeh, you sure can nut, it was quicker for me to pull the plug on the switch than it was to find the channel in vagcom lmfao
    LOTS DONE, LOTS SPENT !!!!

  8. #7
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66
    cheers for the this guys... will have a look if it stops raining today :-D

  9. #8
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    where abouts are you einonsy ?
    dont mind helping you mate if your close enough
    LOTS DONE, LOTS SPENT !!!!

  10. #9
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66
    I live in south wales - bridgend, dont mind travelling a little bit :-)

    had a quick google and found this: http://cgi.ebay.co.uk/newest-vagcom-...ht_3092wt_1167

    I always thought vagcom cost a bit more, so surely this cant be genuine?

  11. #10
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66
    lol, midlands a tad far, probably cheaper going to the stealers than to travel to you 1wheelonly :-D Very kind offer though, thanks!

  12. #11
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    nah, not a genuine one at all mate, hes stating that no other software will work with it, thats rubbish mate, just means its hacked, youll get no support etc etc
    if your after one mate then i suggest you get a genuine one, contact NHN on here, he sell the genuine ones cheaper than anyone else.
    LOTS DONE, LOTS SPENT !!!!

  13. #12
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,099
    Completely fake, dont waste your money as you will eventually regret it.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  14. #13
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66
    cheers! im probablt going to try the clutch switch first as recommended, ive seen there not too expensive to replace if this is the issue.

  15. #14
    einonsy's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bridgend, South Wales
    Posts
    66
    Cheers for all the replies guys, tried suggested test of unplugging the brake / clutch switches, this didnt seam to have any affect, ive taken pictures of what i unplugged to make sure im unplugging the clutch and brake switches.




    Is it a trip to the stealers or is anyone close buy willing to lend me their vagcom :-D

  16. #15
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    the two wires in the plug you have taken out of the switch need to be bridged together to make a circuit, then whilst there together retest the cruise.
    LOTS DONE, LOTS SPENT !!!!

  17. #16
    dubdemand's Avatar
    VAG Addict

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Surrey
    Posts
    405
    Rather than start a new thread I thought I'd just add on to the bottom of this one...

    Had to do a run this afternoon to clear the light and re-gen the DPF and on the way back I realised cruise control would not activate. After a bit of research I realise that the clutch switch is probably the best place to start but am not overly confident on trying to fix it myself.

    Does anyone live near by with VAGCOM or an experience of sorting out this problem? Im in Surrey but willing to travel...
    2009 A4 2.0 TDI (170) Avant S Line Exec. ​Quartz Grey, S Line suspension, Bluetooth phone prep low, AMI, DAB, Symphony III, Leather/Alcantara, rear sun blinds, heated/dimming/folding mirrors and cruise control. Mods so far: BBS LM (reps), needle sweep and dipping mirror on reverse. To come: spacers, rear window tint and badge delete.

  18. #17
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,185
    Trust me, the clutch switch is easy to replace and the part is cheap as well. Just under a few screws to remove the bottom panel underneath your steering wheel. You'll see the white switch above the clutch. Just unplug, twist and remove. To put the new one in, push the clutch down, hold the switch against the hole, bring the clutch back up to it's resting position, then turn and twist into place.
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

  19. #18
    dubdemand's Avatar
    VAG Addict

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Surrey
    Posts
    405
    Thanks matey, will have a word with Audi, get the part on order and hopefully that'll sort it. Will post the outcome!
    2009 A4 2.0 TDI (170) Avant S Line Exec. ​Quartz Grey, S Line suspension, Bluetooth phone prep low, AMI, DAB, Symphony III, Leather/Alcantara, rear sun blinds, heated/dimming/folding mirrors and cruise control. Mods so far: BBS LM (reps), needle sweep and dipping mirror on reverse. To come: spacers, rear window tint and badge delete.

  20. #19
    JimLoskot's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Manchester
    Posts
    155
    just set off for our holdays driving down to france and the cruise isn't working!!!!!!!!!!!!
    fortunately just found this thread, pulled the plug off the clutch switch and put a bent paper clip into both the terminals to bridge it, took it out for a quick spin and it works. hurray!
    I just hope that the local tps has a clutch switch in stock or somewhere else does nearby.
    any other suggestions for parts places incase tps don't have any in? i'm staying in twickenham until about half 11 when we have to go and get the ferry from dover
    2.5 tdi Quattro sport - PhatBox - DIS - Cruise - RS4 ARB - Remap - and a few other minor mods/retrofits
    2.0 TFSI A4 b7 cab - completely std for now... (the wife's car)

  21. #20
    4th Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    807
    Im sure my mate said there is a euro car parts not far from syon lane just opened.

    Or there is a VW garage on gillette corner. Or west london Audi just down the road from VW....

  22. #21
    JimLoskot's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Manchester
    Posts
    155
    thanks for the reply, the tps had one in, 10 min job to fit and good to use the cruise on the long drive down france
    2.5 tdi Quattro sport - PhatBox - DIS - Cruise - RS4 ARB - Remap - and a few other minor mods/retrofits
    2.0 TFSI A4 b7 cab - completely std for now... (the wife's car)

  23. #22
    Neutral

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    34
    thank you so much guys i had the same problem and using the bent paper clip advice i diagnosed a faulty clutch switch. mine was blue instead of white but nevertheless i ll be getting a replacement asap. thanks again!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO