JMB RetrofitsBadger5
Results 1 to 27 of 27
Like Tree1Likes
  • 1 Post By sainte986

Thread: A4 2.0TFSI Quattro feels underpowered

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    10

    A4 2.0TFSI Quattro feels underpowered

    Hello,
    I recently purchased an A4 2.0TFSI Quattro and after driving it for a couple of weeks I think it feels a little underpowered as if somethings not working correctly. I compared it today with a similar car but without Quattro and that pulled really well in 2nd and 3rd gears whereas mine doesnt pull as hard. I guess that a bit of power is lost through the quattro system but surely not this much. At 65mph in 6th I put my foot down and not a lot happens just slowly starts to accelerate.

    Any ideas what could be wrong?

    Cheers,
    Steve

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    10blazin's Avatar
    HYPERDRIVE NEEDED

    Status
    Offline
    Join Date
    Dec 2008
    Location
    gorton
    Posts
    3,272
    Quattro does slow the car a little i suggest you get a remap ...you will be laughing then

  4. #3
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Online
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,503

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Might be worth getting the car on Vagcom to see if maybe you have a lingering fault thats holing her back.

  5. #4
    pjmspeedy's Avatar
    Dude, what's mine say ?

    Status
    Offline
    Join Date
    Apr 2008
    Location
    North West
    Posts
    1,057
    Could possibly be a faulty n75 valve. Plug vagcom in as already suggested to see if it throws any codes up
    Audi A4 1.8T Sport Cabriolet-Full black leather(Electric & heated),RNS-E,BOSE, OEM Bluetooth,RS4 Mirrors,RS4 FBMFSW,RS4 Pedals,RS4 RARB,Cruise Control,B7 Rear Lights,Ally Inlays,18" RS6 Alloys,HID's/Auto lights with dimming rear view mirror,Coming home lights,Ambient light pack & Rear parking sensors.

    For all your VAG OEM PARTS send me a PM or e-mail me at vagoemparts@ymail.com

  6. #5
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    I had the same problem. Same thing in 6th gear etc. It's the diverter valve in the turbo. It's only Ł40 odd quid from Audi. You need the uprated piston type one not a diaphramed one as these are what fail. The rubber splits and it can't hold peak boost. It's easy to fit if your competant with a set of tools if not it's worth buying frm Audi and getting fitted as it's only a half hour job. I had mine mapped by Jabbasport and it was still slow so they plugged in their vagcom and logged it wasn't holding boost. Once the new DV was installed it was unreal. It's a comon fault on these engines. It's important you replace valve if you plan remap etc. Hope this helps. Craig.
    If it's got t*ts or wheels, it's TROUBLE!

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    stoke on trent
    Posts
    17
    where abouts in the engine is this diverter valve located im going to replace mine prior to remap.

  8. #7
    mike beech's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Lancashire
    Posts
    42
    Its located to the front of the engine on the airbox side of the engine bay attached to a hose coming directly off the turbo. There is a fitting guide on the forge website to fit the DV spacer and the actual Diverter Valve needs to be removed to fit this.

    The new upgraded audi one is miles better quality than whats fitted as standard.

    link to forge sheet http://www.forgemotorsport.co.uk/med...it%20valve.pdf

    different car once remapped as well btw
    2006 B7 A4 2.0T Quattro S Line Avant - RNS-E Sat Nav - Bose - DIS - PP 250bhp remap - SOLD

  9. #8
    mike beech's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Lancashire
    Posts
    42
    i'm a dumb arse, just looked at the info sheet, the DV is fitted to the turbo housing itself not a hose as I said. Its about a 30 mins job to do and the undertray needs to be taken off to access the relevant area. Its almost impossible to do this job from above.

    I had to do it twice because the forge spacer that I ordered was incorrect and was meant for the later DV
    2006 B7 A4 2.0T Quattro S Line Avant - RNS-E Sat Nav - Bose - DIS - PP 250bhp remap - SOLD

  10. #9
    10blazin's Avatar
    HYPERDRIVE NEEDED

    Status
    Offline
    Join Date
    Dec 2008
    Location
    gorton
    Posts
    3,272
    I dont think its the dv mine is an a3 2.0tfsi and its faster than the a4 but serious im not overly chuft with the speed either but when i got a trial map , I was like thats better its got the kick it need's ....

    I had a diverter valve leek and the revs were going up and down and the car was crud ...i could defo feel something was wrong so i think you would of noticed it ...You probably just need a map , Get it on vagcom and if nothing shows up dont get the valve changed till it breaks there's no point....IF IT AINT BROKE DONT FIX IT !!

  11. #10
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Quote Originally Posted by 10blazin View Post
    I dont think its the dv mine is an a3 2.0tfsi and its faster than the a4 but serious im not overly chuft with the speed either but when i got a trial map , I was like thats better its got the kick it need's ....

    I had a diverter valve leek and the revs were going up and down and the car was crud ...i could defo feel something was wrong so i think you would of noticed it ...You probably just need a map , Get it on vagcom and if nothing shows up dont get the valve changed till it breaks there's no point....IF IT AINT BROKE DONT FIX IT !!
    If the rubber on the DV is split it doesn't show on vagcom. Also they don't all run funny either as mine idled fine, ran fine but was just not producing peak power because of the leaking boost..
    If it's got t*ts or wheels, it's TROUBLE!

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Worksop, Notts
    Posts
    97
    They do show on VCDS if you log the requested boost vs actual boost.

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    10
    Just an update, it turned out to be the DV diaphram split. It got fixed under warrenty. When the audi tech asked what the problem was I told him I thought it was the DV and he dismissed it saying he had only seen one fail so I left it with him to diagnose, bit of a smile on my face when I got a call saying the DV had split. Anyway all done and its like a different car, pulls really well. Another plus point is they lent me a brand new TT convertible for two days while they were fixing mine.
    Steve

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2010
    Posts
    17
    Any one know when Audi moved over to the improved DV, just sorting out swapping my 3.2 A3 for a07 plate 2.0 TFSI Quattro Sline Special Edition and Id like to know if its something I should look for.

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2010
    Posts
    10
    Quote Originally Posted by TorqueTerrorist View Post
    I had the same problem. Same thing in 6th gear etc. It's the diverter valve in the turbo. It's only Ł40 odd quid from Audi. You need the uprated piston type one not a diaphramed one as these are what fail. The rubber splits and it can't hold peak boost. It's easy to fit if your competant with a set of tools if not it's worth buying frm Audi and getting fitted as it's only a half hour job. I had mine mapped by Jabbasport and it was still slow so they plugged in their vagcom and logged it wasn't holding boost. Once the new DV was installed it was unreal. It's a comon fault on these engines. It's important you replace valve if you plan remap etc. Hope this helps. Craig.
    It must be a common thing on turbo cars, I had the exact same thing on my astra vxr.

  16. #15
    A4 SE S line 2.0T FSI

    Status
    Offline
    Join Date
    Jan 2010
    Location
    greater manchester
    Posts
    3
    hi does anyone have the part number for the diverter vale, thanks

  17. #16
    hazey7's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    170
    Can't believe no-one has said respect to the Torque Terrorist for diagnosing the exact fault via an email. Well done lad.

    'Almost' a similar thing happened years ago on my Audi Quattro Turbo, big flexible hose between turbo and air intercooler had a slight split meaning that once the boost air gets to a certain pressure it leaks and you lose a load of power. Won't show up on diagnostics unless someone is clever enough to measure boost air pressure.

  18. #17
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Quote Originally Posted by hazey7 View Post
    Can't believe no-one has said respect to the Torque Terrorist for diagnosing the exact fault via an email. Well done lad.

    'Almost' a similar thing happened years ago on my Audi Quattro Turbo, big flexible hose between turbo and air intercooler had a slight split meaning that once the boost air gets to a certain pressure it leaks and you lose a load of power. Won't show up on diagnostics unless someone is clever enough to measure boost air pressure.
    Why thankyou!!
    I would just like to thank my family, my agent and all others who really came together to make this advice a reality! LOL
    If it's got t*ts or wheels, it's TROUBLE!

  19. #18
    mike beech's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Lancashire
    Posts
    42
    http://www.jkm.org.uk/performance/tfsidiverters.htm

    Link for the later audi diverter valve, scroll to bottom of page. These are only fitted as standard to B8 audi 2.0 TFSI's not B7's but a direct fit for all B7's.

    Someone else recommended this company to me and cant praise them enough, spoke to them on the phone a few times as well. Very knowledgable
    2006 B7 A4 2.0T Quattro S Line Avant - RNS-E Sat Nav - Bose - DIS - PP 250bhp remap - SOLD

  20. #19
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Picture of failed DV. Split in green rubber diaphram
    Last edited by TorqueTerrorist; 13th February 2010 at 18:56.
    If it's got t*ts or wheels, it's TROUBLE!

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2007
    Posts
    4

    Hi All I'm new to the A4 scene

    Hi all, I'm new and have an A4 B7 2.0TFSi DTM.

    I have just got my DTM, however I have the following faults showing on VCDS, and I'm wondering if this is caused by the same valve as sometimes the revs start hunting a little, enough to notice it though.

    3 Faults Found:
    008583 - Bank 1; System too Lean at Idle
    P2187 - 004 - No Signal/Communication - MIL ON
    Freeze Frame:
    Fault Status: 11100100
    Fault Priority: 0
    Fault Frequency: 3
    Mileage: 46980 km
    Time Indication: 0

    Freeze Frame:
    RPM: 749 /min
    Load: 14.1 %
    Speed: 0.0 km/h
    Temperature: 81.0°C
    Temperature: 7.0°C
    Absolute Pres.: 1000.0 mbar
    Voltage: 14.224 V

    001287 - Idle Control System RPM: Higher than Expected.
    P0507 - 001 - Upper Limit Exceeded
    Freeze Frame:
    Fault Status: 01100001
    Fault Priority: 0
    Fault Frequency: 20
    Mileage: 46981 km
    Time Indication: 0

    Freeze Frame:
    RPM: 1041 /min
    Load: 14.5 %
    Speed: 0.0 km/h
    Temperature: 83.0°C
    Temperature: 24.0°C
    Absolute Pres.: 1010.0 mbar
    Voltage: 13.843 V

    008825 - Leak in Air Intake System
    P2279 - 002 - Lower Limit Exceeded - Intermittent
    Freeze Frame:
    Fault Status: 00100010
    Fault Priority: 0
    Fault Frequency: 2
    Mileage: 46981 km
    Time Indication: 0

    Freeze Frame:
    RPM: 905 /min
    Load: 14.5 %
    Speed: 0.0 km/h
    Temperature: 82.0°C
    Temperature: 17.0°C
    Absolute Pres.: 1000.0 mbar
    Voltage: 14.097 V

    Readiness: 0000 0000



    Any idea's?


    Cheers
    Sarge
    Last edited by Sarge786; 13th February 2010 at 20:55.

  22. #21
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    10
    Just an update, the car is much better now. I have even booked it in for a Revo re-map on the 22nd so that will an interesting day.
    Steve

  23. #22
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Quote Originally Posted by steveaudi View Post
    Just an update, the car is much better now. I have even booked it in for a Revo re-map on the 22nd so that will an interesting day.
    Steve
    It will be like all your Christmas's and Birthdays have all come at once! Its like a different car once mapped!
    If it's got t*ts or wheels, it's TROUBLE!

  24. #23
    sainte986's Avatar
    Vorsprung Durch Technik

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aldershot, Hants
    Posts
    81
    Quote Originally Posted by skiptowncat View Post
    It must be a common thing on turbo cars, I had the exact same thing on my astra vxr.
    I think that would be more down the it being a poorly built vauxhall
    geordiestig likes this.
    Patrick

    '99 Golf 1.8T - AGU | Indigo Blue | FK Angel Eyes | HID 6000k | Recaro Seats | Climatronic | Currently 150bhp...

  25. #24
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Quote Originally Posted by sainte986 View Post
    I think that would be more down the it being a poorly built vauxhall
    LOL
    If it's got t*ts or wheels, it's TROUBLE!

  26. #25
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    10
    Well its been remapped and all I can say WOW what a difference it doesnt feel underpowered any more. Ben at AV Performance did a top job.

  27. #26
    Audi A4 S-line Avant 2.0T FSI

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Stevenage
    Posts
    289
    Quote Originally Posted by steveaudi View Post
    Well its been remapped and all I can say WOW what a difference it doesnt feel underpowered any more. Ben at AV Performance did a top job.
    See, we told you!! Lol Well done mate.
    If it's got t*ts or wheels, it's TROUBLE!

  28. #27
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    324
    I fitted a boost gauge to my old 1.8t (about an hours work) and could then accurately monitor turbo output.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO