Volks AutosChris Nott
Results 1 to 18 of 18
  1. #1
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155

    Parts for cruise control fit?

    I have a B7 A4, thinking of retro-fitting cruise control. What parts will I need? Is it just the cruise stalk and lower steering column cowling?

    Simply fit the stalk and away you go? I have MFSW so dont think I will need steering wheel ECU and I have VAG-COM as well.

    Thanks...
    A6 3.0 TDI.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    terrymcg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    West Lothian
    Posts
    236
    Hi mate,

    Have a look on this site, there is a complete guide to fitting cruise: http://www.audiretrofit.co.uk/

    Hope this helps.

    Terry


    57 Plate Imola Yellow S3

  4. #3
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155
    Thanks for that link mate, that's just what I was looking for. Looks like a pretty straightforward job as I dont need to change the steering ECU, off to order some parts now. Thanks again!
    A6 3.0 TDI.

  5. #4
    Andy D's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2007
    Location
    Inverkip, Scotland
    Posts
    276
    Excellent link, I was kinda gutted when I bought my car and it never had cruise.

    Now I know my first modification t concentrate on.

    Let us know how you get on Isaac

  6. #5
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155
    All fitted to the car now, cost for all the parts from the Audi dealer was about 60, was a very simple job to do - took about an hour from start to finish. Just waiting for my new HEX-CAN VAG-COM cable to arrive then I'll code it to the car so it works.
    A6 3.0 TDI.

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Hi all,I didnt want to start a new thread for one little question,I have now recieved my cruise control stalk and lower cowling.Do I need to purchase any fixing screws to mount the stalk?(2006 A4)

    tony

  8. #7
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155
    Quote Originally Posted by tonycb6
    Hi all,I didnt want to start a new thread for one little question,I have now recieved my cruise control stalk and lower cowling.Do I need to purchase any fixing screws to mount the stalk?(2006 A4)

    tony
    No you wont need anymore screws.
    A6 3.0 TDI.

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Thanks for that, just fitting the cruise control,managed to clear all faults and recoded my steering wheel control(04041) but it wont work.Am i missing something? I printed off the pdf on the retofit site and all went well until it states: "coding for the engine"ENGINE 01,CODING-II 11,enter 11463 (do it). Well i cant select "CODING-II 11" as it is shaded out.

    Any ideas?


    Tony
    Last edited by tonycb6; 2nd February 2008 at 15:08. Reason: I cant spell!

  10. #9
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155
    Are you confident you dont need a new steering ECU? Do you have MFSW? If not then its likely the ECU needs changing.
    A6 3.0 TDI.

  11. #10
    PetrolDave's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,537
    Quote Originally Posted by tonycb6
    Well i cant select "CODING-II 11" as it is shaded out.
    Can you select "LOGIN 11"? That's the one you want.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Ido have the mfsw and the control arm pluged in to the contol module ok.

    as i say coding-II 11 is shaded out and in other modes the same button changes to "login in" ,so it looks like the program is not changing to Login.

    Now currently looking to enter the code in to the security 16 but having to wait 10mins to time out.

    Just to make sure i am singing from same book, Ihave opened vag com

    press select in top left corner
    then select 01 engine from the common tap
    its then i cant select coding/login it is shaded out

    Also in the soft coding box it states "long coding"

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Security access 16 as refused the key.So it dont go there.


    tony

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Hooray done it!!

    I had to use the recode in the long code section,my old code was ..0104000318070020.. I then read:
    http://wiki.ross-tech.com/index.php/.../BWA%29#Coding

    I had to change to;0104000318070120

    Also I dont get it how some people say you dont need extra screws in my install you do need screws? 2 screws hold on each stalk,I had to use one screw from the indicator stalk to hold the cruise stalk,so if you are planning an install buy 2 screws.
    Also be aware that because the battery has been disconnected you will need to pair up the car for the remote locking,instructions in the manual.
    Also the "one touch"windows need to be reset ,again in the manual.

    Now have a niced little "clock timer"light on dash when cruise is on,and feels strange when you can accelerate and deaccelerate moving the stalk and and down.

    Anyway,is there a reason why I couldn't use "login" or"coding-II"

    many thanks

    Tony

  15. #14
    5th Gear

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Hampshire
    Posts
    1,155
    When I said you dont need 'extra' screws I meant that the kit I bought from Audi included the bits needed to complete the job, therefore no 'extra' screws were required. Sorry for the confusion

    Im unsure why the login or coding didnt work, I didnt need to use the long coding to set mine up. I run the same cable and version of VAG-COM. Glad to hear its all workling fine now though!
    A6 3.0 TDI.

  16. #15
    Neutral

    Status
    Offline
    Join Date
    Sep 2006
    Posts
    41
    Ahh part from audi = screws
    part from vagparts = no screws

    cheers

    Tony

  17. #16
    PetrolDave's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,537
    Quote Originally Posted by tonycb6
    Anyway,is there a reason why I couldn't use "login" or"coding-II"
    Yes.

    Your ECU is one of the newer ones that uses long coding, the login is only needed for older type ECUs that use normal (I suppose we should now call it short) coding.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  18. #17
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2009
    Posts
    1
    Hi
    the audi retro fit site has been removed. Does anyone have another link on how to retofit to my 2006 A4 Cab with MFSW
    Thanks Rich

  19. #18
    1st Gear

    Status
    Offline
    Join Date
    May 2008
    Location
    Bedfordshire
    Posts
    137
    Can someone post the part number required for the cruise "kit" from Audi please?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO