EM TuningVolks Autos
Results 1 to 7 of 7
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    UK
    Posts
    233

    Angry software upgrade gone worry

    Hi all

    I took the A4 TDI into audi today and they checked the idle shaking problem out.

    The master tech guy upgraded the ECU software, saying this might help and that my car was running quite an old ECU software version. That sounded strange because its only 8 months old but hey i'm not a car engineer.

    But now driving the car home and tonight 1st gear is totally wrong.
    Every time I pull away in 1st gear the car seems to hold back, like massive turbo lag.

    Its like you get to 2k and someone pulls the handbrake on.

    The car still drives fine apart from this, but this isnt right and its horrible to drive.

    What has gone wrong ?

    The shaking at idle is still just as bad and audi have agreed its there but been quite honest with me and said they doubt they can fix it..
    So I brought a 21k car and put up with it.....yeah right

    Not happy at the mo

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2006
    Location
    N.Ireland
    Posts
    369
    i had a bad shaking engine last week, it was a split hose going to the inlet manifold, it had perished over time, replaced that and car is so smooth at idle again.

    see if they can test all hoses for leaks/splits

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2005
    Location
    Berkshire
    Posts
    22
    I get shaking on and off. Also terrible power dive if I change fast from 1st to 2nd and boot it... Never resolved.
    El Dingo

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Dec 2004
    Location
    Cheshire, UK
    Posts
    42
    My 2.0 tdi A3 does this, and so did my 1.9 TDI golf! I did hear a long time ago that it was a known fault that could be fixed by upgrading the ECU, but could never convince myself that upgrading the software could fix it. I also think that it only does it when the weather is cold, because I can't remember the car doing it in the summer.
    A4 Avant 2.0 TDI Quattro S-line (B8)

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    May 2006
    Location
    UK
    Posts
    233
    Yes my TDI 1.9 golf did as well.
    But only when cold. But this A4 TDI is doing it all the time...
    ARHHHHHHHH!!!

  7. #6
    The911SC's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Sep 2003
    Location
    South Wales - Swansea
    Posts
    1,032
    get it back to the dealers then.. keep bugging them 'til its solved especially if it worse now than before..

    My RS4 shakes a bit...... if you rev it at idle... !!!!!!
    Porsche 997 Carrera 4 S - Black, Sport Chrono, Sport seats, PCM, Nav, Tel, Park assist and rear wiper (Yes!, its an option!)
    2012 Audi Q7 Sline Plus - Daytona Grey ,Nav+, Wheel upgrade, Storage and tow pack.

    Gone -2007 S5 4.2 ,2008 S3, 2007 TTC 3.2, 2007 RS4 Saloon, 2004 S4 Saloon, 2006 A4 2.0T Sline SE,2002 A3 3.2 Sline, 2001 A4 1.8T,2001 Boxster, 1983 911SC,1992 Corrado G60,1988 GTi.

    (Vag com owner)

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Posts
    3
    Take it back! My 5 month old 2.0TDI ended up in the dealers for 2 months and the problems started with shaking when idle then no power as if the turbo had gone. They replaced one of the injectors (on 2 occassions), the wiring harness, fuel pump (3 of those fitted) and the cylinder head. I have got it back and it has stopped the shaking but I don't know if I'll keep it because its been quite a bad experience.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO