AH FabricationsMonster Motorsport
Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By PetrolDave

Thread: Retro fit cruise activating issue.

  1. #1
    Neutral

    Status
    Offline
    Join Date
    May 2013
    Posts
    33

    Retro fit cruise activating issue.

    Morning All,

    I have fitted the cruise and dis stalks to my 2006 A4 avant s line with multi function steering wheel and with Mike Fosters help (thank you) we managed to enable the dis function and I earthed out pin one to get rid of the washer level warning which is great. The problem I have now is I can not enable the cruise, when I go into 01-engine then into coding II- 11 and put in the activation code 11463-cruise activation and then click DO IT an error message comes up saying,

    Login code not accepted by controller!

    You will have to turn the ignition off
    for a while before trying again.

    Error22: Conditions not correct or request sequence error.

    So not being a Vagcom guru i'm a bit stumped can anyone shed a bit of light on this for me as I've obviously missed a step out or have some thing missing.

    Also for info when I go into 16-steering wheel then into meas. blocks-08 I can see that the car and Vagcom can see the stalk is fitted because when I move the stalk it says cruise switch on or off then it says resume etc so it does see it.

    Cheers all,
    Last edited by trickybusa; 21st December 2013 at 11:54.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,099
    So 16 is coded for cruise, did you try with engine started & just ignition turned on.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,492
    i had something like this the first cruise i ever did
    i had engine running
    engine off and it worked.

  5. #4
    PetrolDave's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,533
    Quote Originally Posted by bez101 View Post
    engine off and it worked.
    +1

    I also found that the cruise control switch needed to be in the off position when you do the coding.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  6. #5
    Neutral

    Status
    Offline
    Join Date
    May 2013
    Posts
    33
    We had another go at this over the hols and managed to get rid of the error 22 some how not too sure what happened there. The only differences were that I have earthed out pin one at the back of the clocks to get rid of the low screen wash warning and also I had removed the rear wiper motor as it was faulty first try and I had replaced it on the second try. So first attempt was no wire to pin one and no rear wiper motor and dis up and working fine. So me and Mike Foster tried again this time we got no error 22 and it seemed to accept the 11463 code we had entered but the cruise did not work. Just remembered we noticed the clutch switch was not working so we called it a day. I then went and bought and fitted a new switch recoded again with the vag-com still no cruise so I tried the old locking the steering over fully from side to side drive for 200 yards turned the ignition off for thirty seconds and drove the car again and the cruise worked.

    Cheers Rick......

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,099
    Yeah if there is a module or sensor acting up & not sending correct signal as part of the cruise operating system, it will not allow coding to be done on most cars, sounds like the angle sensor etc needed to be reset aswell after the switch was replaced, glad all fixed.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    Neutral

    Status
    Offline
    Join Date
    May 2013
    Posts
    33
    Quote Originally Posted by NHN View Post
    Yeah if there is a module or sensor acting up & not sending correct signal as part of the cruise operating system, it will not allow coding to be done on most cars, sounds like the angle sensor etc needed to be reset aswell after the switch was replaced, glad all fixed.
    Thanks NHN,

    There is a lot of helpful advice and people on here.

    Cheers Rick.......

  9. #8
    dentsy's Avatar
    I HAVE THE OPTION CODES

    Status
    Offline
    Join Date
    May 2007
    Location
    BLACKWOOD, SOUTH WALES
    Posts
    238
    Hi all, if I fit the cruise switch and DIS stalk this weekend will my car still work ok until I can get the new parts coded in?

    Just thinking that you can't fit new bits as it may disable something on the car until it's coded will it make car in drivable ?

    Thanks

    Si

  10. #9
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,492
    It will work fine

  11. #10
    dentsy's Avatar
    I HAVE THE OPTION CODES

    Status
    Offline
    Join Date
    May 2007
    Location
    BLACKWOOD, SOUTH WALES
    Posts
    238
    Quote Originally Posted by bez101 View Post
    It will work fine

    Ok cool thanks mate !

    As I can't get it hooked up until a few weeks to get it coded in

    What exactly does the guy have to do for me that has the vcds ?

    Regards,

    Si

  12. #11
    PetrolDave's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,533
    Quote Originally Posted by dentsy View Post
    What exactly does the guy have to do for me that has the vcds ?
    1) Recode the SCSM to tell it that a cruise control switch is present.
    2) Enable the cruise control functionality in the engine ECU.
    3) Test that it works.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  13. #12
    dentsy's Avatar
    I HAVE THE OPTION CODES

    Status
    Offline
    Join Date
    May 2007
    Location
    BLACKWOOD, SOUTH WALES
    Posts
    238
    Quote Originally Posted by PetrolDave View Post
    1) Recode the SCSM to tell it that a cruise control switch is present.
    2) Enable the cruise control functionality in the engine ECU.
    3) Test that it works.
    Ok thanks mate , any idea where I can get the vcds process for him and does my radio have to be re coded via vcds do you know as some people say once you disconnect battery you lose your code and it can only be done by logging into the ecu as the code is stored there ?

    Si

  14. #13
    1st Gear

    Status
    Online
    Join Date
    Jun 2013
    Posts
    244
    Radio will not need recoding. It's coded to the car when new, if you remove radio and fit to another vehicle then it would need recoding

  15. #14
    PetrolDave's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,533
    Quote Originally Posted by dentsy View Post
    Ok thanks mate , any idea where I can get the vcds process for him
    Try here retrofit cruise control coding and activation issue

    Or the Ross-Tech wiki here Cruise Control Retrofitting (8E) - Ross-Tech Wiki

    Quote Originally Posted by dentsy View Post
    does my radio have to be re coded via vcds
    Recoded? - no. Need the PIN entered? - different question. If it's the factory fit radio then it remembers the VIN and if that matches then there's no need to enter the PIN. So you shouldn't need the radio PIN code.

    Quote Originally Posted by dentsy View Post
    some people say once you disconnect battery you lose your code and it can only be done by logging into the ecu as the code is stored there ?
    Sounds a load of twaddle to me...
    NHN likes this.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  16. #15
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,099
    As Dave says its mostly Chinese whispers/pub talk, only had a handful in hundreds of units ever require a pin with battery of, they were anomaly's though, but I never take the battery leg of, as it needs vcds anyway, so the coder can clear airbag light at the same time.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

 

 

Similar Threads

  1. retro-fit cruise control
    By IainR in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 0
    Last Post: 15th August 2005, 23:47
  2. Retro Fit Cruise Control on A4 Avant TDI 130
    By kenny_boon in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 11th April 2005, 17:06
  3. Retro Fit Cruise Control
    By mikeA2B in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 21
    Last Post: 17th October 2004, 16:49
  4. Retro fitting Cruise control
    By Seizure in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 16th May 2004, 19:18
  5. Retro fitting cruise control
    By Anito in forum A4/S4 forum(B5 Chassis)
    Replies: 1
    Last Post: 3rd April 2004, 10:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO