Badger5JMB Retrofits
Results 1 to 11 of 11
  1. #1
    pistonripper's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Location
    West Midlands
    Posts
    34

    2.0 TDi EGR Block Problems

    Evening All,

    I've had fuel consumption and power problems (which I never knew I had, until a friend drove my car) ever since I've had the car (over 15 months)...so in trying to find out what is wrong, I blocked the EGR valve today with a metal plate...now there is no power whatsoever for 99% of the time, complete nail...I restarted the car and it went like a rocket..WOW..then died again...will struggle above 2000rpm like its hit a rev limiter. Power will sometimes comeback momentarily....and it comes back strong...just pees me off to experience what I have been missing !! Anybody know what this is pinpointing to ? Oh no error codes when scanned. The reason I blocked the EGR in the first place was the car had no low down power and was smoking under acceleration, crap consumption...I mean really crap and warm start - takes minimum of 5 turns before it fires - cold start is fine.
    Last edited by pistonripper; 15th November 2013 at 15:00.
    2005 Dolphin Grey A4 2.0TDi S-Line Avant.
    19 INCH RS4 Alloys RNS-E Bluetooth Colour DIS Cool box in Glove Box B8 S Line MFSW APS Xenons Auto-dim RV Mirror & Side Mirrors Rain Sensor Coming Home & DRLs Rear APS
    BLB Engine|Tensioner Failure|Full Service History...so what

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Avnt's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    228
    Have you changed fuel filter? Start with the basics first if theys no error codes. Did full service on mine a few weeks back and blanked my egr off as well. I noticed a difference as soon as id changed the fuel filter started nicer drove smoother. I also ran a liquid moly diesel purge as well which made a difference

  4. #3
    DieselJake's Avatar
    God Mode

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Birmingham
    Posts
    1,335
    Turbo's starting to die?... not much knowledge on the situation but this is what a garage said about mine which suffers from similar symptoms.

  5. #4
    pistonripper's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Location
    West Midlands
    Posts
    34
    Ok, going to get the turbo checked, if spindle has no play, then I will get it stripped and cleaned.

    but why is there no power above approx 2000rpm. With the car normal (EGR NORMAL - unblocked) there is decent power above 2000rpm.
    Last edited by pistonripper; 15th November 2013 at 15:04.
    2005 Dolphin Grey A4 2.0TDi S-Line Avant.
    19 INCH RS4 Alloys RNS-E Bluetooth Colour DIS Cool box in Glove Box B8 S Line MFSW APS Xenons Auto-dim RV Mirror & Side Mirrors Rain Sensor Coming Home & DRLs Rear APS
    BLB Engine|Tensioner Failure|Full Service History...so what

  6. #5
    pistonripper's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Location
    West Midlands
    Posts
    34
    Ok my EGR is still blocked off with a plate...but now I have disconnected my MAF...now the power is ALL back ALL the time...its never been this responsive ever....it pulls stong from approx 1400rpm all the way through the rev range.

    This has me baffled now. Is it theturbo vanes...EGR or MAF ?
    2005 Dolphin Grey A4 2.0TDi S-Line Avant.
    19 INCH RS4 Alloys RNS-E Bluetooth Colour DIS Cool box in Glove Box B8 S Line MFSW APS Xenons Auto-dim RV Mirror & Side Mirrors Rain Sensor Coming Home & DRLs Rear APS
    BLB Engine|Tensioner Failure|Full Service History...so what

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    May 2011
    Posts
    195
    If the egr ain't been mapped I'm sure you will get limp mode which sounds like what your getting

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    58
    Correct fossie I had exact same with mine, blanked the egr and no power above 2000 revs, had it mapped out and solved the problem.

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    58
    Quote Originally Posted by pistonripper View Post
    Ok my EGR is still blocked off with a plate...but now I have disconnected my MAF...now the power is ALL back ALL the time...its never been this responsive ever....it pulls stong from approx 1400rpm all the way through the rev range.

    This has me baffled now. Is it theturbo vanes...EGR or MAF ?
    def not the turbo if your back to max power def egr. Have it mapped out never worry about it again

  10. #9
    pistonripper's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Location
    West Midlands
    Posts
    34
    Thanks...took blanking plate off.....if I disconnect MAF, the engine is more responsive and generally car drives better. S%@t fuel consumption either way though
    2005 Dolphin Grey A4 2.0TDi S-Line Avant.
    19 INCH RS4 Alloys RNS-E Bluetooth Colour DIS Cool box in Glove Box B8 S Line MFSW APS Xenons Auto-dim RV Mirror & Side Mirrors Rain Sensor Coming Home & DRLs Rear APS
    BLB Engine|Tensioner Failure|Full Service History...so what

  11. #10
    madstaff's Avatar
    Neutral

    Status
    Offline
    Join Date
    Apr 2012
    Posts
    74
    Quote Originally Posted by pistonripper View Post
    Ok my EGR is still blocked off with a plate...but now I have disconnected my MAF...now the power is ALL back ALL the time...its never been this responsive ever....it pulls stong from approx 1400rpm all the way through the rev range.

    This has me baffled now. Is it theturbo vanes...EGR or MAF ?
    If when you disconnect the MAF sensor it seems to run better, then the MAF is faulty.
    Audi A4 Avant 2.0TDi S-Line Special Edition

  12. #11
    Rick @ Unicorn Motor Dev.'s Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Stockport, Cheshire
    Posts
    748
    EGR needs blanking off, remapping to suit and the MAF checking.

    THanks, RIck
    Unicorn Motor Developments. Bespoke Calibration and Remapping Services
    www.unicornmotordevelopments.com

 

 

Similar Threads

  1. A4 1.9 TDI (130) engine problems - please help
    By Cue_Ball in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 9
    Last Post: 17th March 2008, 14:28
  2. Tdi 130 hesitation problem
    By Burtney in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 32
    Last Post: 11th March 2008, 02:03
  3. A3 2.0 TDI owners POTENTIAL PROBLEM
    By stevehsv868 in forum Diesel forum
    Replies: 0
    Last Post: 11th July 2007, 13:16
  4. AUDI 80 TDI 1995 starting problems
    By adidasandy in forum Diesel forum
    Replies: 1
    Last Post: 6th June 2006, 13:01
  5. Audi A4 1996 TDI 1st gear problem :( Help !!!!!
    By slips in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 26th October 2004, 22:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO