AH FabricationsEM Tuning
Results 1 to 20 of 20
Like Tree2Likes
  • 1 Post By NHN
  • 1 Post By NHN

Thread: No voltage at headlamp washer pump.

  1. #1
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel

    No voltage at headlamp washer pump.

    Having an issue with my headlamp washers not working. I actually went and bought a brand new washer pump to replace it with from TPS. Turns out I bought the pump for the windscreen washer jets (have to sell it now as I can't return electrical items apparently).

    Anyway, I checked the resistance of the pump (1M Ohm) which then led me to bench test it. Turns out the pump works fine. I checked the wiring harness for a supply voltage (ignition and headlights on) but got nothing. Checked for ground on the wiring harness and both the connections (Brown & Brown+Red) were shorting to ground.

    Any ideas what may be the issue here? The washer pumps fuse is fine which has led me to confusion. Also if anybody knows where I can source a wiring diagram to help, or point me in the right direction I'd depreciate it.

    Thanks in advance, Azeem.
    Last edited by A4_MaJiK; 4th November 2013 at 19:32. Reason: Elaborate on issue.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    So the issue is, they don't work or are flaky?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Quote Originally Posted by NHN View Post
    So the issue is, they don't work or are flaky?
    Sorry, they're not working.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    You're testing these with headlights on yes, have to ask as some people don't realise they must be on to work.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Quote Originally Posted by NHN View Post
    You're testing these with headlights on yes, have to ask as some people don't realise they must be on to work.
    Yes headlights on when testing. The motor works fine. I'm just confused why both the wires at the connector are shorting to ground tbh.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  7. #6
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    Have you checked coding is enabled & no errors showing, also can you hear the relay click?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  8. #7
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Quote Originally Posted by NHN View Post
    Have you checked coding is enabled & no errors showing, also can you hear the relay click?
    Not checked anything on VCDS as I don't have access to it. But they used to work before, can the coding lose it's memory or something?

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  9. #8
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    No it shouldn't, but some people play & then wonder why things don't work anymore

    Which fuse did you check, possibly S237 on end of dash & also there's usually a relay that should click, try removing the trim above the drivers footwell, turn engine on, headlights on & activate washers, now you may hear the click for the screen washers, but see if you get a 2nd click for washers even if they don't work, although schematics doesn't show a specific relay for headlight washers, just the x-contact relief relay J59.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  10. #9
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,655
    Can you get access to VCDS?
    Plug it in, check for fault codes and do a output test.
    That should give you a better idea of what it is?

    Might be easier than pulling your csr apart?
    A4 B5 Double Din, RNS-d, TMC, Full Sports Leather Heated with Leather Door Cards and Lower Door trims all for sale.

    Audrey's Build Thread
    RIP Audrey. She's being broken down.
    New Car, New Thread.
    Scott's Akoya Silver A8

  11. #10
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Might just do that, inspecting the relays isn't too difficult anyway. Takes 2mins to pull the footwell trim out so may have a look at that.

    Thanks for the help again guys, I'll keep the thread updated with any further discoveries.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  12. #11
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Had a quick read through this retrofit guide for further information on the headlamp washer circuit. Looks like the control voltage is from the central control module at connector T10/Pin2. Might check for voltage output here just to be sure. Will also check wiring back to pump from there too as it shouldn't be shorting to ground as it is.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  13. #12
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    UPDATE: Checked for voltage output at the module and it's only giving me 0.1V whenever I use the screenwash (headlights on/off). Anyway, the wire it sends the signal to (which goes to the pump) appears to be shorting to ground somewhere. Need to find out where the "A-Pillar" wire junction is as there is another single pin connection there.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  14. #13
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    I would now put it on vcds & see what it shows & coding is correct, could be an anomaly.
    A4_MaJiK likes this.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  15. #14
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Quote Originally Posted by NHN View Post
    I would now put it on vcds & see what it shows & coding is correct, could be an anomaly.
    I can see why you'd do this but, surely the wire shorting to ground is the issue here?

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  16. #15
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    Depends on how the CE module rests the wire when not in use, usually you'd think it would rest as open circuit.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  17. #16
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Quote Originally Posted by NHN View Post
    Depends on how the CE module rests the wire when not in use, usually you'd think it would rest as open circuit.
    I checked the wire while it was disconnected from the CE module and it was still closed circuit to ground.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  18. #17
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    That's very strange then, check the 17pin connector in A Pillar left, remove the footwell side trim to hopefully reveal the connector blocks, I wonder if anything got wet somehow.
    A4_MaJiK likes this.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  19. #18
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Apparently it is a red/white wire at a one pin connector in black (T1a) at the left A pillar connector station. So I should find it behind the lower footwell trim on the left side right?

    How does the lower trim come apart?

    I'll disconnect the connector and check the wires again to try and pin down where it might be shorting to ground. Nothing is wet as such and even if it were, I'd expect a couple of other things to play up at least.

    Thanks for the help!

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

  20. #19
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,734
    Depends on the engine/gearbox code, but red/white is what I see for an 07 A4 but going through T17B green connector.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  21. #20
    A4_MaJiK's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Leicester, UK
    Posts
    789

    My Social Networking

    Add A4_MaJiK on Facebook Visit A4_MaJiK's Instagram Channel
    Oh ok, well I know what I'm looking for anyway so will keep updating.

    Audi A4 B7 3.0TDI S-Line Sprint Blue
    ~ MTEC DRLs & Sidelights ~ 8000k D1S ~ 19" A6 Le Mans Edition Wheels ~ Eibach Wheel Spacers (5mm F/15mm R) ~ Rear Ambient Lighting ~
    ~ UK Legal Pressed Plates ~ Full Interior LED Lighting ~ Rear Numberplate LED Lights ~ LCR Front Splitter ~

 

 

Similar Threads

  1. headlamp washer pump
    By SteveS in forum A4/S4 forum(B5 Chassis)
    Replies: 0
    Last Post: 13th January 2007, 22:12
  2. Headlamp washers sticking out
    By imported_monkeytrousers in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 6th March 2005, 20:41
  3. Headlamp washer??
    By imported_dpo in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 28th October 2004, 15:44
  4. Installing a Headlamp washer system
    By imported_Tariq in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 20th September 2004, 19:46
  5. Headlamp Washers
    By ZAF in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 27th October 2003, 11:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO