AH FabricationsMonster Motorsport
Results 1 to 8 of 8
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    117

    A4 2.0TFSI Screeching noise

    Hi Everyone,

    I have what sounds like a big problem which I think may be Turbo bearings, here are the symptoms - Everything fine when cold, engine idles and revs fine with no noises.

    When she gets warm I get a horrible screeching noise at idle and on the move when taking my foot off the gas, under load she is fine.

    No appreciable loss of power but idle RPM rises to around 1400 and hunts

    Cant really pinpoint the noise, I am guessing its Turbo related with the change in RPM, but reading around most failures seem to result in noise when revving the engine not when off throttle, engine management light comes on when the noise is there but does go off when starting from cold

    Any ideas? car has been regularly serviced with an Oil change in March

    Any help would be appreciated
    Ken

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    117
    Just a thought, if it was the turbo bearings would I expect to see a lot of smoke from the exhaust? any help would be appreciated

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2012
    Location
    Fife, Scotland
    Posts
    20
    It's not the alternator belt or something silly like that? Also get it scanned with Vcds software, this will show up any errors that have been logged when your engine management light came on.

  5. #4
    Molnboman's Avatar
    5th Gear

    Status
    Offline
    Am no expert Mate...but if your turbo was knackered you would know all about it....White smoke from your exhaust if it's gubbed. Can you remove the oil cap at idle?...if not, it might be your PCV valve. My engine revs were hunting and I was getting a EML light on and poor mpg.....it cured it. Lots of issues and quite a few symptoms when the PCV goes. One is a high pitch whistling sound. You could also try some belt dressing spray to eliminate the V belt being the issue. ......Have you had it checked for fault codes yet?

    Cheers
    A
    Last edited by Molnboman; 3rd September 2013 at 16:58.

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    117
    Thanks A, I have to admit that the noise in this video is exactly the same I am convinced of it - audi engine noise.m4v - YouTube will take a look tonight and let you know, one thing why would it happen only when she is warm?

    Is the round black assembly the PCV valve?

    Thank you for the help really appreciated, Ken

  7. #6
    craichouse's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    76
    Quote Originally Posted by heli_madken View Post
    Thanks A, I have to admit that the noise in this video is exactly the same I am convinced of it - audi engine noise.m4v - YouTube will take a look tonight and let you know, one thing why would it happen only when she is warm?

    Is the round black assembly the PCV valve?

    Thank you for the help really appreciated, Ken
    its the Air con pulley. the exactly same thing is happening to mine, Exactly
    my mechanic says it is a common fault with the air con pulley

    getting mine sorted next week
    “If everything seems under control, you're just not going fast enough."

  8. #7
    craichouse's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    76
    “If everything seems under control, you're just not going fast enough."

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Mar 2008
    Posts
    117
    Thanks for your help, it looks like Molnboman is spot on thank you, when I checked last night by running the engine it was difficult to remove the oil cap and when I did air was sucked into the engine, new PCV on order, thanks for your help, Ken

 

 

Similar Threads

  1. Short Screeching Noise on Start Up
    By metricspaces in forum A3/S3 Forum (8L Chassis)
    Replies: 12
    Last Post: 25th November 2013, 21:23
  2. Screeching Noise On Startup
    By WorkInProgress in forum A3/S3 Forum (8L Chassis)
    Replies: 13
    Last Post: 25th February 2013, 18:56
  3. Audi a3 2.0 tdi(2004)- screeching/chirping noise from engine?
    By Weechris90 in forum A3/S3/Sportback (8P Chassis)
    Replies: 14
    Last Post: 8th June 2012, 07:27
  4. Screeching noise
    By physk in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 11th March 2011, 12:09
  5. Loud screeching noise
    By [Dave B] in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 24th December 2009, 23:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO