Sky InsuranceEM Tuning
Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By Gazthesparky
  • 1 Post By Gazthesparky

Thread: Strange Door Electric problems

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Location
    Southampton
    Posts
    128

    Strange Door Electric problems

    Hi,
    I have a strange problem with the electrics on my passenger door of my A4 B7 Cab.
    I removed both front door cards to fit puddle light looms, no problems with fitting them following info from this site.
    The problems started when we tried to code them in, VCDS could,nt communicate with them, though in retrospect "I think" this maybe correct as my friends S4 B7 Cab is exactly the same. Time was short so we put everything back together and the puddle lights worked ok on the drivers door, but nothing on the passenger door at all and now the electric window now doesn't work from the switch on that door.
    I thought that I might have either forgotten to plug the door card loom back in or maybe the switch, but I took off the card again this weekend, and everything is as it should be.
    The passenger window operates ok from the drivers door switches, I checked for a possible blown fuse and fuse 22 is intact, (drivers and passenger door 15A), the drivers window works perfectly as does the electric mirrors on both doors and the central locking as well, now looking at the motor it appears there is a door control unit but it is part of the electric window motor, and there seems to be three plugs going to this unit. I have even swapped the door switch units over with my mates S4 Cab, and mine is good, so I,m at a loss now.
    The only thing I can think of is the control unit on the motor has gone U/S, or possibly a damaged cable in the door hinge area, though as the window can be operated from the drivers side and everything else seems to be ok in that door I,m inclined to think that the cables are ok.
    Has anyone got any ideas? its a bit baffling to be honest.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Location
    Southampton
    Posts
    128
    Well as I have had no replies I can only think that people are at a loss like me on what is wrong, so I have bought a second hand passenger side electric window motor, as the door control unit is part of it, which is what I think maybe U/S.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Dec 2011
    Location
    Glasgow
    Posts
    195
    The cab doesn't have separate door modules. That's why when you are trying to code the door modules it says no communication

    The door modules are actually part of the convenience module 46 I think
    If you go into that module you should see 4 part numbers listed these are the individual door modules


    The puddle lights don't need coding on the cab they just work (you might have to remove the power to the module to reset the puddle light power)


    I've had it where the module locks out and needs resetting


    Make sure all the plugs are attached to the module then remove the power plug and then refit it this removes the power from the module and then when powers applied it resets it


    On another note it would be worth checking for fault codes in module 46 you might have caused a problem and made a fault code be logged hence it shuts the module down.


    Reset all the fault codes and see what happens
    Andy27168 likes this.

    A4 B7 2.0ltr TDI Cabriolet

    Mods
    Puddle lights Illuminated cup holder Cd changer in glove box Interior lighting led upgraded

    Full VCDs

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Location
    Southampton
    Posts
    128
    Cheers for the reply Gaz, I have run a scan with VCDS since and there has been no re-occurring faults, so I will give what you say about trying to reset the module tomorrow, I will update if successful, thanks again.

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Location
    Southampton
    Posts
    128
    I thought I would update this thread, I have now fixed this and it was exactly as Gaz had said somehow the door control just needed resetting.
    I removed the door card and I checked my wiring on the card as I had fitted puddle lights, and after checking the connections were correct and a few continuity checks with a multimeter everything was ok. I then turned my attention to the DCM, and comparing my old one with the new one I bought, and it appeared I had bought the wrong one the pt. no.s were different, all info I had pointed me to a 801 D unit but the one fitted in my car is a 801 B, (I did,nt know at this time the pt. no. of the motor/DCM was shown in the VCDS log, not until Gaz posted above).
    I think from the VCDS log and the pt. no.s that it brings up in the log it looks like this unit has been replaced before, and I was correct that the 801 D unit would of been fitted from factory.

    Address 46: Central Conv. Labels: 8E0-959-433-MAX.lbl
    Part No: 8H0 959 433 K
    Component: Komfortgerát T3B 5040
    Coding: 07931
    Shop #: WSC 00672
    VCID: 3C717BD92CBDFCF83D4
    Subsystem 1 - Part No: 8H2959802D
    Component: Tõrsteuer.FS BRM 0205
    Subsystem 2 - Part No: 8H2959801B
    Component: Tõrsteuer.BF BRM 3020
    Subsystem 3 - Part No: 8H0959801A
    Component: Tõrsteuer.HL BRM 0002
    Subsystem 4 - Part No: 8H0959802A
    Component: Tõrsteuer.HR BRM 0002

    Items 3 & 4 are the rear window motors/DCM's, and 1 & 2 are the front ones, the 801 B unit seems to be the odd one out, do you not think?
    After finding the discrepancy with the wrong pt. no. I decided to try what Gaz said before I did anything else, unplugged the four plugs to the unit, turned the ignition on, then plugged each one back in turn. tried the window and result all working including my newly fitted puddle lights.
    Thanks again for the Info Gaz, much appreciated.

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Dec 2011
    Location
    Glasgow
    Posts
    195
    I'm glad that you got your door sorted. the modules have this protection where they shut down to protect damage and they have to be reset to enable them again

    I've had a look at one of my scans and here's my module numbers

    Subsystem 1 - Part No: 8H2959802D
    Component: Tõrsteuer.FS BRM 0205

    Subsystem 2 - Part No: 8H2959801D
    Component: Tõrsteuer.BF BRM 0205

    Subsystem 3 - Part No: 8H0959801A
    Component: Tõrsteuer.HL BRM 0003

    Subsystem 4 - Part No: 8H0959802A
    Component: Tõrsteuer.HR BRM 0003

    I guess as you say the module has been replace at some point but that's just a guess

    Glad to have been some help and you got it sorted
    Andy27168 likes this.

    A4 B7 2.0ltr TDI Cabriolet

    Mods
    Puddle lights Illuminated cup holder Cd changer in glove box Interior lighting led upgraded

    Full VCDs

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Mar 2013
    Location
    Southampton
    Posts
    128
    Quick update.
    As I was changing the coding in the RNSE I decided to run a scan the first since resetting my DCM, and I had a load of DTC's on at least three of the scanned control units all down to intermittent communication with the passenger side DCM.
    Because of this I have decided to change my old unit for the one I had just bought, since it looked like I had the wrong one fitted anyway and the one I had bought was the correct one.
    So fingers crossed that should eliminate the intermittent communication.

 

 

Similar Threads

  1. Intermittent door electrics problem?
    By welshwoody in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 28th February 2012, 06:57
  2. Strange electrical problem with my front passenger door.....
    By Az in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 6
    Last Post: 2nd August 2011, 19:32
  3. Strange Door Problem
    By 22imy22 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 9
    Last Post: 15th July 2011, 15:20
  4. Electric Windows/Door Lock Problems
    By donsajid in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 8
    Last Post: 1st September 2010, 18:10
  5. Strange electrical problem
    By Dwarfy in forum A4/S4 forum(B5 Chassis)
    Replies: 2
    Last Post: 3rd April 2010, 16:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO