Sky InsuranceAH Fabrications
Results 1 to 10 of 10
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    13

    Question Audi A4 Soft Top problem

    Hi there,

    Just bought a A4 3.0 TDI quattro on a 57 plate and the roof would not close earlier today.

    When I tested the car everything worked fine, i bought it private so can't go back.....

    There was no warning signs, and I checked the fuse to be ok. I manually open the roof but found it a struggle to close on my own so put it back in. I tried to close the roof again it worked ok?

    Do you think this could have been a one off and does anyone have any experience with soft tops not closing?

    Thanks and look forward to hearing from you

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Norfolk
    Posts
    66
    I had the same thing with mine, same car too.

    It was the soft top position sensor, now works perfectly. Do you have vcds? where are you located?

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    13
    Thanks for reply.

    What is VCDS and I live in Gloucester

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Norfolk
    Posts
    66
    VCDS is the audi/vw diagnostic program that will find all the fault codes.

    From there you can find any issues and parts to fix. I was down in Worcester last weekend and i have VCDS. You just need someone to scan your car to find out.

  6. #5
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,988
    they sometimes go out of sync
    so by opening and closeing with the tool in the dash resets the roof
    i wouldnt worry if its working

  7. #6
    g12
    Neutral

    Status
    Offline
    Join Date
    Aug 2006
    Posts
    40
    I doubt it'd be a sensor. Its happened to mine before - would open fine, but then wouldnt close, or would open only to unlock the top and not move any further.

    I fixed this by resetting it via VAGCOM (restore defaults), then to readapt its settings by opening/closing the hood manually 3 times (procedures on the forums somewhere).

    I'd do that before changing any sensors!

  8. #7
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leicester, United Kingdom, United Kingdom
    Posts
    317
    Quote Originally Posted by Evans94 View Post
    Hi there,

    Just bought a A4 3.0 TDI quattro on a 57 plate and the roof would not close earlier today.

    When I tested the car everything worked fine, i bought it private so can't go back.....

    There was no warning signs, and I checked the fuse to be ok. I manually open the roof but found it a struggle to close on my own so put it back in. I tried to close the roof again it worked ok?

    Do you think this could have been a one off and does anyone have any experience with soft tops not closing?

    Thanks and look forward to hearing from you
    Get the codes read using vagcom, if there are no codes after resetting chances are its the brushes in the motor sticking. Ive wrote a guide on how to solve this

    Audi A4 Cabriolet Soft Top/ Roof / Hood Motor Repair Guide

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leicester, United Kingdom, United Kingdom
    Posts
    317
    Quote Originally Posted by g12 View Post
    I doubt it'd be a sensor. Its happened to mine before - would open fine, but then wouldnt close, or would open only to unlock the top and not move any further.

    I fixed this by resetting it via VAGCOM (restore defaults), then to readapt its settings by opening/closing the hood manually 3 times (procedures on the forums somewhere).

    I'd do that before changing any sensors!
    Hi, this is caused by the brushes in the motor sticking in their carriers and causing arcing with the commutator, this leads to poor contact. I've just posted a link to a guide how to solve this

  10. #9
    g12
    Neutral

    Status
    Offline
    Join Date
    Aug 2006
    Posts
    40
    Cheers@VagPro

    I read your guide when I had problems with mine (3 months back). I didn't think it was this as my car had only done 15K miles which is why I did what I did and thankfully its been working since.

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    13
    Poentiometer was replaced today. All good.

 

 

Similar Threads

  1. Audi A4 Cabriolet Soft Top/ Roof / Hood Motor Repair Guide
    By VagPro in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 456
    Last Post: 1 Day Ago, 17:15
  2. Soft top problem
    By plasmaduck in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 13
    Last Post: 14th February 2014, 13:11
  3. Audi TT Soft top enhancement detail
    By butler2.8i in forum Detailing
    Replies: 7
    Last Post: 21st May 2012, 23:57
  4. HI from the VW man looking for an Audi Soft-top
    By Ricey155 in forum The Welcome Section
    Replies: 3
    Last Post: 16th July 2009, 13:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO