Chris NottAH Fabrications
Results 1 to 6 of 6
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    North Wales
    Posts
    206

    oil level sensor faulty ?

    hi,

    My oil level warning light keeps coming on despite the oil level being on just about max.

    Hopefully it's a faulty sensor - anyone changed one of these and is it a difficult job ?

    I'm planning on changing the oil in the next week or two also.

    Thanks

    2.0 TDI 170 2007

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    CHEZ's Avatar
    moderately amusing

    Status
    Online
    Join Date
    Jul 2011
    Location
    just about, right here!
    Posts
    3,753
    is it the yellow level warning or the red warning?


  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    North Wales
    Posts
    206
    Quote Originally Posted by CHEZ View Post
    is it the yellow level warning or the red warning?
    it's yellow warning light

  5. #4
    CHEZ's Avatar
    moderately amusing

    Status
    Online
    Join Date
    Jul 2011
    Location
    just about, right here!
    Posts
    3,753
    if your due a service anyway, personally i would monitor it after the oil change imo.
    it could be that the oil is a bit thin and dirty, and possibly low as the dip sticks on these are a nightmare to read!
    i would put tippex on your dip stick and check the level against the white of the tippex as it might be actually low!
    if low, remember its only 500ml between min and max so dont overfill!
    remember also, oil consumption is normal (as long as not excessive) and regular top ups are needed on these engines as they dont hold much oil!
    a couple of times mine has flashed yellow so i always carry some oil in the boot!
    its when it flashes red when you need to worry about mate! and stop the engine straight away! and call the AA!


  6. #5
    i_786_i's Avatar
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    57
    Hi,

    I have a B7 2.0TDI 2006 and had to replace my sensor 5months ago. Oil Min sensor displays after a while driving, lifting the bonnet will reset, but will display again after few miles (I wrote an article here about this)

    Check the dipstick to confirm - if oils fine then most likely sensor is faulty. Easy to replace (located on sump pan near sump nut) - ideally replaced when changing oil.

    5months later - no error again and no loss of oil either

  7. #6
    Luke2.0tdi2006's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    West London, U.K.
    Posts
    181
    Yep, I've had the same problem on my 2.0 a4 avant '06, just replaced it last Wednesday, very very easy to replace however like someone else said you would probly wanna combine it with a service/oil change as you will need to drop all your oil to replace it.
    touch wood all seems to be fine so far!
    good luck

 

 

Similar Threads

  1. Oil level sensor problem ?
    By luis.filipe in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 9
    Last Post: 22nd April 2011, 22:32
  2. Oil level sensor
    By ianysm in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 21st January 2010, 22:14
  3. Sump oil level sensor conversion
    By lucksta in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 19th April 2009, 20:46
  4. Oil Level Sensor on Early S3's?
    By metricspaces in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 27th February 2009, 16:08
  5. Replies: 1
    Last Post: 17th August 2007, 23:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO