EM TuningVolks Autos
Results 1 to 8 of 8
  1. #1
    Spencer13's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Leeds Uk
    Posts
    10

    help with my ecu code p0601

    hi everyone, having loads of problems with my car, ecp light on with mil on

    was told by independant audi that my ecu was knackered so i got another used ecu with same part numbers

    installed new ecu after sending old and new off to some guy for recoding to my car, when put on car lights still illuminated but code coming back for p0106 which showed absolute pressure, i installed a new map sensor but problem code is still there, iv reset lights but after turning ignition off and restarting the epc comes back on, mil not on until the 3rd start up.

    Just had elm code reader on again and now its showing old code of p0601 internal check sum

    where do i go from here? is there a common problem or is it a flash problem that could fix this? hate stealerships but i seemed to think the independant audi was trying to rip my arse out too!

    any help would be appreciated, 2.0 tfsi quattro a4

    thanks
    Mines an Audi!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    jjmurphy21187's Avatar
    Tiptronic

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Nottingham, UK
    Posts
    749
    Can't really help with this. Although when my HP fuel pump on my old 2.5tdi reprogramming it to the ECU etc was a massive ball-ache and ended up costing the best part of £2k in labour including a trip on a flat-bed from the specialist to the main dealer.

    From personal experience I hope you manage to get this sorted with minimal issues/cost!

    Car: 2007 A4 3.0TDI Quattro S-Line Cabriolet
    Mods: Pipercross Panel Filter, Smarttop, LED Plate Bulbs, LED Interior Bulbs, Blue LED Needles, Remap, EGR Delete, Custom Stainless Exhaust (4" Slash Tips), Cupra-R Splitter, Embossed Number Plates, 19" BBS CH Reps & Vredestein Ultra Sessanta's, 12mm TPI Spacers, -30m H&R Springs, MTEC Black Edition Brakes (Dimpled & Grooved), Mintex Pads, RS4 RARB, Vibe Square Subwoofer in Ski-pass & Alpine MRP-350 Amp

    VCDS - PM for details (East Midlands)

  4. #3
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    P0601
    16985/P0601/001537 - Internal Control Module: Memory Check Sum Error

    Possible Symptoms

    • MIL illuminated
    Possible Causes

    • Engine Control Unit (ECU) defective
    • Flash ROM (used in aftermarket "chips") defective
    • Low Voltage
    Possible Solutions

    • Replace ECU
    • Contact aftermarket chiptuner for repair of their chip
    • Check and test Battery and Charging system
    Special Notes

    • When found in 1.8T:
    • When found in 2.0l TFSI (BPJ, BPY, BWA, BWJ, BYK), check/update Engine Control Module Software Version
      • Audi A3 (8P), A4 (8E/8H) or Audi A6 (4F):
        • North American Region (NAR): TSB 2017905/24-08-82
        • Rest of World (RoW): Campaign 24H8 (2013846) or TPI 2012760
      • Seat Altea (5P) or Leon (1P), see Campaign 24S1 (2014557).
      • Skoda Octavia (1Z), see Campaign 24K5 (2014942).
      • Volkswagen Models:
        • Rest of World (RoW): TPI 2014494
        • North American Region (NAR): TSB 2014077/01-09-18 or 24M2/O3 RVU (may be covered under warranty)
    • When found in Audi V8 and V10 FSI engines see TSBs:
      • Pass-Thru TSB # 24-08-31 (2017905/1)
      • Audi TSB # 24-08-82 (2017905/4)
    Retrieved from "16985/P0601/001537 - Ross-Tech Wiki"
    Category:





    Categories

    Meta


  5. #4
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    P0106
    16490/P0106/000262 - Manifold / Barometric Pressure Sensor (G71) / (F96): Implausible Signal

    Possible Symptoms

    • Erratic Idle
    Possible Causes

    • Wiring and/or Connections from/to Manifold/Barometric Pressure Sensor (G71)/(F96) faulty
    • Leak in Air Intake and/or Exhaust
    • Manifold/Barometric Pressure Sensor (G71)/(F96) faulty
    • Engine Control Module faulty
    Possible Solutions

    • Check Engine Control Module Software Version
      • See Special Notes for Details
    • Check Timing
      • See Special Notes for Details
    • Check Wiring and/or Connections from/to Manifold/Barometric Pressure Sensor (G71)/(F96)
    • Check for Leak in Air Intake and/or Exhaust
    • Check/Replace Manifold/Barometric Pressure Sensor (G71)/(F96)
    • Check/Replace Engine Controle Module
    Special Notes

    • On certain smaller Engines we've seen cases where a buggy Engine Control Unit Firmware can cause these fault codes, additionally there are known Problems with the Timing Chain Tensioners which can also result in these fault codes. Please refer to the related TPL/TSB for more instructions.
    Retrieved from "16490/P0106/000262 - Ross-Tech Wiki"
    Category:





    Categories

    Meta


  6. #5
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    The G71 sensor is in the ECU in some cars whats your engine code ?
    looks like you have bought a dodgey ECU or it needs updateing.

  7. #6
    Spencer13's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Leeds Uk
    Posts
    10
    Thanks, iv checked out the above on ross tek and like I say iv put in a new map sensor/thrust boost
    the new ecu 2nd hand part is showing the same code as the first ecu was so I'm thinking it's some kind of problem other than ecu being knacked! Would the car pass an mot with these 2 lights showing? Car runs really smooth with the new ecu with no problems apart from mil light and epc, the old ecu was using too much petrol and rough idling on cold starts but still car run smooth
    Mines an Audi!!

  8. #7
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    but it could still need the audi update to cure it
    has the new ecu or old 1 had any updates you can check by calling audi
    also the map sensor/thrust boost is really nothing to do with the codes
    have you had the timeing checked ?

  9. #8
    Spencer13's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Leeds Uk
    Posts
    10
    No mate iv not checked if it's had an update at any point! I think maybe that's best thing for me to do first!

    Not had the timing checked either, threw code p0106 absolute pressure/ range performance so that's why I threw in a new map sensor
    Mines an Audi!!

 

 

Similar Threads

  1. Help Please: Abs Ecu Coding and help with ecu.
    By asasprey in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 30th August 2011, 18:02
  2. where's the n80 and help with vag-com codes please.....
    By shufti in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 5
    Last Post: 9th August 2007, 14:18
  3. Help with recorded fault code
    By Damian s in forum A4/S4 forum(B5 Chassis)
    Replies: 1
    Last Post: 8th March 2007, 18:33
  4. helps with some vag codes!!!!!
    By technics100 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 12th November 2005, 19:46
  5. Help with a part code please?
    By Add7 in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 3rd September 2004, 16:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO