Monster MotorsportChris Nott
Results 1 to 4 of 4
  1. #1
    3rd Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    596

    Angry Flashing glowplug light, loss of power, eps light on limp mode etc...

    Apologies if this is a repeat post which im sure this issue maybe..but im on a mobile and cant really do thorough searches on forums on a mobile phone at 3:30 am on the side of a dual carriageway!

    cutting most of this short ive been told by an AA tow driver that it maybe a brake light switch.
    Can a simple switch really cause all this ****?? :

    Loss of power
    Glow plug flashing light
    Limp Mode/no acceleration
    ESP light
    brake lights permanently on ??

    I thought my turbo had gone initially...but nothing is smoking out the back.
    , none of the tail lights or healights are dimming so i dont think it would be the alternator. I will obv have it run through a diagnostics later on this morning by AA first off to find out what it is bringing up code wise if anything... but ffs if it turns out to be brake light switch why can't audi spend more of their money on making sure simple things dont break and cause electrical chaos!

    Im hoping it is that and not some failing ECU problem etc

    I love audi but i also hate them.
    Current - 2006 B7 A4 S Line Saloon 2.0T TFSI Special Edition 220bhp, 18" TTRS Rotors, Ferrari Red front/rear Calipers, 3.5" Powerflow tailpipes, BOSE, Cupra R splitter, Chrome grille slats, S4 Mirror covers, Black/silver leather interior, Debadged, Arm rest delete, LED plate lights, Dectane LED Red/Crystal tail lights. remap/diverter valve soon

    Gone - 2005 B7 A4 SE TDI Avant 2.0 140bhp

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    3rd Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    596
    Well it was towed to a garage and the core read came up with about 9 codes lol, all sorts of rubbish. Brake light switch being one and it looks like may possibly be an ECU error or just electrical short somewhere. boo
    Current - 2006 B7 A4 S Line Saloon 2.0T TFSI Special Edition 220bhp, 18" TTRS Rotors, Ferrari Red front/rear Calipers, 3.5" Powerflow tailpipes, BOSE, Cupra R splitter, Chrome grille slats, S4 Mirror covers, Black/silver leather interior, Debadged, Arm rest delete, LED plate lights, Dectane LED Red/Crystal tail lights. remap/diverter valve soon

    Gone - 2005 B7 A4 SE TDI Avant 2.0 140bhp

  4. #3
    PetrolDave's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,470
    Quote Originally Posted by Av4nt View Post
    ive been told by an AA tow driver that it maybe a brake light switch.
    Can a simple switch really cause all this ****??
    Yup, check the brake switch and both brake light bulbs.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  5. #4
    3rd Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    596
    just an update for any future readers. Garage called this morning to say that the electrics had shorted out due to a wiring harness being melted. Melted by.. i think he said the turbo pipe of somesort and had shorted out against the pipe after melting through the wire housing. Handy...

    I am quite crap at names for most things as a learner on car parts under the bonnet lol so ill post a pic up later if thats indeed all it was to show the offending pipe!
    Current - 2006 B7 A4 S Line Saloon 2.0T TFSI Special Edition 220bhp, 18" TTRS Rotors, Ferrari Red front/rear Calipers, 3.5" Powerflow tailpipes, BOSE, Cupra R splitter, Chrome grille slats, S4 Mirror covers, Black/silver leather interior, Debadged, Arm rest delete, LED plate lights, Dectane LED Red/Crystal tail lights. remap/diverter valve soon

    Gone - 2005 B7 A4 SE TDI Avant 2.0 140bhp

 

 

Similar Threads

  1. EPC Light on, Loss of power !!!
    By Digger1 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 9
    Last Post: 8th April 2011, 01:05
  2. Glow plug light and complete power loss
    By norm29 in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 21st February 2011, 12:15
  3. Replies: 2
    Last Post: 25th November 2010, 16:00
  4. Knocking sound, loss of power and ECU light on
    By Stoosh in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 6th November 2009, 21:21
  5. A4 Help Needed!! EPC light loss of power
    By randemo in forum General Technical / How To
    Replies: 1
    Last Post: 27th February 2008, 15:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO