EM TuningMonster Motorsport
Results 1 to 26 of 26
Like Tree1Likes
  • 1 Post By Oddie

Thread: sticky for turbo cleaning

  1. #1
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87

    sticky for turbo cleaning

    does anyone know if there is a link for cleaning the turbo on b7 2.0 tdi?
    thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Quote Originally Posted by hubbo1 View Post
    does anyone know if there is a link for cleaning the turbo on b7 2.0 tdi?
    thanks
    I would appreciate this as well, looking to do this to mine

  4. #3
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    Un-Sticking Your TDi VNT Turbo Vanes.....
    found this,it shouldnt be to different-gonna have a play at the weekend

  5. #4
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Quote Originally Posted by hubbo1 View Post
    Where abouts are you pal ? Are you going to use the Mr muscle stuff ?

  7. #6
    rowdyboy's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Derbyshire
    Posts
    802
    If you YouTube "Innotec turbo clean", it tells you exactly how to clean the turbo. Looking at it, you could use any cleaning solvent, safely to do the same thing, for a lot less than the £40 the kit costs.
    3.0 Tdi Q A4 Avant S-Line Dolphin Grey
    RNS-E retrofitted

  8. #7
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    oddie
    yes i am going to use mr muscle-and i live in great yarmouth

  9. #8
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    Pictures by hubbo36 - Photobucket
    think i have done this picture thing right!?
    just cleaned turbo with mr muscle-wow! cant believe it is the same car! no limp mode,more responsive!

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Hi Mate. Is there any chance you could write up some instructions ? There some instructions knocking about for a B6 but i haven't seen any for a B7 yet. I am looking at doing mine asap but i am a little bit apprehensive incase i make a mess of something !

  11. #10
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    ok oddie here goes
    remove the air intake-held in by 2 philips screws on the slam panel,this will come out in 2 parts-they are push fit.
    then remove jubilee clip from large rubber pipe on the air box itself.
    then remove the sensor plug from the maf on the air box and unclip the wire attached to the airbox.
    the air box needs to come out next,its held in by a plastic insert through a rubber grommet into the inner wing,when this is removed just give it a tug upwards-it is only sat in 2 rubber seats underneath.
    now you should have clear access to the turbo outlet/exhaust, 3x12mm nuts to remove-i got 2 with a ratchet and socket and 1 with a ring spanner plenty of wd 40!, then you should be able to seperate the turbo/exhaust-bit of pulling and the use of a large screwdriver for levering(dont put anything in the turbo!).
    once this is done you can tape up the open end of the turbo,poke a small hole in it and squirt some mr muscle in,leave for an hour and repeat-refitting is the reverse.
    im sure there will be some other tips and comments but this is how i did mine and it worked.

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Fantastic mate, thank you very much ! I have actually been out there this morning about 30 minutes ago and have got everything removed. I have sprayed the 3 bolts with WD40 so i am just trying to give it as much time as possible to work its magic, don't fancy snapping any bolts off !

    Did you notice a difference straight away in yours, and has it gone into limp mode since you did it ?

    Thanks mate

  13. #12
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    i drove it as soon as i had it back together-let it get up to temp before i gave it some wellie,no limp mode as yet,and it feels so much more responsive.

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Good work ! I hope it sorts mine out. Have you cleaned your EGR valve out ? I keep meaning to do mine but haven't got round to doing it yet, i imagine it is going to be horrible after 104,000 miles !

  15. #14
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87

    Smile

    yes i have done the egr-dont think it made much difference though,mines on 119000 and tbh wasnt as bad as i thought it was gonna be,i think alot depends on driving ie short journeys and fuel quality.
    why dont you do it today while youre under the bonnett?

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    How difficult was that to do ? Easier or more difficult than that turbo ?

  17. #16
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    it was no worse than doing the turbo-there is a step by step guide on here as well

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Ok. thanks for taking the time to get back to me mate, much appreciated.

  19. #18
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    more than welcome

  20. #19
    rowdyboy's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Derbyshire
    Posts
    802
    If its not a new fuel filter for a while, it's worth changing that. No point having lots of air but not enough fuel flow. They get quite clogged.
    3.0 Tdi Q A4 Avant S-Line Dolphin Grey
    RNS-E retrofitted

  21. #20
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    So.... it worked !! I sprayed the cleaner into the turbo and left it for about an hour to dwell and then took it for a blast. It felt awful at first, almost like i was trying to rev through treacle, maybe this was the cleaner or all the carbon hanging around in there ? As soon as i got up the road it felt miles better. Once it had warmed up i gave it a really good thrashing and it drove really well, no limp mode !

    Hubbo, how much of the cleaner did you put in ? I wasnt able to get loads in because it just foamed up straight away. And how did you remove that nut on the right hand side nearest the engine ? That was a right ******* to do, took me ages !
    pistonripper likes this.

  22. #21
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    nice one! carry on like this and we wont need the dealers or indy garages at all, lol!
    used very little cleaner,like you say it does foam up.
    yes that nut was a little tricky,i used a short ring spanner.
    glad it worked for ya! been out and about today and fingers crossed no limp mode.

  23. #22
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    I had to use a hammer and a long bar in conjunction with the ring spanner on that tricky nut, it was a nightmare ! I think i am going to apply some more in about a months time or so. I am addicted to Mr Muscle now haha.

    How do you remove the air box fully ? I managed to separate that rubber grommit that goes into the wing but still couldn't remove the box. Once you separate the grommit and pull the long bit out of the middle of it what do you do then ?

  24. #23
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    North Wales
    Posts
    201
    Was there any particular driving situation that made your cars go into limp mode and did you get any error codes retrieved ? I'm only asking as mine did this about 2 weeks ago and I'm wondering whether to clean the turbo and egr. With me I was in cruise control doing about 80 when it had to accelerate to go up a hill. Error code said it was an underboost ??

    Thanks

  25. #24
    1st Gear

    Status
    Offline
    Join Date
    Nov 2011
    Posts
    171
    Quote Originally Posted by mm707 View Post
    Was there any particular driving situation that made your cars go into limp mode and did you get any error codes retrieved ? I'm only asking as mine did this about 2 weeks ago and I'm wondering whether to clean the turbo and egr. With me I was in cruise control doing about 80 when it had to accelerate to go up a hill. Error code said it was an underboost ??

    Thanks
    Hi pal. Mine was doing it on the motorway in 4th or 5th. I had to drive it fairly hard to get it to go into limp mode but it always did it around 3k RPM. I never got any warning lights but i had it serviced yesterday and the mechanic said he scanned it and it had an over boost fault code. I may be wrong but i think under boost is normally caused by something else ? Sorry i can't help you much mate

  26. #25
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    once you have removed top and bottom hose and removed the maf plug and wiring from the air box you should just be able to wiggle/pull the air box out,no need to rmove filter.

  27. #26
    Neutral

    Status
    Offline
    Join Date
    May 2012
    Posts
    87
    yep mine had overboost code as well,no warning lights

 

 

Similar Threads

  1. looking for turbo swap insight
    By a427tq in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 1
    Last Post: 19th November 2007, 20:15
  2. new clutch for turbo conversion?
    By dappadan786 in forum Tuning
    Replies: 0
    Last Post: 31st July 2007, 14:55
  3. Advice please! Getting ready for first clean.
    By doeboy in forum Detailing
    Replies: 18
    Last Post: 19th February 2007, 16:42
  4. Part numbers for turbos required
    By clcollins in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 21st December 2005, 14:45
  5. Sticky for A4 FAQ?
    By Kevint in forum A4/S4 forum(B5 Chassis)
    Replies: 2
    Last Post: 12th May 2005, 13:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO