Chris NottVolks Autos
Results 1 to 4 of 4

Thread: ECU Problems

  1. #1
    Spencer13's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Leeds Uk
    Posts
    10

    Cool ECU Problems

    Hi Guys, can anyone help??

    Im the owner of a A4 sline quattro 56 plate 2 litre petrol, iv been driving around with the EPC light on and emissions light for ages.

    My car shows no sign of anything wrong with it apart from it having the lights on the dash or maybe using a bit too much oil.

    I had it looked at by an independant audi in stourton leeds, they said i needed a new ecu then it would need recoding to my car along with a bill for nearly £800 big ones.

    Im one for trying anything myself so went off and found a second hand ecu unit with same part number for £130, now it needs coding to my car! i have some Knowledge of easyobd as iv turned my trouble lights off with it but they always come back on.

    Iv taken the old ecu out and replaced with the donor part but car starts then dies so i put old part back on for now.

    The trouble code is P0610 internal control module mil on, from what iv read or know this means ecu is bad but does anyone know if this can be fixed by reflashing or something similar????

    If my original ecu cant be fixed then does anyone know anyone or anything i can do to get my donor ecu to work???

    Any help is much appreciated as i need this problem fixing at the cheapest price possible(typical tight Yorkshireman)

    Thanks guys
    Spencer
    Mines an Audi!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    carl-1968's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Nottingham
    Posts
    457
    If you are will to travel there is a guy in Nottingham who knows his onions!, pm me for his details, he sorted out my faults and remapped mine in a few hours
    Cheers
    Carl

  4. #3
    Spencer13's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Leeds Uk
    Posts
    10
    Hi Carl, thanks for the message, did you have similar problems and was it the internal control module P0610 code?
    Cheers mate
    Spence
    Mines an Audi!!

  5. #4
    carl-1968's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Nottingham
    Posts
    457
    Just got stuck in the regeneration cycle hence blue smoke and stinking like a BBQ!, the guy sorted it out no problem

 

 

Similar Threads

  1. ECU Problem 58 Plate S3 Sportsback
    By jfairham in forum A3/S3/Sportback (8P Chassis)
    Replies: 1
    Last Post: 4th March 2009, 16:44
  2. audi a6 ecu problem? water in the electrics? any help out there?
    By darby7 in forum General Technical / How To
    Replies: 16
    Last Post: 20th July 2005, 10:31
  3. a6 ecu problem? water in the electrics? any advise out there?
    By darby7 in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 2
    Last Post: 20th July 2005, 00:19
  4. possible ecu problem? water in the car! any help out there....?
    By darby7 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 16th May 2005, 19:53
  5. Replies: 2
    Last Post: 16th May 2005, 19:52

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO