Chris NottMonster Motorsport
Results 1 to 8 of 8

Thread: MFSW problem

  1. #1
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Teesside
    Posts
    327

    MFSW problem

    Im currently having a MFSW retrofitted to my 2005 A4. Im getting it done by a professional but we are having a problem. The lad fitting it is on the case but I thought id throw up the question, you never know........ Im sure the lad will come up with the solution but I still may aswell ask.

    The wheel fits perfect and the guy codes it in but the buttons don't work nor do they light up. I have the correct module ( 8E0953549Q) and slip ring (4E0953541) and I already have cruise control fitted.

    The module has been replaced to see if that was the problem, it wasn't.

    The guy checked the wheel in his car and it works fine.

    The next point of interest is the slip ring. The horn works and the air bag light doesn't come, two signs of a faulty/damaged slip ring i've been told.

    Im sure the guy will figure out whats wrong however if anyone on here has had the same problem or has any suggestions, that would be great.

    I'd rather go back to the guy with suggestions and see if anything works.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,148
    I assume you got a new airbag harness?
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

  4. #3
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Teesside
    Posts
    327
    Yeah, the guy did fit a new harness to the back of the airbag.

  5. #4
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,148
    In that case it does sound like the slip ring, you did get the right slip ring? From memory there should be a letter after the part number.
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

  6. #5
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,148
    Just checked and you need either 4E0953541A or B as they have the 12 pins.
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

  7. #6
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Teesside
    Posts
    327
    Cheers Nathan

  8. #7
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,747
    Yeap cant be much more at fault tbh, only items I can think are slip ring & airbag loom, but if he's tested wheel/bag on his car then obviously the loom is fine, so must be ring with an issue.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  9. #8
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Teesside
    Posts
    327
    He suggested the slip ring so I think that's a good way to go......

    Cheers guys, as always a great help

 

 

Similar Threads

  1. MFSW airbag fitment problem
    By Shane. in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 24th February 2011, 11:52
  2. 2005 A4 with Bluetooth and MFSW question - coding problem?
    By Fireyjack in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 29
    Last Post: 8th January 2011, 15:58
  3. mfsw problem
    By sbhoy17 in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 15th May 2010, 22:44
  4. MFSW fitting & wiring problem
    By k6tyw in forum General Technical / How To
    Replies: 13
    Last Post: 12th December 2008, 16:51
  5. Ooo eck I've got a problem!
    By AlexStanley in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 20th January 2003, 13:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO