Volks AutosAH Fabrications
Results 1 to 4 of 4
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Derby
    Posts
    18

    Turbo lag 2007 B7 2.0 tdi 140bhp

    Hi all

    Hoping someone can help as i have not found a definate answer to this problem.

    Recently remapped my car 1500miles ago and it has been running at its peak...
    Unfortunatly over the last few days i have noticed a power loss and very recently
    it has a huge turbo lag, the turbo still comes in but around 3000rpm and not as strong..

    All turbo pipes have been checked for leaks, everything seems fine, car has been plugged in
    and shows no faults. I have drove with the maf unplugged and it drives exactly the same..


    There is no smoke on start up, and on full throttle just the normal diesel smoke.
    I have also inspected the turbo, the spindle has 1mm movement right and left??
    Information is pointing out to the turbo, but need to make sure if it is the culprit...

    Any feedback will be appriciated
    Thanks in advance...

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Posts
    8
    have you checked the actuator rod to the turbo, i had a similar problem to you and found the lever that the actuator bar connects to was seized solid i had to remove the turbo and strip to fix.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Derby
    Posts
    18
    Thanks for the response,

    Have tried this today with another pipe and blew into it,
    moves freeley up and down

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    Derby
    Posts
    18
    Hi
    This has been resolved, eventually the clutch started to slip and i got this changed as soon as.
    Apparantly even though the clutch was not slipping at the start as it was worn the torque was limited
    and there was at least a 3 second delay before you can feel the turbo come in...
    Has been sorted now happy days...

 

 

Similar Threads

  1. 2007 A6 2.7 TDI Turbo upgrade
    By DobermanUK in forum A6/S6/Allroad forum (C6 Chassis)
    Replies: 1
    Last Post: 28th February 2012, 14:49
  2. Turbo charger - standard 2.0 ltr TDI 140bhp BKD engine
    By tdi-man in forum For Sale/Wanted - Audi Parts
    Replies: 10
    Last Post: 7th October 2011, 13:39
  3. 2.0 TDI 140bhp turbo required
    By ash3435 in forum A3/S3/Sportback (8P Chassis)
    Replies: 5
    Last Post: 23rd March 2011, 23:20
  4. 2.0 TDI 140BHP turbo problems
    By tdisportuk in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 1st April 2009, 20:49
  5. TURBO LAG
    By viper in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 17th October 2003, 08:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO